summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-04-26 20:13:09 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-04-26 20:13:09 +0000
commita56c567f341b5ea376a9459269e8141981261a6b (patch)
treee535573b144f092e615a6ddf9423b92760217303 /media-libs/gstreamer
parentInitial commit. Ebuild submitted by Todd Wright (Bug #1835). (diff)
downloadhistorical-a56c567f341b5ea376a9459269e8141981261a6b.tar.gz
historical-a56c567f341b5ea376a9459269e8141981261a6b.tar.bz2
historical-a56c567f341b5ea376a9459269e8141981261a6b.zip
adding gstreamer to portage
Diffstat (limited to 'media-libs/gstreamer')
-rw-r--r--media-libs/gstreamer/ChangeLog34
-rw-r--r--media-libs/gstreamer/files/digest-gstreamer-0.3.41
-rw-r--r--media-libs/gstreamer/gstreamer-0.3.4.ebuild63
3 files changed, 98 insertions, 0 deletions
diff --git a/media-libs/gstreamer/ChangeLog b/media-libs/gstreamer/ChangeLog
new file mode 100644
index 000000000000..9e00d82501d0
--- /dev/null
+++ b/media-libs/gstreamer/ChangeLog
@@ -0,0 +1,34 @@
+# ChangeLog for media-libs/gstreamer
+
+* gstreamer-0.3.4 (26 Apr 2002)
+ 26 Apr 2002; Spider <spider@gentoo.org> gstreamer-0.3.4.ebuild
+ libtoolize
+ version bump
+ add sysconfdir
+ fix use lines and documentation
+
+
+* gstreamer-0.3.3-r3 (3 Apr 2002)
+
+ 3 Apr 2002; A. Baguinski <artm@v2.nl> gstreamer-0.3.3-r3.ebuild
+
+ added gtk-doc dependancy if USE contains "perl", need some more work on
+ that (some more dependancies and different USE word).
+
+ fixed gtkdoc-fixxref issue (was trying to write outside DESTDIR), added
+ installation of documentation (not everything, dunno what to do with
+ examples and docs/random, they contain the whole trees of files and dodoc
+ doesnt do recursive, neither does doins). some docs are gzipped, others -
+ not.
+
+* gstreamer-0.3.3-r2 (28 Mar 2002)
+
+ 28 Mar 2002; A. Baguinski <artm@v2.nl> gstreamer-0.3.3-r2.ebuild
+
+ Added gst-register to pkg_postinst
+
+* gstreamer-0.3.3-r1 (28 Mar 2002)
+
+ 28 Mar 2002; A. Baguinski <artm@v2.nl> gstreamer-0.3.3-r1.ebuild ChangeLog
+
+ Just started
diff --git a/media-libs/gstreamer/files/digest-gstreamer-0.3.4 b/media-libs/gstreamer/files/digest-gstreamer-0.3.4
new file mode 100644
index 000000000000..dcf9ce91cc3c
--- /dev/null
+++ b/media-libs/gstreamer/files/digest-gstreamer-0.3.4
@@ -0,0 +1 @@
+MD5 7acf59cf10a3714d2bd4ac28c0512f68 gstreamer-0.3.4.tar.gz 1186741
diff --git a/media-libs/gstreamer/gstreamer-0.3.4.ebuild b/media-libs/gstreamer/gstreamer-0.3.4.ebuild
new file mode 100644
index 000000000000..d108b6cff7e0
--- /dev/null
+++ b/media-libs/gstreamer/gstreamer-0.3.4.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Artem Baguinski <artm@v2.nl>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.4 2002/03/12 16:05:09 tod Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Streaming media framework"
+SRC_URI="http://prdownloads.sourceforge.net/gstreamer/${P}.tar.gz"
+HOMEPAGE="http://gstreamer.sourceforge.net"
+
+# required packages
+# there are many many optional libraries. features are compiled if the libraries
+# are present. most optional libraries are from gnome.
+DEPEND=">=dev-libs/glib-2.0
+ >=dev-libs/libxml2-2.4
+ >=dev-libs/popt-1.5
+ doc? ( >=dev-util/gtk-doc-0.9
+ media-gfx/transfig
+ dev-libs/libxslt
+ app-text/xmltex
+ app-text/xpdf
+ app-text/ghostscript )"
+
+src_compile() {
+ local myconf
+ use doc && myconf="${myconf} --enable-docs-build" || myconf="${myconf} --disable-docs-build"
+
+ # gtkdoc-fixxref should do its stuff in DESTDIR
+ pushd docs/libs
+ cat Makefile.am | sed 's/\(gtkdoc-fixxref.*html-dir=\)/\1$(DESTDIR)/' > Makefile.am.new
+ mv Makefile.am.new Makefile.am
+ popd
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ ${myconf} \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ # gtkdoc will install stuff in a directory with wrong name (wrong after my opinion)
+ # fix it:
+ mv ${D}/usr/share/doc/${P} ${D}/usr/share/doc/${PF}
+ # now have to clean after gtkdoc-fixxref
+ prepalldocs
+ dodoc AUTHORS COPYING COPYING.LIB INSTALL README RELEASE REQUIREMENTS TODO
+ # will do these later - must do some recursive stuff about it... (with find???)
+ # docs/random/*
+ # examples/*
+ # get all those html manuals and stuff like that.
+ dohtml -r docs/fwg/gts-plugin-writers-guide
+ dohtml -r docs/gst/html
+ dohtml -r docs/manual/gstreamer-manual
+}
+
+pkg_postinst () {
+ gst-register
+}