summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2011-04-13 12:32:41 +0000
committerMart Raudsepp <leio@gentoo.org>2011-04-13 12:32:41 +0000
commit723adb3d559c62506af13872c1af3d122bbd0dfb (patch)
treed7c64f77583828d5fac1a9f9d9947e8b87ca8952 /media-libs/gnonlin/gnonlin-0.10.17.ebuild
parentFix building with --as-needed wrt #363479 by Diego Elio Pettenò <flameeyes@g... (diff)
downloadhistorical-723adb3d559c62506af13872c1af3d122bbd0dfb.tar.gz
historical-723adb3d559c62506af13872c1af3d122bbd0dfb.tar.bz2
historical-723adb3d559c62506af13872c1af3d122bbd0dfb.zip
Version bump. Documentation and debugging fixes
Package-Manager: portage-2.2.0_alpha10/cvs/Linux x86_64
Diffstat (limited to 'media-libs/gnonlin/gnonlin-0.10.17.ebuild')
-rw-r--r--media-libs/gnonlin/gnonlin-0.10.17.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/media-libs/gnonlin/gnonlin-0.10.17.ebuild b/media-libs/gnonlin/gnonlin-0.10.17.ebuild
new file mode 100644
index 000000000000..e003d730b4f3
--- /dev/null
+++ b/media-libs/gnonlin/gnonlin-0.10.17.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gnonlin/gnonlin-0.10.17.ebuild,v 1.1 2011/04/13 12:32:41 leio Exp $
+
+DESCRIPTION="Gnonlin is a set of GStreamer elements to ease the creation of non-linear multimedia editors."
+HOMEPAGE="http://gnonlin.sourceforge.net"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0.10"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND=">=media-libs/gstreamer-0.10.30
+ >=media-libs/gst-plugins-base-0.10.30"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( || (
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/gtk-doc-1.3 ) )
+ test? ( dev-libs/check
+ media-libs/gst-plugins-good )" # videomixer
+
+src_configure() {
+ econf \
+ $(use_enable doc gtk-doc) \
+ $(use_enable doc docbook)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README RELEASE
+
+ # For some reason, make install doesn't do this
+ if use doc; then
+ local htmldir="/usr/share/gtk-doc/html"
+ cd "${S}/docs/libs/html"
+ gtkdoc-rebase --html-dir=${htmldir} || die "gtkdoc-rebase failed"
+ insinto "${htmldir}/gnonlin"
+ doins "${S}"/docs/libs/html/* || die "doins docs failed"
+ fi
+}