summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-18 14:42:28 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-04-18 14:42:28 +0000
commit1162c181b8b4e8b4917f0125484995c101229768 (patch)
tree4ccf89c4bd047727502cc3be4a5ca5d913cd24ee /media-libs/gle/gle-3.0.1-r2.ebuild
parent- added back 2.0.54-r1 but moved the patches into a tarball (diff)
downloadhistorical-1162c181b8b4e8b4917f0125484995c101229768.tar.gz
historical-1162c181b8b4e8b4917f0125484995c101229768.tar.bz2
historical-1162c181b8b4e8b4917f0125484995c101229768.zip
Replace malloc.h inclusions with stdlib.h inclusions to build on FreeBSD and OSX. Bug #130340.
Package-Manager: portage-2.1_pre7-r5
Diffstat (limited to 'media-libs/gle/gle-3.0.1-r2.ebuild')
-rw-r--r--media-libs/gle/gle-3.0.1-r2.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/media-libs/gle/gle-3.0.1-r2.ebuild b/media-libs/gle/gle-3.0.1-r2.ebuild
index 62cc6cc15acc..ad19caaafb97 100644
--- a/media-libs/gle/gle-3.0.1-r2.ebuild
+++ b/media-libs/gle/gle-3.0.1-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/gle-3.0.1-r2.ebuild,v 1.28 2005/07/02 01:09:07 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gle/gle-3.0.1-r2.ebuild,v 1.29 2006/04/18 14:42:28 flameeyes Exp $
DESCRIPTION="GL extrusion library"
HOMEPAGE="http://www.linas.org/gle"
@@ -15,6 +15,15 @@ DEPEND="virtual/opengl
virtual/glu
virtual/glut"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Replace inclusion of malloc.h with stdlib.h as needed by Mac OS X and
+ # FreeBSD.
+ sed -i -e 's:malloc.h:stdlib.h:g' ${S}/src/*
+}
+
src_compile() {
econf --with-x || die
emake || die