summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2012-10-22 14:15:11 +0000
committerThomas Sachau <tommy@gentoo.org>2012-10-22 14:15:11 +0000
commit7497231eff79a44997ec0c5530c220f50e2d4714 (patch)
tree67c355857cd94a65813b5abb36230d60328d9509 /media-libs/edje/edje-1.7.1.ebuild
parentAssign spidermonkey directly to mozilla herd (diff)
downloadhistorical-7497231eff79a44997ec0c5530c220f50e2d4714.tar.gz
historical-7497231eff79a44997ec0c5530c220f50e2d4714.tar.bz2
historical-7497231eff79a44997ec0c5530c220f50e2d4714.zip
Version bump, drop old
Package-Manager: portage-2.2.0_alpha141-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x35899067
Diffstat (limited to 'media-libs/edje/edje-1.7.1.ebuild')
-rw-r--r--media-libs/edje/edje-1.7.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/edje/edje-1.7.1.ebuild b/media-libs/edje/edje-1.7.1.ebuild
new file mode 100644
index 000000000000..f0fe27890d0f
--- /dev/null
+++ b/media-libs/edje/edje-1.7.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/edje/edje-1.7.1.ebuild,v 1.1 2012/10/22 14:15:01 tommy Exp $
+
+EAPI=1
+
+inherit enlightenment
+
+DESCRIPTION="graphical layout and animation library"
+HOMEPAGE="http://www.enlightenment.org/pages/edje.html"
+SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug +cache static-libs vim-syntax"
+
+DEPEND="dev-lang/lua
+ >=dev-libs/eet-1.7.0
+ >=dev-libs/eina-1.7.0
+ >=dev-libs/embryo-1.7.0
+ >=media-libs/evas-1.7.0
+ >=dev-libs/ecore-1.7.0"
+RDEPEND=${DEPEND}
+
+src_compile() {
+ export MY_ECONF="
+ $(use_enable cache edje-program-cache)
+ $(use_enable cache edje-calc-cache)
+ $(use_enable !debug amalgamation)
+ $(use_with vim-syntax vim /usr/share/vim)
+ "
+ enlightenment_src_compile
+}
+
+src_install() {
+ if use vim-syntax ; then
+ insinto /usr/share/vim/vimfiles/syntax/
+ doins data/edc.vim || die
+ fi
+ dodoc utils/{gimp-edje-export.py,inkscape2edc} || die
+ enlightenment_src_install
+}