summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-09-01 08:50:02 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-09-01 08:50:02 +0000
commit9ac615ad3ba6ac79e36f4bad48ee89dab8446b17 (patch)
tree414fab468d9f99b79f2035404da1caa21d190059 /media-libs/babl/babl-0.1.0.ebuild
parentremove old (diff)
downloadhistorical-9ac615ad3ba6ac79e36f4bad48ee89dab8446b17.tar.gz
historical-9ac615ad3ba6ac79e36f4bad48ee89dab8446b17.tar.bz2
historical-9ac615ad3ba6ac79e36f4bad48ee89dab8446b17.zip
Bump to 0.1.0, fixes half of #281264
Package-Manager: portage-2.2_rc40/cvs/Linux x86_64
Diffstat (limited to 'media-libs/babl/babl-0.1.0.ebuild')
-rw-r--r--media-libs/babl/babl-0.1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/media-libs/babl/babl-0.1.0.ebuild b/media-libs/babl/babl-0.1.0.ebuild
new file mode 100644
index 000000000000..5d363ab5dfe6
--- /dev/null
+++ b/media-libs/babl/babl-0.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/babl/babl-0.1.0.ebuild,v 1.1 2009/09/01 08:50:02 patrick Exp $
+
+EAPI="2"
+
+inherit eutils autotools
+
+DESCRIPTION="A dynamic, any to any, pixel format conversion library"
+HOMEPAGE="http://www.gegl.org/babl/"
+SRC_URI="ftp://ftp.gtk.org/pub/${PN}/${PV:0:3}/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="sse mmx"
+
+DEPEND="virtual/libc"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-build-fixes.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable mmx) \
+ $(use_enable sse)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ find "${D}" -name '*.la' -delete
+ dodoc AUTHORS ChangeLog README NEWS || die "dodoc failed"
+}