summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-12-31 19:31:16 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-12-31 19:31:16 +0000
commitb8f9adc86192ac0f689015442eecb87c95d54637 (patch)
tree1c26444e09accaa39469a9ac65edf11b10b19c02 /media-libs/atlas-c++/atlas-c++-0.4.6.ebuild
parentcompile time fix #35167 (diff)
downloadhistorical-b8f9adc86192ac0f689015442eecb87c95d54637.tar.gz
historical-b8f9adc86192ac0f689015442eecb87c95d54637.tar.bz2
historical-b8f9adc86192ac0f689015442eecb87c95d54637.zip
new version, SRC_URI corrections. Plus this really belongs to games people
Diffstat (limited to 'media-libs/atlas-c++/atlas-c++-0.4.6.ebuild')
-rw-r--r--media-libs/atlas-c++/atlas-c++-0.4.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/atlas-c++/atlas-c++-0.4.6.ebuild b/media-libs/atlas-c++/atlas-c++-0.4.6.ebuild
new file mode 100644
index 000000000000..7ec52ba3d2d5
--- /dev/null
+++ b/media-libs/atlas-c++/atlas-c++-0.4.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/atlas-c++/atlas-c++-0.4.6.ebuild,v 1.1 2003/12/31 19:31:04 george Exp $
+
+MY_PN="Atlas-C++"
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Atlas protocol standard implementation in C++. Atlas protocol is used in role playing games at worldforge."
+HOMEPAGE="http://www.worldforge.net"
+SRC_URI="ftp://ftp.worldforge.org/pub/worldforge/libs/${MY_PN}/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~x86"
+
+DEPEND="virtual/glibc
+ >=dev-libs/libsigc++-1.2*"
+
+src_compile() {
+
+ econf || die
+ emake || die
+
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ #dodoc will install all these docs and a few more
+ rm -rf ${D}/usr/share/doc/${My_P}
+ #PR=r0 in this case, but don't fprget to add ${PR} here for non-zero revisions!
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README ROADMAP THANKS TODO
+}