summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Meier <maekke@gentoo.org>2008-08-16 11:12:22 +0000
committerMarkus Meier <maekke@gentoo.org>2008-08-16 11:12:22 +0000
commit6647c5728e8a57b2e01b842ea51a94a07b3ce869 (patch)
treea6f640fcc063d27c62fb30200af206631a269229 /media-gfx
parentfix typo (diff)
downloadhistorical-6647c5728e8a57b2e01b842ea51a94a07b3ce869.tar.gz
historical-6647c5728e8a57b2e01b842ea51a94a07b3ce869.tar.bz2
historical-6647c5728e8a57b2e01b842ea51a94a07b3ce869.zip
snapshot-bump, required for hugin-0.7.0_rc2
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.27-rc2 i686
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/enblend/ChangeLog8
-rw-r--r--media-gfx/enblend/enblend-3.0_p20080807.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/media-gfx/enblend/ChangeLog b/media-gfx/enblend/ChangeLog
index 056799dcabf4..5a1ef13fd7be 100644
--- a/media-gfx/enblend/ChangeLog
+++ b/media-gfx/enblend/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-gfx/enblend
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/ChangeLog,v 1.22 2008/05/02 11:43:35 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/ChangeLog,v 1.23 2008/08/16 11:12:22 maekke Exp $
+
+*enblend-3.0_p20080807 (16 Aug 2008)
+
+ 16 Aug 2008; Markus Meier <maekke@gentoo.org>
+ +enblend-3.0_p20080807.ebuild:
+ snapshot-bump, required for hugin-0.7.0_rc2
02 May 2008; Markus Meier <maekke@gentoo.org>
+files/enblend-3.0-gcc43.patch, -enblend-2.3.ebuild, -enblend-2.5.ebuild,
diff --git a/media-gfx/enblend/enblend-3.0_p20080807.ebuild b/media-gfx/enblend/enblend-3.0_p20080807.ebuild
new file mode 100644
index 000000000000..243bf5af98e4
--- /dev/null
+++ b/media-gfx/enblend/enblend-3.0_p20080807.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/enblend/enblend-3.0_p20080807.ebuild,v 1.1 2008/08/16 11:12:22 maekke Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Image Blending with Multiresolution Splines"
+HOMEPAGE="http://enblend.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2 VIGRA"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-libs/boost-1.31.0
+ media-libs/lcms
+ media-libs/glew
+ media-libs/plotutils
+ media-libs/tiff
+ virtual/glut"
+
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ # bug 202476
+ if ! built_with_use media-libs/plotutils X ; then
+ eerror
+ eerror "media-gfx/plotutils has to be built with USE=\"X\""
+ eerror
+ die "emerge plotutils with USE=\"X\""
+ fi
+
+ ewarn
+ ewarn "The compilation of enblend needs a lot of RAM. If you have less"
+ ewarn "than 1GB RAM (and swap) you probably won't be able to compile it."
+ ewarn
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.0-gcc43.patch
+ AT_M4DIR="${S}/m4" eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}