summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBart Verwilst <verwilst@gentoo.org>2002-02-07 15:38:25 +0000
committerBart Verwilst <verwilst@gentoo.org>2002-02-07 15:38:25 +0000
commit1ff0e98866beaff7162922ad616da3d739d38ab5 (patch)
treec0c0b22142c5565156d1d1c4286fe6baf0662184 /media-gfx/xpaint
parentinitial ebuild, closed bug #565 (diff)
downloadhistorical-1ff0e98866beaff7162922ad616da3d739d38ab5.tar.gz
historical-1ff0e98866beaff7162922ad616da3d739d38ab5.tar.bz2
historical-1ff0e98866beaff7162922ad616da3d739d38ab5.zip
initial ebuild, closed bug #201
Diffstat (limited to 'media-gfx/xpaint')
-rw-r--r--media-gfx/xpaint/files/Local.config-2.6.2.diff23
-rw-r--r--media-gfx/xpaint/files/digest-xpaint-2.6.21
-rw-r--r--media-gfx/xpaint/xpaint-2.6.2.ebuild43
3 files changed, 67 insertions, 0 deletions
diff --git a/media-gfx/xpaint/files/Local.config-2.6.2.diff b/media-gfx/xpaint/files/Local.config-2.6.2.diff
new file mode 100644
index 000000000000..0a04207fb07e
--- /dev/null
+++ b/media-gfx/xpaint/files/Local.config-2.6.2.diff
@@ -0,0 +1,23 @@
+*** Local.config.orig Wed Jan 16 21:04:42 2002
+--- Local.config Wed Jan 16 21:18:22 2002
+***************
+*** 117,124 ****
+ XCOMM Uncomment these lines and tailor to taste, if you don't like
+ XCOMM the default paths and man page extension.
+ XCOMM
+! XCOMM BINDIR = /usr/local/bin
+! XCOMM MANDIR = /usr/local/man
+ XCOMM #undef ManSuffix
+ XCOMM #define ManSuffix 1
+
+--- 117,124 ----
+ XCOMM Uncomment these lines and tailor to taste, if you don't like
+ XCOMM the default paths and man page extension.
+ XCOMM
+! BINDIR = /usr/bin
+! MANDIR = /usr/share/man
+ XCOMM #undef ManSuffix
+ XCOMM #define ManSuffix 1
+
+
+
diff --git a/media-gfx/xpaint/files/digest-xpaint-2.6.2 b/media-gfx/xpaint/files/digest-xpaint-2.6.2
new file mode 100644
index 000000000000..60175c84d1cd
--- /dev/null
+++ b/media-gfx/xpaint/files/digest-xpaint-2.6.2
@@ -0,0 +1 @@
+MD5 9f22460f15a189721573d88454ce3d41 xpaint-2.6.2.tar.gz 265319
diff --git a/media-gfx/xpaint/xpaint-2.6.2.ebuild b/media-gfx/xpaint/xpaint-2.6.2.ebuild
new file mode 100644
index 000000000000..41dd9efed652
--- /dev/null
+++ b/media-gfx/xpaint/xpaint-2.6.2.ebuild
@@ -0,0 +1,43 @@
+#Copyright 2002 Gentoo Technologies, Inc.
+#Distributed under the terms of the GNU General Public License, v2 or later
+#Author John Stalker <stalker@math.princeton.edu>
+#$Header: /var/cvsroot/gentoo-x86/media-gfx/xpaint/xpaint-2.6.2.ebuild,v 1.1 2002/02/07 15:38:25 verwilst Exp $
+
+S=${WORKDIR}/xpaint
+DESCRIPTION="XPaint is an image editor which supports most standard paint program options."
+SRC_URI="http://home.worldonline.dk/~torsten/xpaint/${P}.tar.gz"
+HOMEPAGE="http://home.worldonline.dk/~torsten/xpaint/"
+SLOT="0"
+
+DEPEND=">=media-libs/tiff-3.2
+ virtual/x11
+ >=media-libs/jpeg-6
+ >=media-libs/libpng-1.0.2"
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+ cd ${S}
+ patch -p0 < ${FILESDIR}/Local.config-2.6.2.diff
+
+}
+
+src_compile() {
+
+ xmkmf || die
+ make Makefiles || die
+ emake || die
+
+}
+
+src_install () {
+
+ make install || die
+ make install.man
+ dodoc ChangeLog INSTALL README README.PNG README.old TODO
+
+}
+
+
+
+