summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Nigbur <pyrania@gentoo.org>2003-09-27 16:52:54 +0000
committerMarkus Nigbur <pyrania@gentoo.org>2003-09-27 16:52:54 +0000
commit2b46e419e7131b1d8e2a2f8f53a142b8e9f7cc83 (patch)
tree9276523a6604086482c580134f71384fc9bef2b9 /media-gfx/graphviz
parentFixed SRC_URI and Bumped to 1.10 (diff)
downloadhistorical-2b46e419e7131b1d8e2a2f8f53a142b8e9f7cc83.tar.gz
historical-2b46e419e7131b1d8e2a2f8f53a142b8e9f7cc83.tar.bz2
historical-2b46e419e7131b1d8e2a2f8f53a142b8e9f7cc83.zip
Fixed SRC_URI and Bumped to 1.10
Diffstat (limited to 'media-gfx/graphviz')
-rw-r--r--media-gfx/graphviz/Manifest6
-rw-r--r--media-gfx/graphviz/files/digest-graphviz-1.101
-rw-r--r--media-gfx/graphviz/graphviz-1.10.ebuild47
-rw-r--r--media-gfx/graphviz/graphviz-1.9.ebuild4
4 files changed, 53 insertions, 5 deletions
diff --git a/media-gfx/graphviz/Manifest b/media-gfx/graphviz/Manifest
index 54571de2466d..b25243533f72 100644
--- a/media-gfx/graphviz/Manifest
+++ b/media-gfx/graphviz/Manifest
@@ -1,9 +1,9 @@
MD5 047f7bfbc1d9050e61bf41bcf3090600 graphviz-1.8.10.ebuild 1191
MD5 01ecc4acc9c20fc3891bc057a441829e graphviz-1.8.10-r3.ebuild 1960
-MD5 66b93ec8f3beaf0e90554a90421979b0 graphviz-1.9.ebuild 1100
-MD5 01b696e086244bddf150796a018ba31e graphviz-1.10.ebuild 1097
+MD5 d6160b4c9466ac4453e984cfde9f3f39 graphviz-1.9.ebuild 1101
+MD5 37071ff584f615b3ac066fd4827e5000 graphviz-1.10.ebuild 1099
MD5 47f4a86ba45ffafdea2d765b42462528 graphviz-1.8.10-r2.ebuild 1261
-MD5 e498ce3259bcb9143b2ab066e26a7b17 ChangeLog 3111
+MD5 0aa7eb9637ea6004509172a43042a9ce ChangeLog 3112
MD5 1737afe4c207e5a3efb388e1f558850f files/digest-graphviz-1.9 190
MD5 5e8726d7d859188692efcfe9e9155761 files/gdgen.c.patch 756
MD5 378952274e1900d18448028732e49690 files/digest-graphviz-1.8.10 68
diff --git a/media-gfx/graphviz/files/digest-graphviz-1.10 b/media-gfx/graphviz/files/digest-graphviz-1.10
new file mode 100644
index 000000000000..46ecb35a1af6
--- /dev/null
+++ b/media-gfx/graphviz/files/digest-graphviz-1.10
@@ -0,0 +1 @@
+MD5 e1402531abff68d146bf94e72b44dc2a graphviz-1.10.tar.gz 3357416
diff --git a/media-gfx/graphviz/graphviz-1.10.ebuild b/media-gfx/graphviz/graphviz-1.10.ebuild
new file mode 100644
index 000000000000..81c0b27d907f
--- /dev/null
+++ b/media-gfx/graphviz/graphviz-1.10.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-1.10.ebuild,v 1.1 2003/09/27 16:52:48 pyrania Exp $
+
+IUSE="tcltk"
+
+DESCRIPTION="open source graph drawing software"
+SRC_URI="http://www.graphviz.org/pub/graphviz/${P}.tar.gz"
+HOMEPAGE="http://www.research.att.com/sw/tools/graphviz/"
+
+SLOT="0"
+LICENSE="as-is | ATT"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa"
+
+#Can use freetype-1.3 or 2.0, but not both
+DEPEND=">=sys-libs/zlib-1.1.3
+ >=sys-devel/gcc-3.2*
+ >=media-libs/libpng-1.2*
+ >=media-libs/jpeg-6b
+ media-libs/freetype
+ tcltk? ( >=dev-lang/tk-8.3* )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ local myconf
+ #if no tcltk, this will generate configure warnings, but will
+ #compile without tcltk support
+ use tcltk || myconf="${myconf} --without-tcl --without-tk"
+
+ econf ${myconf}
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS ChangeLog FAQ.txt INSTALL MINTERMS.txt \
+ NEWS README
+
+ dohtml -r .
+ dodoc doc/*.pdf
+}
diff --git a/media-gfx/graphviz/graphviz-1.9.ebuild b/media-gfx/graphviz/graphviz-1.9.ebuild
index 847ece7d263d..60345116e828 100644
--- a/media-gfx/graphviz/graphviz-1.9.ebuild
+++ b/media-gfx/graphviz/graphviz-1.9.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-1.9.ebuild,v 1.8 2003/07/17 19:58:07 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/graphviz/graphviz-1.9.ebuild,v 1.9 2003/09/27 16:52:48 pyrania Exp $
IUSE="tcltk"
DESCRIPTION="open source graph drawing software"
-SRC_URI="http://www.graphviz.org/pub/graphviz/${P}.tar.gz"
+SRC_URI="http://www.graphviz.org/pub/graphviz/ARCHIVE/${P}.tar.gz"
HOMEPAGE="http://www.research.att.com/sw/tools/graphviz/"
SLOT="0"