summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-03-01 07:29:33 +0000
committerTim Harder <radhermit@gentoo.org>2014-03-01 07:29:33 +0000
commite8ace310cfae2886061e13f14d2d705f0a886433 (patch)
treed60348d8f6973bf5bfcc150cbb36da217dd1c9a8 /media-gfx/feh/feh-2.9.1-r1.ebuild
parentForce rebuild on libpng slot change. (diff)
downloadhistorical-e8ace310cfae2886061e13f14d2d705f0a886433.tar.gz
historical-e8ace310cfae2886061e13f14d2d705f0a886433.tar.bz2
historical-e8ace310cfae2886061e13f14d2d705f0a886433.zip
Remove old.
Package-Manager: portage-2.2.8-r1/cvs/Linux x86_64 Manifest-Sign-Key: 0x4AB3E85B4F064CA3
Diffstat (limited to 'media-gfx/feh/feh-2.9.1-r1.ebuild')
-rw-r--r--media-gfx/feh/feh-2.9.1-r1.ebuild63
1 files changed, 0 insertions, 63 deletions
diff --git a/media-gfx/feh/feh-2.9.1-r1.ebuild b/media-gfx/feh/feh-2.9.1-r1.ebuild
deleted file mode 100644
index cbea361c881a..000000000000
--- a/media-gfx/feh/feh-2.9.1-r1.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/feh/feh-2.9.1-r1.ebuild,v 1.3 2013/03/27 09:19:44 ago Exp $
-
-EAPI=5
-inherit eutils toolchain-funcs
-
-DESCRIPTION="A fast, lightweight imageviewer using imlib2"
-HOMEPAGE="http://feh.finalrewind.org/"
-SRC_URI="http://feh.finalrewind.org/${P}.tar.bz2"
-
-LICENSE="feh"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ppc64 x86"
-IUSE="debug curl exif test xinerama"
-
-COMMON_DEPEND=">=media-libs/giblib-1.2.4
- media-libs/imlib2
- >=media-libs/libpng-1.2:0
- x11-libs/libX11
- curl? ( net-misc/curl )
- exif? ( media-libs/libexif )
- xinerama? ( x11-libs/libXinerama )"
-RDEPEND="${COMMON_DEPEND}
- virtual/jpeg"
-DEPEND="${COMMON_DEPEND}
- x11-libs/libXt
- x11-proto/xproto
- test? (
- >=dev-lang/perl-5.10
- dev-perl/Test-Command
- )"
-
-pkg_setup() {
- use_feh() { usex $1 1 0; }
-
- fehopts=(
- DESTDIR="${D}"
- PREFIX=/usr
- doc_dir='${main_dir}'/share/doc/${PF}
- example_dir='${main_dir}'/share/doc/${PF}/examples
- curl=$(use_feh curl)
- debug=$(use_feh debug)
- xinerama=$(use_feh xinerama)
- exif=$(use_feh exif)
- )
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.6.2-debug-cflags.patch
- # fix desktop file
- sed -i -e "s:^Icon=.*:Icon=/usr/share/feh/images/logo.svg:" \
- share/applications/${PN}.pre || die
-}
-
-src_compile() {
- tc-export CC
- emake "${fehopts[@]}"
-}
-
-src_install() {
- emake "${fehopts[@]}" install
-}