summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <rhill@gentoo.org>2007-09-16 03:45:57 +0000
committerRyan Hill <rhill@gentoo.org>2007-09-16 03:45:57 +0000
commitba928fe4097873a1ae6f7207f346227d36871770 (patch)
tree150c173b7dca5f7e92c0befac7971d38f78b63e9 /media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild
parentInstall bdf if USE="-X". (diff)
downloadhistorical-ba928fe4097873a1ae6f7207f346227d36871770.tar.gz
historical-ba928fe4097873a1ae6f7207f346227d36871770.tar.bz2
historical-ba928fe4097873a1ae6f7207f346227d36871770.zip
Let eclass handle FONT_SUFFIX.
Package-Manager: portage-2.1.3.9
Diffstat (limited to 'media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild')
-rw-r--r--media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild b/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild
index 1b49a8cd2840..eb5c50cde654 100644
--- a/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild
+++ b/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild,v 1.9 2007/06/13 16:53:56 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/jisx0213-fonts/jisx0213-fonts-20040425-r2.ebuild,v 1.10 2007/09/16 03:45:57 dirtyepic Exp $
inherit font font-ebdftopcf
@@ -31,15 +31,16 @@ S="${WORKDIR}"
FONT_S="${S}"
FONT_PN="${PN/-fonts/}"
FONTDIR="/usr/share/fonts/${FONT_PN}"
-FONT_SUFFIX="pcf.gz"
# Only installs fonts
RESTRICT="strip binchecks"
pkg_postinst(){
- elog "You need you add following line into 'Section \"Files\"' in"
- elog "XF86Config and reboot X Window System, to use these fonts."
- elog ""
- elog "\t FontPath \"${FONTDIR}\""
- elog ""
+ if use X; then
+ elog "You need you add following line into 'Section \"Files\"' in"
+ elog "XF86Config and reboot X Window System, to use these fonts."
+ elog ""
+ elog "\t FontPath \"${FONTDIR}\""
+ elog ""
+ fi
}