summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-06-02 13:45:30 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-06-02 13:45:30 +0000
commit64d173ac0100f9cc213f7db004305a097c57bbed (patch)
treeb9a2cefa17bbd0248b38e826b4d128a3c62db11a /media-fonts/arphicfonts
parentmove fonts to media-fonts (diff)
downloadhistorical-64d173ac0100f9cc213f7db004305a097c57bbed.tar.gz
historical-64d173ac0100f9cc213f7db004305a097c57bbed.tar.bz2
historical-64d173ac0100f9cc213f7db004305a097c57bbed.zip
moved from x11-misc to media-fonts
Diffstat (limited to 'media-fonts/arphicfonts')
-rw-r--r--media-fonts/arphicfonts/Manifest10
-rw-r--r--media-fonts/arphicfonts/arphicfonts-0.1-r1.ebuild78
-rw-r--r--media-fonts/arphicfonts/arphicfonts-0.1.ebuild48
-rw-r--r--media-fonts/arphicfonts/files/CN-fonts.scale5
-rw-r--r--media-fonts/arphicfonts/files/TW-fonts.scale11
-rw-r--r--media-fonts/arphicfonts/files/digest-arphicfonts-0.14
-rw-r--r--media-fonts/arphicfonts/files/digest-arphicfonts-0.1-r14
7 files changed, 155 insertions, 5 deletions
diff --git a/media-fonts/arphicfonts/Manifest b/media-fonts/arphicfonts/Manifest
index 721c5e939132..9d92e2624060 100644
--- a/media-fonts/arphicfonts/Manifest
+++ b/media-fonts/arphicfonts/Manifest
@@ -1,7 +1,7 @@
-MD5 e8854a583090816f27fc71d059281a68 ChangeLog 1058
-MD5 76a5d08ca768b2f1d7b3e900e33ffa9d arphicfonts-0.1-r1.ebuild 3249
-MD5 f04431f2ca71635932a4151f7d27a262 arphicfonts-0.1.ebuild 1545
-MD5 8092f72476c54669d231fa1e36c4272d files/CN-fonts.scale 316
-MD5 3bd7bba2b62aba255babce12594cbdd8 files/TW-fonts.scale 945
+MD5 5a140d8f419e0f6f60ca2a99d5bc8d58 arphicfonts-0.1.ebuild 1534
+MD5 3bcab866a3874ba460971d9a0dd76b65 arphicfonts-0.1-r1.ebuild 3220
+MD5 37ead0d1241b93fd028842698b3260c8 ChangeLog 1276
MD5 2fe8346e604f4ae761d1a8cbb551f6c7 files/digest-arphicfonts-0.1 244
+MD5 3bd7bba2b62aba255babce12594cbdd8 files/TW-fonts.scale 945
+MD5 8092f72476c54669d231fa1e36c4272d files/CN-fonts.scale 316
MD5 2fe8346e604f4ae761d1a8cbb551f6c7 files/digest-arphicfonts-0.1-r1 244
diff --git a/media-fonts/arphicfonts/arphicfonts-0.1-r1.ebuild b/media-fonts/arphicfonts/arphicfonts-0.1-r1.ebuild
new file mode 100644
index 000000000000..e2f5298c41ac
--- /dev/null
+++ b/media-fonts/arphicfonts/arphicfonts-0.1-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/arphicfonts/arphicfonts-0.1-r1.ebuild,v 1.1 2003/06/02 13:45:18 seemant Exp $
+
+S=${WORKDIR}
+DESCRIPTION="Arphic Fonts"
+HOMEPAGE="http://www.arphic.com.tw/"
+SRC_URI="ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/gkai00mp.ttf.gz
+ ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/bkai00mp.ttf.gz
+ ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/bsmi00lp.ttf.gz
+ ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/gbsn00lp.ttf.gz"
+
+SLOT="0"
+LICENSE="Arphic"
+KEYWORDS="x86 ppc"
+
+DEPEND="virtual/x11
+ x11-misc/ttmkfdir"
+
+src_install() {
+ insopts -m0644
+ insinto /usr/share/fonts/ttf/zh_TW
+ doins b*.ttf
+ if test -r /usr/share/fonts/ttf/zh_TW/fonts.scale; then
+ tail +2 /usr/share/fonts/ttf/zh_TW/fonts.scale > tmp
+ tail +2 ${FILESDIR}/TW-fonts.scale >> tmp
+ echo $(sort -u tmp | wc -l) > newfont.scale
+ sort -u tmp >> newfont.scale
+ newins newfont.scale fonts.scale
+ else
+ newins ${FILESDIR}/TW-fonts.scale fonts.scale
+ fi
+ insinto /usr/share/fonts/ttf/zh_CN
+ doins g*.ttf
+ if test -r /usr/share/fonts/ttf/zh_CN/fonts.scale; then
+ tail +2 /usr/share/fonts/ttf/zh_CN/fonts.scale > tmp
+ tail +2 ${FILESDIR}/CN-fonts.scale >> tmp
+ echo $(sort -u tmp | wc -l) > newfont.scale
+ sort -u tmp >> newfont.scale
+ newins newfont.scale fonts.scale
+ else
+ newins ${FILESDIR}/CN-fonts.scale fonts.scale
+ fi
+
+# These don't get downloaded because there is no simple way to
+# fetch them.. ie if I included the README in SRC_URI above, it would
+# get saved as ${DISTDIR}/README which doesn't seem like
+# a really good idea.
+# dodoc LICENSE README
+}
+
+pkg_postinst() {
+ echo ">>> Making big5 font dirs..."
+ cd /usr/share/fonts/ttf/zh_TW
+ echo ">>> Creating fonts.dir info"
+ mkfontdir -e /usr/share/fonts/encodings/large \
+ -e /usr/share/fonts/encodings
+ echo ">>> Making gb2312 font dirs..."
+ cd /usr/share/fonts/ttf/zh_CN
+ echo ">>> Creating fonts.dir info"
+ mkfontdir -e /usr/share/fonts/encodings/large \
+ -e /usr/share/fonts/encodings
+ echo ">>> Make sure X knows about these font directories!"
+ if ( `grep -e "^.*FontPath.*\"/usr/share/fonts/ttf/zh_TW\"" /etc/X11/XF86Config -q` ); then
+ echo "Font path for big5 fonts is listed in /etc/X11/XF86Config."
+ else
+ echo ">>> You must add /usr/share/fonts/ttf/zh_TW to your font path"
+ echo ">>> to be able to use your new Big5 fonts."
+ fi
+ if ( `grep -e "^.*[fF]ont[Pp]ath.*\"/usr/share/fonts/ttf/zh_CN\"" /etc/X11/XF86Config -q` ); then
+ echo "Font path for gb2312 fonts is listed in /etc/X11/XF86Config."
+ else
+ echo ">>> You must add /usr/share/fonts/ttf/zh_CN to your font path"
+ echo ">>> to be able to use your new gb2312 fonts."
+ fi
+
+ echo ">>> Restart font server for changes to take effect."
+}
diff --git a/media-fonts/arphicfonts/arphicfonts-0.1.ebuild b/media-fonts/arphicfonts/arphicfonts-0.1.ebuild
new file mode 100644
index 000000000000..0c7703462639
--- /dev/null
+++ b/media-fonts/arphicfonts/arphicfonts-0.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-fonts/arphicfonts/arphicfonts-0.1.ebuild,v 1.1 2003/06/02 13:45:18 seemant Exp $
+
+DESCRIPTION="Arphic Fonts"
+SRC_URI="ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/gkai00mp.ttf.gz
+ ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/bkai00mp.ttf.gz
+ ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/bsmi00lp.ttf.gz
+ ftp://ftp.gnu.org/non-gnu/chinese-fonts-truetype/gbsn00lp.ttf.gz"
+HOMEPAGE="http://www.arphic.com.tw/"
+LICENSE="Arphic"
+SLOT="0"
+KEYWORDS="x86 sparc ppc"
+
+DEPEND="virtual/x11
+ x11-misc/ttmkfdir"
+
+src_unpack() {
+ mkdir ${WORKDIR}/${P}
+ gunzip -c ${DISTDIR}/gkai00mp.ttf.gz > ${WORKDIR}/${P}/gkai00mp.ttf
+ gunzip -c ${DISTDIR}/bkai00mp.ttf.gz > ${WORKDIR}/${P}/bkai00mp.ttf
+ gunzip -c ${DISTDIR}/bsmi00lp.ttf.gz > ${WORKDIR}/${P}/bsmi00lp.ttf
+ gunzip -c ${DISTDIR}/gbsn00lp.ttf.gz > ${WORKDIR}/${P}/gbsn00lp.ttf
+}
+
+src_compile() {
+ echo "Truetype fonts don't need to be compiled! ;)"
+}
+
+src_install() {
+ cd ${WORKDIR}/${P}
+ insopts -m0644
+ insinto /usr/share/fonts/truetype
+ doins *.ttf
+
+# These don't get downloaded because there is no simple way to
+# fetch them.. ie if I included the README in SRC_URI above, it would
+# get saved as ${DISTDIR}/README which doesn't seem like
+# a really good idea.
+# dodoc LICENSE README
+}
+
+pkg_postinst() {
+ echo ">>> Making font dirs..."
+ cd /usr/share/fonts/truetype/
+ /usr/X11R6/bin/ttmkfdir > fonts.scale
+ mkfontdir
+}
diff --git a/media-fonts/arphicfonts/files/CN-fonts.scale b/media-fonts/arphicfonts/files/CN-fonts.scale
new file mode 100644
index 000000000000..f6dc9059b90b
--- /dev/null
+++ b/media-fonts/arphicfonts/files/CN-fonts.scale
@@ -0,0 +1,5 @@
+4
+gkai00mp.ttf -arphic-ar pl kaitim gb-medium-r-normal--0-0-0-0-p-0-iso8859-1
+gkai00mp.ttf -arphic-ar pl kaitim gb-medium-r-normal--0-0-0-0-p-0-gb2312.1980-0
+gbsn00lp.ttf -arphic-ar pl sungtil gb-medium-r-normal--0-0-0-0-p-0-iso8859-1
+gbsn00lp.ttf -arphic-ar pl sungtil gb-medium-r-normal--0-0-0-0-p-0-gb2312.1980-0
diff --git a/media-fonts/arphicfonts/files/TW-fonts.scale b/media-fonts/arphicfonts/files/TW-fonts.scale
new file mode 100644
index 000000000000..5131770d2957
--- /dev/null
+++ b/media-fonts/arphicfonts/files/TW-fonts.scale
@@ -0,0 +1,11 @@
+10
+bkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM Big5-medium-r-normal--0-0-0-0-c-0-ascii-0
+bkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM Big5-medium-r-normal--0-0-0-0-c-0-big5-0
+bkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM Big5-medium-r-normal--0-0-0-0-c-0-big5.cp950-0
+bkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM Big5-medium-r-normal--0-0-0-0-c-0-big5.eten-0
+bkai00mp.ttf -Arphic Technology Co.-AR PL KaitiM Big5-medium-r-normal--0-0-0-0-c-0-iso10646-1
+bsmi00lp.ttf -Arphic Technology Co.-AR PL Mingti2L Big5-medium-r-normal--0-0-0-0-c-0-ascii-0
+bsmi00lp.ttf -Arphic Technology Co.-AR PL Mingti2L Big5-medium-r-normal--0-0-0-0-c-0-big5-0
+bsmi00lp.ttf -Arphic Technology Co.-AR PL Mingti2L Big5-medium-r-normal--0-0-0-0-c-0-big5.cp950-0
+bsmi00lp.ttf -Arphic Technology Co.-AR PL Mingti2L Big5-medium-r-normal--0-0-0-0-c-0-big5.eten-0
+bsmi00lp.ttf -Arphic Technology Co.-AR PL Mingti2L Big5-medium-r-normal--0-0-0-0-c-0-iso10646-1
diff --git a/media-fonts/arphicfonts/files/digest-arphicfonts-0.1 b/media-fonts/arphicfonts/files/digest-arphicfonts-0.1
new file mode 100644
index 000000000000..8cb6db87971d
--- /dev/null
+++ b/media-fonts/arphicfonts/files/digest-arphicfonts-0.1
@@ -0,0 +1,4 @@
+MD5 5ee11417a8b42d08a33421dd6c64bed2 gkai00mp.ttf.gz 2698942
+MD5 9abc1efeaf08df5554629b10eb79b1b2 bkai00mp.ttf.gz 6013768
+MD5 42b13b73c5572d886824ee249d1ad500 bsmi00lp.ttf.gz 5653466
+MD5 757ca4959ed2325d49a64730766140ee gbsn00lp.ttf.gz 2345803
diff --git a/media-fonts/arphicfonts/files/digest-arphicfonts-0.1-r1 b/media-fonts/arphicfonts/files/digest-arphicfonts-0.1-r1
new file mode 100644
index 000000000000..8cb6db87971d
--- /dev/null
+++ b/media-fonts/arphicfonts/files/digest-arphicfonts-0.1-r1
@@ -0,0 +1,4 @@
+MD5 5ee11417a8b42d08a33421dd6c64bed2 gkai00mp.ttf.gz 2698942
+MD5 9abc1efeaf08df5554629b10eb79b1b2 bkai00mp.ttf.gz 6013768
+MD5 42b13b73c5572d886824ee249d1ad500 bsmi00lp.ttf.gz 5653466
+MD5 757ca4959ed2325d49a64730766140ee gbsn00lp.ttf.gz 2345803