summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
committerJohannes Huber <johu@gentoo.org>2012-09-04 18:45:48 +0000
commit96b2ccccbdb3a629585880f16ae065b3a046ecf8 (patch)
tree8614154608c173341cea9bbafdd085551b050be8 /kde-base/qyoto
parentAdd net-misc/leechcraft-launchy, thanks to 0xd34df00d (diff)
downloadhistorical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.tar.gz
historical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.tar.bz2
historical-96b2ccccbdb3a629585880f16ae065b3a046ecf8.zip
Version bump KDE SC 4.9.1
Package-Manager: portage-2.2.0_alpha124/cvs/Linux x86_64
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/ChangeLog7
-rw-r--r--kde-base/qyoto/qyoto-4.9.1.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/kde-base/qyoto/ChangeLog b/kde-base/qyoto/ChangeLog
index 6384d8a57f63..00903e6e7016 100644
--- a/kde-base/qyoto/ChangeLog
+++ b/kde-base/qyoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qyoto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.37 2012/09/03 13:29:37 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.38 2012/09/04 18:45:06 johu Exp $
+
+*qyoto-4.9.1 (04 Sep 2012)
+
+ 04 Sep 2012; Johannes Huber <johu@gentoo.org> +qyoto-4.9.1.ebuild:
+ Version bump KDE SC 4.9.1
03 Sep 2012; Johannes Huber <johu@gentoo.org> -qyoto-4.7.4.ebuild:
Remove KDE SC 4.7.4
diff --git a/kde-base/qyoto/qyoto-4.9.1.ebuild b/kde-base/qyoto/qyoto-4.9.1.ebuild
new file mode 100644
index 000000000000..4ba44dcf58e7
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.9.1.ebuild,v 1.1 2012/09/04 18:45:06 johu Exp $
+
+EAPI=4
+
+KDE_REQUIRED="never"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qscintilla webkit"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}