summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-11-02 20:48:23 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-11-02 20:48:23 +0000
commit36ac1ffbbf2ff5c49cacc02c077bdf2e5e85ac27 (patch)
tree864e8e2eb92341590d978e2d8da33306956db3de /kde-base/qyoto
parent[profiles/arch/powerpc] Update kde mask (diff)
downloadhistorical-36ac1ffbbf2ff5c49cacc02c077bdf2e5e85ac27.tar.gz
historical-36ac1ffbbf2ff5c49cacc02c077bdf2e5e85ac27.tar.bz2
historical-36ac1ffbbf2ff5c49cacc02c077bdf2e5e85ac27.zip
[kde-base] KDE SC 4.7.3
Package-Manager: portage-2.2.0_alpha72/cvs/Linux x86_64
Diffstat (limited to 'kde-base/qyoto')
-rw-r--r--kde-base/qyoto/ChangeLog7
-rw-r--r--kde-base/qyoto/qyoto-4.7.3.ebuild31
2 files changed, 37 insertions, 1 deletions
diff --git a/kde-base/qyoto/ChangeLog b/kde-base/qyoto/ChangeLog
index 8bcf1dff1345..4eb48eb60a97 100644
--- a/kde-base/qyoto/ChangeLog
+++ b/kde-base/qyoto/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/qyoto
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.5 2011/10/28 19:03:32 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/ChangeLog,v 1.6 2011/11/02 20:47:52 alexxy Exp $
+
+*qyoto-4.7.3 (02 Nov 2011)
+
+ 02 Nov 2011; Alexey Shvetsov <alexxy@gentoo.org> +qyoto-4.7.3.ebuild:
+ Version bump KDE SC 4.7.3
28 Oct 2011; Andreas K. Huettel <dilfridge@gentoo.org> -qyoto-4.7.1.ebuild:
Drop KDEpim 4.6.1 and KDE 4.7.1
diff --git a/kde-base/qyoto/qyoto-4.7.3.ebuild b/kde-base/qyoto/qyoto-4.7.3.ebuild
new file mode 100644
index 000000000000..dcc73baaf2ee
--- /dev/null
+++ b/kde-base/qyoto/qyoto-4.7.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/qyoto/qyoto-4.7.3.ebuild,v 1.1 2011/11/02 20:47:52 alexxy Exp $
+
+EAPI=4
+
+KDE_REQUIRED="never"
+KDE_SCM="git"
+inherit kde4-base mono
+
+DESCRIPTION="C# bindings for Qt"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +phonon qscintilla webkit"
+
+DEPEND="
+ dev-lang/mono
+ $(add_kdebase_dep smokeqt 'opengl,phonon?,qscintilla?,webkit?')
+"
+RDEPEND="${DEPEND}"
+
+# Split from kdebindings-csharp in 4.7
+add_blocker kdebindings-csharp
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_disable qscintilla QScintilla)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-base_src_configure
+}