summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2007-05-23 02:49:29 +0000
committerCarsten Lohrke <carlo@gentoo.org>2007-05-23 02:49:29 +0000
commit6a9d9dc553e6d8ff6263e5b70ce1ed868f443cea (patch)
tree529c3eb3257d70e522d1bbe5267c1b9ac3f102cc /kde-base/noatun-plugins
parentAdd ~x86 keyword (diff)
downloadhistorical-6a9d9dc553e6d8ff6263e5b70ce1ed868f443cea.tar.gz
historical-6a9d9dc553e6d8ff6263e5b70ce1ed868f443cea.tar.bz2
historical-6a9d9dc553e6d8ff6263e5b70ce1ed868f443cea.zip
Version bump.
Package-Manager: portage-2.1.2.7
Diffstat (limited to 'kde-base/noatun-plugins')
-rw-r--r--kde-base/noatun-plugins/ChangeLog8
-rw-r--r--kde-base/noatun-plugins/files/digest-noatun-plugins-3.5.73
-rw-r--r--kde-base/noatun-plugins/noatun-plugins-3.5.7.ebuild40
3 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/noatun-plugins/ChangeLog b/kde-base/noatun-plugins/ChangeLog
index d43d48e2cee7..eb066bfb11fc 100644
--- a/kde-base/noatun-plugins/ChangeLog
+++ b/kde-base/noatun-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/noatun-plugins
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/ChangeLog,v 1.66 2007/04/25 15:37:03 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/ChangeLog,v 1.67 2007/05/23 02:37:57 carlo Exp $
+
+*noatun-plugins-3.5.7 (23 May 2007)
+
+ 23 May 2007; Carsten Lohrke <carlo@gentoo.org>
+ +noatun-plugins-3.5.7.ebuild:
+ Version bump.
25 Apr 2007; Carsten Lohrke <carlo@gentoo.org>
noatun-plugins-3.5.6.ebuild:
diff --git a/kde-base/noatun-plugins/files/digest-noatun-plugins-3.5.7 b/kde-base/noatun-plugins/files/digest-noatun-plugins-3.5.7
new file mode 100644
index 000000000000..fa11933fd916
--- /dev/null
+++ b/kde-base/noatun-plugins/files/digest-noatun-plugins-3.5.7
@@ -0,0 +1,3 @@
+MD5 7b50fa8e103bd722dfcdfc329126ff28 kdeaddons-3.5.7.tar.bz2 1735896
+RMD160 f5326ff18a2529ab1046f1623b5cdab11267de5e kdeaddons-3.5.7.tar.bz2 1735896
+SHA256 b95d00802b0e34147a3540518dcdf6d6532ff1acaaf7bb165e0aee2a95effbcd kdeaddons-3.5.7.tar.bz2 1735896
diff --git a/kde-base/noatun-plugins/noatun-plugins-3.5.7.ebuild b/kde-base/noatun-plugins/noatun-plugins-3.5.7.ebuild
new file mode 100644
index 000000000000..ae8066cb0fea
--- /dev/null
+++ b/kde-base/noatun-plugins/noatun-plugins-3.5.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun-plugins/noatun-plugins-3.5.7.ebuild,v 1.1 2007/05/23 02:37:57 carlo Exp $
+KMNAME=kdeaddons
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit db-use kde-meta
+
+DESCRIPTION="Various plugins for Noatun."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="arts sdl berkdb"
+
+DEPEND="$(deprange-dual 3.5.6 $MAXKDEVER kde-base/noatun)
+ arts? ( $(deprange 3.5.5 $MAXKDEVER kde-base/arts) )
+ sdl? ( >=media-libs/libsdl-1.2 )
+ berkdb? ( =sys-libs/db-4* )"
+
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ kde_pkg_setup
+ if use sdl && ! built_with_use media-libs/libsdl X ; then
+ eerror "media-libs/libsdl is not build with X support."
+ die "Please reemerge media-libs/libsdl with USE=\"X\"."
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_with sdl)"
+
+ if use berkdb; then
+ dblib="$(db_libname)"
+ myconf="${myconf} --with-berkeley-db --with-db-lib=${dblib/-/_cxx-}
+ --with-extra-includes=${ROOT}$(db_includedir)"
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ kde-meta_src_compile
+}