summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-01-15 02:24:42 +0000
committerDan Armak <danarmak@gentoo.org>2005-01-15 02:24:42 +0000
commit9300be3031aefac98b4fa4b0b02abec7b657d43e (patch)
treee0ca082a44a83de2d88a041ecadbb5b75f066c76 /kde-base/lisa
parent(no commit message) (diff)
downloadhistorical-9300be3031aefac98b4fa4b0b02abec7b657d43e.tar.gz
historical-9300be3031aefac98b4fa4b0b02abec7b657d43e.tar.bz2
historical-9300be3031aefac98b4fa4b0b02abec7b657d43e.zip
kde 3.4 split ebuilds, all masked
Diffstat (limited to 'kde-base/lisa')
-rw-r--r--kde-base/lisa/ChangeLog12
-rw-r--r--kde-base/lisa/Manifest8
-rw-r--r--kde-base/lisa/files/digest-lisa-3.4.0_beta13
-rwxr-xr-xkde-base/lisa/files/lisa20
-rw-r--r--kde-base/lisa/files/lisa.conf11
-rwxr-xr-xkde-base/lisa/files/reslisa20
-rw-r--r--kde-base/lisa/files/reslisa.conf11
-rw-r--r--kde-base/lisa/lisa-3.4.0_beta1.ebuild34
-rw-r--r--kde-base/lisa/metadata.xml5
9 files changed, 124 insertions, 0 deletions
diff --git a/kde-base/lisa/ChangeLog b/kde-base/lisa/ChangeLog
new file mode 100644
index 000000000000..89f4a7552c7f
--- /dev/null
+++ b/kde-base/lisa/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for kde-base/lisa
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/lisa/ChangeLog,v 1.1 2005/01/15 02:24:41 danarmak Exp $
+
+*lisa-3.4.0_beta1 (15 Jan 2005)
+
+ 15 Jan 2005; Dan Armak <danarmak@gentoo.org> +metadata.xml, +files/lisa,
+ +files/lisa.conf, +files/reslisa, +files/reslisa.conf,
+ +lisa-3.4.0_beta1.ebuild:
+ Adding the split ebuilds to portage. For KDE 3.4, we've created separate
+ ebuilds for all the KDE apps.
+
diff --git a/kde-base/lisa/Manifest b/kde-base/lisa/Manifest
new file mode 100644
index 000000000000..df1eba48904a
--- /dev/null
+++ b/kde-base/lisa/Manifest
@@ -0,0 +1,8 @@
+MD5 761fca3b6d252e15434db4fcee283412 lisa-3.4.0_alpha1.ebuild 981
+MD5 761fca3b6d252e15434db4fcee283412 lisa-3.4.0_beta1.ebuild 981
+MD5 732cc856c1e48585781d79173f5d271b files/lisa 538
+MD5 8f9373cda4770eab4d67c6adf6621547 files/reslisa 562
+MD5 01dd2bacee59738f96d17c77774a5102 files/reslisa.conf 450
+MD5 d97100af0cb95f733660b7a61492d71f files/lisa.conf 452
+MD5 4af013c3a73d9988c67cfbfcc7fff890 files/digest-lisa-3.4.0_beta1 223
+MD5 09cbac9d8b68d5bd4514c50df459e782 files/digest-lisa-3.4.0_alpha1 71
diff --git a/kde-base/lisa/files/digest-lisa-3.4.0_beta1 b/kde-base/lisa/files/digest-lisa-3.4.0_beta1
new file mode 100644
index 000000000000..b8124c5a3b23
--- /dev/null
+++ b/kde-base/lisa/files/digest-lisa-3.4.0_beta1
@@ -0,0 +1,3 @@
+MD5 9806e2569f7ce04d06a685b490ad9025 kdenetwork-3.3.90.tar.bz2 7105855
+MD5 a801f7e549402e859061ebdfd3c64ee0 kdenetwork-3.3.90-3.3.91.tar.xdelta 1063517
+MD5 962ff8207d025846cf8cbc15960be2ca kdenetwork-3.3.91.tar.bz2 7489946
diff --git a/kde-base/lisa/files/lisa b/kde-base/lisa/files/lisa
new file mode 100755
index 000000000000..f0da1fa0413f
--- /dev/null
+++ b/kde-base/lisa/files/lisa
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/lisa/files/lisa,v 1.1 2005/01/15 02:24:41 danarmak Exp $
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting lisa"
+ start-stop-daemon --start -x _KDEDIR_/bin/lisa -q -- $LISACONF 1>/dev/null
+ eend $? "Failed to start lisa"
+}
+
+stop() {
+ ebegin "Stopping lisa"
+ start-stop-daemon --stop -x _KDEDIR_/bin/lisa -q
+ eend $? "Failed to stop lisa"
+}
diff --git a/kde-base/lisa/files/lisa.conf b/kde-base/lisa/files/lisa.conf
new file mode 100644
index 000000000000..bad3fa8261fc
--- /dev/null
+++ b/kde-base/lisa/files/lisa.conf
@@ -0,0 +1,11 @@
+# Note: this is NOT the main lisa configuratio file. That is in /etc/lisarc.
+# This merely sets startup options for the gentoo lisa initscript.
+# Add anything you want to $LISACONF.
+
+# config file to use; overrides default
+# note that default checks /etc/lisarc and ~/.lisarc
+# LISACONF="$LISACONF --config=myfile"
+
+# port to use; overrides default of 7741
+# I think all lisas on the network have to use the same port
+# LISACONF="$LISACONF --port 7741" \ No newline at end of file
diff --git a/kde-base/lisa/files/reslisa b/kde-base/lisa/files/reslisa
new file mode 100755
index 000000000000..c37d8851410a
--- /dev/null
+++ b/kde-base/lisa/files/reslisa
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/lisa/files/reslisa,v 1.1 2005/01/15 02:24:41 danarmak Exp $
+
+depend() {
+ use net
+}
+
+start() {
+ ebegin "Starting reslisa"
+ start-stop-daemon --start -x _KDEDIR_/bin/reslisa -q -- $RESLISACONF 1>/dev/null
+ eend $? "Failed to start reslisa"
+}
+
+stop() {
+ ebegin "Stopping reslisa"
+ start-stop-daemon --stop -x _KDEDIR_/bin/reslisa -q
+ eend $? "Failed to stop reslisa"
+}
diff --git a/kde-base/lisa/files/reslisa.conf b/kde-base/lisa/files/reslisa.conf
new file mode 100644
index 000000000000..04328058935c
--- /dev/null
+++ b/kde-base/lisa/files/reslisa.conf
@@ -0,0 +1,11 @@
+# Note: this is NOT the main reslisa configuration file.
+# This merely sets startup options for the gentoo lisa initscript.
+# Add anything you want to $RESLISACONF.
+
+# config file to use; overrides default
+# note that default checks /etc/lisarc and ~/.lisarc
+# RESLISACONF="$RESLISACONF --config=myfile"
+
+# port to use; overrides default of 7741
+# I think all reslisas on the network have to use the same port
+# RESLISACONF="$RESLISACONF --port 7741" \ No newline at end of file
diff --git a/kde-base/lisa/lisa-3.4.0_beta1.ebuild b/kde-base/lisa/lisa-3.4.0_beta1.ebuild
new file mode 100644
index 000000000000..6f7f2e94e522
--- /dev/null
+++ b/kde-base/lisa/lisa-3.4.0_beta1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/lisa/lisa-3.4.0_beta1.ebuild,v 1.1 2005/01/15 02:24:41 danarmak Exp $
+
+KMNAME=kdenetwork
+KMMODULE=lanbrowsing
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE Lan Information Server - allows KDE desktops to share information over a network"
+KEYWORDS="~x86"
+IUSE=""
+KMEXTRA="doc/kcontrol/lanbrowser"
+
+src_install() {
+ kde-meta_src_install
+
+ chmod u+s ${D}/${KDEDIR}/bin/reslisa
+
+ # lisa, reslisa initscripts
+ dodir /etc/init.d
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/lisa > ${D}/etc/init.d/lisa
+ sed -e "s:_KDEDIR_:${KDEDIR}:g" ${FILESDIR}/reslisa > ${D}/etc/init.d/reslisa
+ chmod +x ${D}/etc/init.d/*
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/lisa.conf lisa
+ newins ${FILESDIR}/reslisa.conf reslisa
+
+ for x in /etc/lisarc /etc/reslisarc; do
+ echo '# Default lisa/reslisa configfile' > $D/$x
+ done
+} \ No newline at end of file
diff --git a/kde-base/lisa/metadata.xml b/kde-base/lisa/metadata.xml
new file mode 100644
index 000000000000..1a4592f97a10
--- /dev/null
+++ b/kde-base/lisa/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde-core</herd>
+</pkgmetadata>