summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
commit89e71ef45253e6d197ba528112eeae6984651626 (patch)
tree043bfec14e51381244a2ec0e91acb3879eae0a5c /kde-base/ksystemlog
parentInitial import. New dependency for forthcoming Rails 3.1 release. (diff)
downloadhistorical-89e71ef45253e6d197ba528112eeae6984651626.tar.gz
historical-89e71ef45253e6d197ba528112eeae6984651626.tar.bz2
historical-89e71ef45253e6d197ba528112eeae6984651626.zip
[kde-base] KDE SC 4.7.2
Package-Manager: portage-2.2.0_alpha61/cvs/Linux x86_64
Diffstat (limited to 'kde-base/ksystemlog')
-rw-r--r--kde-base/ksystemlog/ChangeLog7
-rw-r--r--kde-base/ksystemlog/ksystemlog-4.7.2.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/ksystemlog/ChangeLog b/kde-base/ksystemlog/ChangeLog
index c9bafb18b3de..984a07eea949 100644
--- a/kde-base/ksystemlog/ChangeLog
+++ b/kde-base/ksystemlog/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksystemlog
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.85 2011/09/07 20:13:51 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ChangeLog,v 1.86 2011/10/06 18:10:57 alexxy Exp $
+
+*ksystemlog-4.7.2 (06 Oct 2011)
+
+ 06 Oct 2011; Alexey Shvetsov <alexxy@gentoo.org> +ksystemlog-4.7.2.ebuild:
+ Version bump KDE SC 4.7.2
*ksystemlog-4.7.1 (07 Sep 2011)
diff --git a/kde-base/ksystemlog/ksystemlog-4.7.2.ebuild b/kde-base/ksystemlog/ksystemlog-4.7.2.ebuild
new file mode 100644
index 000000000000..ac6de234a8ec
--- /dev/null
+++ b/kde-base/ksystemlog/ksystemlog-4.7.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksystemlog/ksystemlog-4.7.2.ebuild,v 1.1 2011/10/06 18:10:57 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+KMNAME="kdeadmin"
+
+VIRTUALX_REQUIRED=test
+inherit kde4-meta
+
+DESCRIPTION="KDE system log viewer"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug test"
+
+RESTRICT=test
+# bug 378101
+
+src_prepare() {
+ kde4-meta_src_prepare
+
+ if use test; then
+ # beat this stupid test into shape: the test files contain no year, so
+ # comparison succeeds only in 2007 !!!
+ local theyear=$(date +%Y)
+ einfo Setting the current year as ${theyear} in the test files
+ sed -e "s:2007:${theyear}:g" -i ksystemlog/tests/systemAnalyzerTest.cpp
+
+ # one test consistently fails, so comment it out for the moment
+ sed -e "s:systemAnalyzerTest:# dont run systemAnalyzerTest:g" -i ksystemlog/tests/CMakeLists.txt
+ fi
+}