summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2012-12-05 16:58:30 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2012-12-05 16:58:30 +0000
commitb7e10b1ff43fba2e87d10b1de1b37a907f25a32d (patch)
tree991d07389d560eb2828b10508e6ca8022fb6c212 /kde-base/ksplash
parentStable for HPPA (bug #444546). (diff)
downloadhistorical-b7e10b1ff43fba2e87d10b1de1b37a907f25a32d.tar.gz
historical-b7e10b1ff43fba2e87d10b1de1b37a907f25a32d.tar.bz2
historical-b7e10b1ff43fba2e87d10b1de1b37a907f25a32d.zip
[kde-base] Add KDE SC 4.9.4
Package-Manager: portage-2.2.0_alpha144/cvs/Linux x86_64 Manifest-Sign-Key: 0xF82F92E6
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog7
-rw-r--r--kde-base/ksplash/ksplash-4.9.4.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index d8385d113945..c81af4fec1c4 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.149 2012/11/30 16:22:07 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.150 2012/12/05 16:58:08 alexxy Exp $
+
+*ksplash-4.9.4 (05 Dec 2012)
+
+ 05 Dec 2012; Alexey Shvetsov <alexxy@gentoo.org> +ksplash-4.9.4.ebuild:
+ Version bump KDE SC 4.9.4
30 Nov 2012; <ago@gentoo.org> ksplash-4.9.3.ebuild:
Stable for ppc, wrt bug #442394
diff --git a/kde-base/ksplash/ksplash-4.9.4.ebuild b/kde-base/ksplash/ksplash-4.9.4.ebuild
new file mode 100644
index 000000000000..5d01433bc5be
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.9.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.9.4.ebuild,v 1.1 2012/12/05 16:58:08 alexxy Exp $
+
+EAPI=4
+
+KMNAME="kde-workspace"
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+COMMONDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_has 3dnow X86_3DNOW)
+ $(cmake-utils_use_has altivec PPC_ALTIVEC)
+ $(cmake-utils_use_has mmx X86_MMX)
+ $(cmake-utils_use_has sse X86_SSE)
+ $(cmake-utils_use_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama)
+ )
+
+ kde4-meta_src_configure
+}