summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-10-02 18:12:30 +0000
committerJohannes Huber <johu@gentoo.org>2012-10-02 18:12:30 +0000
commite24d1892c460e245f1dd758fe478f50e1365610d (patch)
treecdfa55b52059355077e16df18b81627a78ffa553 /kde-base/kdeplasma-addons
parentUpdate dev channel mask for beta release of chromium-23. (diff)
downloadhistorical-e24d1892c460e245f1dd758fe478f50e1365610d.tar.gz
historical-e24d1892c460e245f1dd758fe478f50e1365610d.tar.bz2
historical-e24d1892c460e245f1dd758fe478f50e1365610d.zip
Version bump KDE SC 4.9.2
Package-Manager: portage-2.2.0_alpha134/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kdeplasma-addons')
-rw-r--r--kde-base/kdeplasma-addons/ChangeLog7
-rw-r--r--kde-base/kdeplasma-addons/kdeplasma-addons-4.9.2.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/kde-base/kdeplasma-addons/ChangeLog b/kde-base/kdeplasma-addons/ChangeLog
index 17e2c4b0e45b..d40bac9d5137 100644
--- a/kde-base/kdeplasma-addons/ChangeLog
+++ b/kde-base/kdeplasma-addons/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdeplasma-addons
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.150 2012/09/21 09:32:52 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.151 2012/10/02 18:12:15 johu Exp $
+
+*kdeplasma-addons-4.9.2 (02 Oct 2012)
+
+ 02 Oct 2012; Johannes Huber <johu@gentoo.org> +kdeplasma-addons-4.9.2.ebuild:
+ Version bump KDE SC 4.9.2
21 Sep 2012; Johannes Huber <johu@gentoo.org> -kdeplasma-addons-4.9.0.ebuild:
Remove KDE SC 4.9.0
diff --git a/kde-base/kdeplasma-addons/kdeplasma-addons-4.9.2.ebuild b/kde-base/kdeplasma-addons/kdeplasma-addons-4.9.2.ebuild
new file mode 100644
index 000000000000..e7d2d4b6b9c8
--- /dev/null
+++ b/kde-base/kdeplasma-addons/kdeplasma-addons-4.9.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/kdeplasma-addons-4.9.2.ebuild,v 1.1 2012/10/02 18:12:15 johu Exp $
+
+EAPI=4
+
+inherit kde4-base
+
+DESCRIPTION="Extra Plasma applets and engines"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2 LGPL-2"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="attica debug desktopglobe exif fcitx ibus json oauth qalculate qwt scim
+semantic-desktop"
+
+# krunner is only needed to generate dbus interface for lancelot
+COMMON_DEPEND="
+ app-crypt/qca:2
+ app-crypt/qca-ossl:2
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep krunner)
+ $(add_kdebase_dep plasma-workspace 'semantic-desktop=')
+ x11-misc/shared-mime-info
+ attica? ( dev-libs/libattica )
+ desktopglobe? ( $(add_kdebase_dep marble) )
+ exif? ( $(add_kdebase_dep libkexiv2) )
+ fcitx? ( app-i18n/fcitx[dbus(+)] )
+ ibus? ( app-i18n/ibus )
+ json? ( dev-libs/qjson )
+ oauth? ( dev-libs/qoauth )
+ qalculate? ( sci-libs/libqalculate )
+ qwt? ( x11-libs/qwt:5 )
+ scim? ( app-i18n/scim )
+ semantic-desktop? (
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep plasma-workspace 'rss')
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:2
+"
+RDEPEND="${COMMON_DEPEND}
+"
+
+src_configure() {
+ mycmakeargs=(
+ -DDBUS_INTERFACES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/interfaces/"
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_with desktopglobe Marble)
+ $(cmake-utils_use_with exif Kexiv2)
+ $(cmake-utils_use_with ibus)
+ $(cmake-utils_use_with json QJSON)
+ $(cmake-utils_use_with oauth QtOAuth)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with qwt)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with scim)
+ )
+
+ kde4-base_src_configure
+}