summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-10-12 13:32:54 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-10-12 13:32:54 +0000
commitfe1059f8c562d3bf4a890036ca21bc47431453a9 (patch)
tree94909a9c006294c8c3c2b8980bde61d28c6e5dee /kde-base/kdegraphics
parentClock skew fix for AMD64 X2, and update to Linux 2.6.13.4 (diff)
downloadhistorical-fe1059f8c562d3bf4a890036ca21bc47431453a9.tar.gz
historical-fe1059f8c562d3bf4a890036ca21bc47431453a9.tar.bz2
historical-fe1059f8c562d3bf4a890036ca21bc47431453a9.zip
New version.
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'kde-base/kdegraphics')
-rw-r--r--kde-base/kdegraphics/ChangeLog7
-rw-r--r--kde-base/kdegraphics/files/digest-kdegraphics-3.4.31
-rw-r--r--kde-base/kdegraphics/kdegraphics-3.4.3.ebuild67
3 files changed, 74 insertions, 1 deletions
diff --git a/kde-base/kdegraphics/ChangeLog b/kde-base/kdegraphics/ChangeLog
index ff0511ff148d..6224a62623d3 100644
--- a/kde-base/kdegraphics/ChangeLog
+++ b/kde-base/kdegraphics/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdegraphics
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/ChangeLog,v 1.187 2005/10/06 23:24:55 hardave Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/ChangeLog,v 1.188 2005/10/12 13:25:26 greg_g Exp $
+
+*kdegraphics-3.4.3 (12 Oct 2005)
+
+ 12 Oct 2005; Gregorio Guidi <greg_g@gentoo.org> +kdegraphics-3.4.3.ebuild:
+ New version.
06 Oct 2005; Hardave Riar <hardave@gentoo.org>
kdegraphics-3.4.2-r2.ebuild:
diff --git a/kde-base/kdegraphics/files/digest-kdegraphics-3.4.3 b/kde-base/kdegraphics/files/digest-kdegraphics-3.4.3
new file mode 100644
index 000000000000..2cb888ba9f29
--- /dev/null
+++ b/kde-base/kdegraphics/files/digest-kdegraphics-3.4.3
@@ -0,0 +1 @@
+MD5 e2b2926301204a0f587d9e6e163c06d9 kdegraphics-3.4.3.tar.bz2 6554272
diff --git a/kde-base/kdegraphics/kdegraphics-3.4.3.ebuild b/kde-base/kdegraphics/kdegraphics-3.4.3.ebuild
new file mode 100644
index 000000000000..25dc7761ee2a
--- /dev/null
+++ b/kde-base/kdegraphics/kdegraphics-3.4.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdegraphics/kdegraphics-3.4.3.ebuild,v 1.1 2005/10/12 13:25:26 greg_g Exp $
+
+inherit kde-dist eutils
+
+DESCRIPTION="KDE graphics-related apps"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE="gphoto2 imlib nodrm openexr opengl povray scanner tetex"
+
+DEPEND="~kde-base/kdebase-${PV}
+ >=media-libs/freetype-2
+ media-libs/fontconfig
+ gphoto2? ( media-libs/libgphoto2 )
+ scanner? ( media-gfx/sane-backends )
+ media-libs/libart_lgpl
+ media-libs/lcms
+ dev-libs/fribidi
+ imlib? ( media-libs/imlib )
+ virtual/ghostscript
+ media-libs/tiff
+ openexr? ( >=media-libs/openexr-1.2 )
+ povray? ( media-gfx/povray
+ virtual/opengl )"
+
+RDEPEND="${DEPEND}
+ app-text/xpdf
+ tetex? (
+ || ( >=app-text/tetex-2
+ app-text/ptex
+ app-text/cstetex
+ app-text/dvipdfm ) )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ kde_src_unpack
+
+ # Fix detection of gocr (kde bug 90082).
+ epatch "${FILESDIR}/kdegraphics-3.4.1-gocr.patch"
+
+ # Configure patch. Applied for 3.5.
+ epatch "${FILESDIR}/kdegraphics-3.4-configure.patch"
+
+ # For the configure patch.
+ make -f admin/Makefile.common || die
+}
+
+src_compile() {
+ if use gphoto2; then
+ myconf="${myconf} --with-kamera \
+ --with-gphoto2-includes=/usr/include/gphoto2 \
+ --with-gphoto2-libraries=/usr/lib/gphoto2"
+ else
+ myconf="${myconf} --without-kamera"
+ fi
+
+ use scanner || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kooka libkscan"
+ use povray || export DO_NOT_COMPILE="${DO_NOT_COMPILE} kpovmodeler"
+
+ myconf="${myconf} $(use_with imlib) $(use_enable !nodrm kpdf-drm)
+ $(use_with openexr)"
+
+ kde_src_compile
+}