summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
commit86166760b8aa7e1c789581787e2f7bd3d159df87 (patch)
tree3c1095c1c98ae9f6510c9d93134aa0062970a3bd /kde-base/kdeaccessibility
parentEnabled support for openmpi and mpich2 (see bug #210639). (diff)
downloadhistorical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.gz
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.bz2
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.zip
Version bump to KDE 3.5.9.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/kdeaccessibility')
-rw-r--r--kde-base/kdeaccessibility/ChangeLog8
-rw-r--r--kde-base/kdeaccessibility/kdeaccessibility-3.5.9.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/kde-base/kdeaccessibility/ChangeLog b/kde-base/kdeaccessibility/ChangeLog
index 4060bc7731a3..a1b63b427b1c 100644
--- a/kde-base/kdeaccessibility/ChangeLog
+++ b/kde-base/kdeaccessibility/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdeaccessibility
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaccessibility/ChangeLog,v 1.152 2008/02/18 23:54:36 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaccessibility/ChangeLog,v 1.153 2008/02/20 22:42:13 philantrop Exp $
+
+*kdeaccessibility-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kdeaccessibility-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
18 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-kdeaccessibility-3.5.5.ebuild:
diff --git a/kde-base/kdeaccessibility/kdeaccessibility-3.5.9.ebuild b/kde-base/kdeaccessibility/kdeaccessibility-3.5.9.ebuild
new file mode 100644
index 000000000000..35d10b742c55
--- /dev/null
+++ b/kde-base/kdeaccessibility/kdeaccessibility-3.5.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeaccessibility/kdeaccessibility-3.5.9.ebuild,v 1.1 2008/02/20 22:42:13 philantrop Exp $
+
+EAPI="1"
+inherit kde-dist
+
+DESCRIPTION="KDE accessibility module"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="alsa"
+
+DEPEND="media-libs/akode
+ alsa? ( media-libs/alsa-lib )"
+
+RDEPEND="${DEPEND}
+ || ( app-accessibility/festival
+ app-accessibility/epos
+ app-accessibility/flite
+ app-accessibility/freetts )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ local myconf="--with-akode
+ $(use_with alsa)
+ --without-gstreamer"
+
+ # Fix the desktop file.
+ sed -i -e "s:MimeTypes=:MimeType=:" ./kttsd/kttsmgr/kttsmgr.desktop
+
+ kde_src_compile
+}
+
+pkg_postinst() {
+ kde_pkg_postinst
+ echo
+ elog "${P} has some optional dependencies which you might want to emerge:"
+ elog "- app-accessibility/festival to enable the Festival text to speech engine."
+ elog "- app-accessibility/epos to enable the epos text to speech engine."
+ elog "- app-accessibility/flite to enable the Flite text to speech engine."
+ elog "- app-accessibility/freetts for enabling the freetts text to speech engine."
+ echo
+}