summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-07 00:22:11 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-07 00:22:11 +0000
commitee5e4f34061337ffcea150f1c790eea2f794e41c (patch)
tree823b8b79eb6d56c4166f6755dd39875eea0cc790 /kde-base/kde-l10n
parentRename modprobe.d/alsa file to alsa.conf. (diff)
downloadhistorical-ee5e4f34061337ffcea150f1c790eea2f794e41c.tar.gz
historical-ee5e4f34061337ffcea150f1c790eea2f794e41c.tar.bz2
historical-ee5e4f34061337ffcea150f1c790eea2f794e41c.zip
Version bump KDE 4.2.3
Package-Manager: portage-2.2_rc31/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kde-l10n')
-rw-r--r--kde-base/kde-l10n/ChangeLog7
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.2.3.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/kde-base/kde-l10n/ChangeLog b/kde-base/kde-l10n/ChangeLog
index 83c66f8f7f46..d1f44cec0871 100644
--- a/kde-base/kde-l10n/ChangeLog
+++ b/kde-base/kde-l10n/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kde-l10n
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.25 2009/04/17 06:22:24 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.26 2009/05/06 23:11:27 scarabeus Exp $
+
+*kde-l10n-4.2.3 (06 May 2009)
+
+ 06 May 2009; Tomas Chvatal <scarabeus@gentoo.org> +kde-l10n-4.2.3.ebuild:
+ Version bump
17 Apr 2009; Alexey Shvetsov <alexxy@gentoo.org> kde-l10n-4.2.2:
Restore ~hppa keywords
diff --git a/kde-base/kde-l10n/kde-l10n-4.2.3.ebuild b/kde-base/kde-l10n/kde-l10n-4.2.3.ebuild
new file mode 100644
index 000000000000..78b175a98d97
--- /dev/null
+++ b/kde-base/kde-l10n/kde-l10n-4.2.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.2.3.ebuild,v 1.1 2009/05/06 23:11:27 scarabeus Exp $
+
+EAPI="2"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="sys-devel/gettext"
+RDEPEND=""
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+MY_LANGS="ar bg bn_IN ca cs csb da de el en_GB es et eu fi fr ga gl gu he hi hu
+ is it ja kk km kn ko ku lt lv mai mk ml mr nb nds nl nn pa pl pt pt_BR
+ ro ru sk sl sr sv tg th tr uk wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/${PN}-${MY_LANG}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local LNG DIR
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # add all linguas to cmake
+ if [[ -n ${A} ]]; then
+ for LNG in ${LINGUAS}; do
+ DIR="${PN}-${LNG}-${PV}"
+ if [[ -d "${DIR}" ]] ; then
+ echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
+ fi
+ done
+ fi
+}
+
+src_configure() {
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}