summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-10-06 18:11:13 +0000
commit89e71ef45253e6d197ba528112eeae6984651626 (patch)
tree043bfec14e51381244a2ec0e91acb3879eae0a5c /kde-base/kcalc
parentInitial import. New dependency for forthcoming Rails 3.1 release. (diff)
downloadhistorical-89e71ef45253e6d197ba528112eeae6984651626.tar.gz
historical-89e71ef45253e6d197ba528112eeae6984651626.tar.bz2
historical-89e71ef45253e6d197ba528112eeae6984651626.zip
[kde-base] KDE SC 4.7.2
Package-Manager: portage-2.2.0_alpha61/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kcalc')
-rw-r--r--kde-base/kcalc/ChangeLog7
-rw-r--r--kde-base/kcalc/kcalc-4.7.2.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/kde-base/kcalc/ChangeLog b/kde-base/kcalc/ChangeLog
index 73a692d7e6a6..8d8a5e015546 100644
--- a/kde-base/kcalc/ChangeLog
+++ b/kde-base/kcalc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kcalc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcalc/ChangeLog,v 1.187 2011/09/07 20:13:46 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcalc/ChangeLog,v 1.188 2011/10/06 18:10:52 alexxy Exp $
+
+*kcalc-4.7.2 (06 Oct 2011)
+
+ 06 Oct 2011; Alexey Shvetsov <alexxy@gentoo.org> +kcalc-4.7.2.ebuild:
+ Version bump KDE SC 4.7.2
*kcalc-4.7.1 (07 Sep 2011)
diff --git a/kde-base/kcalc/kcalc-4.7.2.ebuild b/kde-base/kcalc/kcalc-4.7.2.ebuild
new file mode 100644
index 000000000000..7e20d26f2894
--- /dev/null
+++ b/kde-base/kcalc/kcalc-4.7.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcalc/kcalc-4.7.2.ebuild,v 1.1 2011/10/06 18:10:52 alexxy Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+CPPUNIT_REQUIRED="optional"
+KDE_SCM="git"
+if [[ ${PV} == *9999 ]]; then
+ kde_eclass="kde4-base"
+else
+ KMNAME="kdeutils"
+ kde_eclass="kde4-meta"
+fi
+inherit ${kde_eclass}
+
+DESCRIPTION="KDE calculator"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/gmp
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris-knumber_priv.patch
+)
+
+src_test() {
+ LANG=C ${kde_eclass}_src_test
+}