summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-12-02 21:18:24 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-12-02 21:18:24 +0000
commit307c276a3b4c55dca98f0a87512c3cbb4ace9264 (patch)
treebe7fdf498714778819009f86b7aa2b771e52ebd1 /kde-base/kate
parentMask KDE SC 4.5 due to missing deps on ppc ppc64 and x86-fbsd. bug #336158 (diff)
downloadhistorical-307c276a3b4c55dca98f0a87512c3cbb4ace9264.tar.gz
historical-307c276a3b4c55dca98f0a87512c3cbb4ace9264.tar.bz2
historical-307c276a3b4c55dca98f0a87512c3cbb4ace9264.zip
[kde-base] Add KDE SC 4.5.4
Package-Manager: portage-2.2.0_alpha6_p10/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kate')
-rw-r--r--kde-base/kate/ChangeLog7
-rw-r--r--kde-base/kate/kate-4.5.4.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/kde-base/kate/ChangeLog b/kde-base/kate/ChangeLog
index 96669e160382..673262615b7b 100644
--- a/kde-base/kate/ChangeLog
+++ b/kde-base/kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kate
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.186 2010/11/03 16:30:41 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/ChangeLog,v 1.187 2010/12/02 21:16:52 alexxy Exp $
+
+*kate-4.5.4 (02 Dec 2010)
+
+ 02 Dec 2010; Alexey Shvetsov <alexxy@gentoo.org> +kate-4.5.4.ebuild:
+ Version bump KDE SC 4.5.4
*kate-4.5.3 (03 Nov 2010)
diff --git a/kde-base/kate/kate-4.5.4.ebuild b/kde-base/kate/kate-4.5.4.ebuild
new file mode 100644
index 000000000000..3cb50a4b1c9a
--- /dev/null
+++ b/kde-base/kate/kate-4.5.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kate/kate-4.5.4.ebuild,v 1.1 2010/12/02 21:16:52 alexxy Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Kate is an MDI texteditor."
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +plasma"
+
+DEPEND="
+ dev-libs/libxml2
+ dev-libs/libxslt
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with plasma)
+ )
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kaddressbook:${SLOT}; then
+ echo
+ elog "File templates plugin requires kde-base/kaddressbook:${SLOT}."
+ elog "Please install it if you plan to use this plugin."
+ echo
+ fi
+}