summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-03 21:49:41 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-03 21:49:41 +0000
commitc720f79a21ec6fc47b92109987daca264d416bff (patch)
tree1b6bd65f854b288e82f20100a5ed85c008e3511e /kde-base/kalgebra
parentadded ~amd64 (diff)
downloadhistorical-c720f79a21ec6fc47b92109987daca264d416bff.tar.gz
historical-c720f79a21ec6fc47b92109987daca264d416bff.tar.bz2
historical-c720f79a21ec6fc47b92109987daca264d416bff.zip
Version bump to KDE 4.0.3. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/kalgebra')
-rw-r--r--kde-base/kalgebra/ChangeLog9
-rw-r--r--kde-base/kalgebra/kalgebra-4.0.3.ebuild39
2 files changed, 47 insertions, 1 deletions
diff --git a/kde-base/kalgebra/ChangeLog b/kde-base/kalgebra/ChangeLog
index 449bc5ae3c6c..aa8d48be06f5 100644
--- a/kde-base/kalgebra/ChangeLog
+++ b/kde-base/kalgebra/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/kalgebra
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.7 2008/03/20 16:20:44 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.8 2008/04/03 20:38:18 philantrop Exp $
+
+*kalgebra-4.0.3 (03 Apr 2008)
+
+ 03 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kalgebra-4.0.3.ebuild:
+ Version bump to KDE 4.0.3. This is still not intended for mainstream so DO
+ NOT KEYWORD IT without talking to the KDE herd first.
20 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-files/kalgebra-4.0.1-opengl.patch, -kalgebra-4.0.1.ebuild:
diff --git a/kde-base/kalgebra/kalgebra-4.0.3.ebuild b/kde-base/kalgebra/kalgebra-4.0.3.ebuild
new file mode 100644
index 000000000000..c032af061fe6
--- /dev/null
+++ b/kde-base/kalgebra/kalgebra-4.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/kalgebra-4.0.3.ebuild,v 1.1 2008/04/03 20:38:18 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdeedu
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="MathML-based graph calculator for KDE."
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook opengl readline"
+
+DEPEND="opengl? ( virtual/opengl )
+ readline? ( sys-libs/readline )"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY=libkdeedu/kdeeduui
+
+# Needed for USE="-opengl"
+PATCHES="${FILESDIR}/${PN}-4.0.2-opengl.patch"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with readline Readline)
+ $(cmake-utils_use_with opengl OpenGL)"
+
+ kde4-meta_src_compile
+}
+
+src_test() {
+# Miraculously, the tests seem to have been fixed. Leaving this in for now, though.
+# sed -i -e '/functiontest/ s/^/#DONOTRUNTEST/' \
+# kalgebra/src/tests/CMakeLists.txt || \
+# die "Failed to disable functiontest."
+
+ kde4-meta_src_test
+}