summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2012-04-12 20:18:40 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2012-04-12 20:18:40 +0000
commit79a0f26d9587bad1676583d94849171ae605616e (patch)
tree8f7597a2e82ea2aa0969b7683260228e00d297f4 /gnome-extra/drwright/drwright-3.2.5.ebuild
parentVersion bump to 2.0.6_rc1 (diff)
downloadhistorical-79a0f26d9587bad1676583d94849171ae605616e.tar.gz
historical-79a0f26d9587bad1676583d94849171ae605616e.tar.bz2
historical-79a0f26d9587bad1676583d94849171ae605616e.zip
Version bump. Clean up old revisions.
Package-Manager: portage-2.2.0_alpha100/cvs/Linux x86_64
Diffstat (limited to 'gnome-extra/drwright/drwright-3.2.5.ebuild')
-rw-r--r--gnome-extra/drwright/drwright-3.2.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/drwright/drwright-3.2.5.ebuild b/gnome-extra/drwright/drwright-3.2.5.ebuild
new file mode 100644
index 000000000000..af991ddab016
--- /dev/null
+++ b/gnome-extra/drwright/drwright-3.2.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/drwright/drwright-3.2.5.ebuild,v 1.1 2012/04/12 20:18:40 eva Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="A GNOME 3 tool that forces you to take regular breaks to prevent RSI"
+HOMEPAGE="http://git.gnome.org/browse/drwright"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.26.0:2
+ >=x11-libs/gtk+-3.0.0:3
+ >=gnome-base/gnome-settings-daemon-2.91.8
+ >=gnome-base/gnome-control-center-3.2
+ >=x11-libs/libnotify-0.7
+ media-libs/libcanberra[gtk3]
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+"
+DEPEND="${RDEPEND}
+ x11-proto/scrnsaverproto
+ sys-devel/gettext
+ >=dev-util/intltool-0.35.0
+ >=dev-util/pkgconfig-0.12.0
+ || ( dev-util/gtk-builder-convert <=x11-libs/gtk+-2.24.10:2 )
+"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog NEWS"
+ G2CONF="${G2CONF} --disable-static"
+}