summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYi Quang <khai@gentoo.org>2004-04-22 03:15:08 +0000
committerYi Quang <khai@gentoo.org>2004-04-22 03:15:08 +0000
commit7478f86728dbc3e4978392dc3dbd993d0358b4cc (patch)
treee3c8983b7ae8ba535cb81f7fd995ce1dd171bb18 /gnome-base/libgnomeprint/libgnomeprint-2.6.1.ebuild
parentupdate USE flags for gcc (diff)
downloadhistorical-7478f86728dbc3e4978392dc3dbd993d0358b4cc.tar.gz
historical-7478f86728dbc3e4978392dc3dbd993d0358b4cc.tar.bz2
historical-7478f86728dbc3e4978392dc3dbd993d0358b4cc.zip
Version bump.
Diffstat (limited to 'gnome-base/libgnomeprint/libgnomeprint-2.6.1.ebuild')
-rw-r--r--gnome-base/libgnomeprint/libgnomeprint-2.6.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnome-base/libgnomeprint/libgnomeprint-2.6.1.ebuild b/gnome-base/libgnomeprint/libgnomeprint-2.6.1.ebuild
new file mode 100644
index 000000000000..87ce4bbb3e20
--- /dev/null
+++ b/gnome-base/libgnomeprint/libgnomeprint-2.6.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/libgnomeprint-2.6.1.ebuild,v 1.1 2004/04/22 03:15:08 khai Exp $
+
+inherit gnome2
+
+DESCRIPTION="Printer handling for Gnome"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="2.2"
+KEYWORDS="~x86 ~ppc ~alpha ~sparc ~hppa ~amd64 ~ia64 ~mips"
+IUSE="cups doc"
+
+RDEPEND=">=dev-libs/glib-2
+ sys-libs/zlib
+ dev-libs/popt
+ >=x11-libs/pango-1
+ >=media-libs/fontconfig-1
+ >=media-libs/libart_lgpl-2.3.7
+ >=dev-libs/libxml2-2.4.23
+ >=media-libs/freetype-2.0.5
+ cups? ( >=net-print/cups-1.1.20 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.29
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+G2CONF="${G2CONF} `use_with cups`"
+
+DOCS="AUTHORS COPYING* ChangeLog* INSTALL NEWS README"