summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-08-19 08:28:51 +0000
committerMart Raudsepp <leio@gentoo.org>2008-08-19 08:28:51 +0000
commit4b028df7efc5232ca675421a00cf78680d9ea733 (patch)
treeb0c816820ef1f96337446c2a38bf82637e55f24d /gnome-base/libglade/libglade-2.6.3.ebuild
parentVersion bump to fix invalid chunk type problem, bug #234916. Removed affected... (diff)
downloadhistorical-4b028df7efc5232ca675421a00cf78680d9ea733.tar.gz
historical-4b028df7efc5232ca675421a00cf78680d9ea733.tar.bz2
historical-4b028df7efc5232ca675421a00cf78680d9ea733.zip
Version bump
Package-Manager: portage-2.2_rc8/cvs/Linux 2.6.26-gentoo x86_64
Diffstat (limited to 'gnome-base/libglade/libglade-2.6.3.ebuild')
-rw-r--r--gnome-base/libglade/libglade-2.6.3.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/gnome-base/libglade/libglade-2.6.3.ebuild b/gnome-base/libglade/libglade-2.6.3.ebuild
new file mode 100644
index 000000000000..b73e4d72f77c
--- /dev/null
+++ b/gnome-base/libglade/libglade-2.6.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libglade/libglade-2.6.3.ebuild,v 1.1 2008/08/19 08:28:51 leio Exp $
+
+# FIXME : catalog stuff
+inherit eutils gnome2
+
+DESCRIPTION="Library to construct graphical interfaces at runtime"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/glib-2.10
+ >=x11-libs/gtk+-2.8.10
+ >=dev-libs/atk-1.9
+ >=dev-libs/libxml2-2.4.10
+ >=dev-lang/python-2.0-r7"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_compile() {
+ # patch to stop make install installing the xml catalog
+ # because we do it ourselves in postinst()
+ epatch "${FILESDIR}"/Makefile.in.am-2.4.2-xmlcatalog.patch
+
+ gnome2_src_compile
+}
+
+src_install() {
+ dodir /etc/xml
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ echo ">>> Updating XML catalog"
+ /usr/bin/xmlcatalog --noout --add "system" \
+ "http://glade.gnome.org/glade-2.0.dtd" \
+ /usr/share/xml/libglade/glade-2.0.dtd /etc/xml/catalog
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ echo ">>> removing entries from the XML catalog"
+ /usr/bin/xmlcatalog --noout --del \
+ /usr/share/xml/libglade/glade-2.0.dtd /etc/xml/catalog
+}