summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-08-31 21:57:36 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-08-31 21:57:36 +0000
commit422bc305f6e483391db93f5805f4e05566658399 (patch)
tree27e568ac1b7df6508bf84cf8d0dc4a02c085e729 /gnome-base/gnome-core
parentstructure cleanup (diff)
downloadhistorical-422bc305f6e483391db93f5805f4e05566658399.tar.gz
historical-422bc305f6e483391db93f5805f4e05566658399.tar.bz2
historical-422bc305f6e483391db93f5805f4e05566658399.zip
removed old files so people don't accidently use them
Diffstat (limited to 'gnome-base/gnome-core')
-rw-r--r--gnome-base/gnome-core/gnome-core-1.4.0.4.ebuild53
1 files changed, 25 insertions, 28 deletions
diff --git a/gnome-base/gnome-core/gnome-core-1.4.0.4.ebuild b/gnome-base/gnome-core/gnome-core-1.4.0.4.ebuild
index 7824252ae76e..0348c4200efe 100644
--- a/gnome-base/gnome-core/gnome-core-1.4.0.4.ebuild
+++ b/gnome-base/gnome-core/gnome-core-1.4.0.4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-core/gnome-core-1.4.0.4.ebuild,v 1.6 2001/08/31 19:00:30 hallski Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-core/gnome-core-1.4.0.4.ebuild,v 1.7 2001/08/31 21:57:36 hallski Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -11,7 +11,6 @@ HOMEPAGE="http://www.gnome.org/"
RDEPEND=">=gnome-base/control-center-1.2.4 >=gnome-base/libglade-0.16-r1"
-#gtkhtml? ( >=gnome-base/gtkhtml-0.7 )
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )
>=gnome-base/gnome-libs-1.2.13
@@ -20,36 +19,34 @@ DEPEND="${RDEPEND}
>=dev-util/xml-i18n-tools-0.8.4"
src_compile() {
- local myconf
- local myldflags
- if [ -z "`use nls`" ] ; then
- myconf="--disable-nls"
- fi
- if [ "`use gtkhtml`" ]
- then
- # does not work !
- #myconf="${myconf} --enable-gtkhtml-help"
- echo
- fi
- if [ "`use kde`" ]
- then
- myconf="${myconf} --with-kde-datadir=/opt/kde2/share"
- fi
- try ./configure --host=${CHOST} --mandir=/opt/gnome/man \
- --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome \
- ${myconf}
- try pmake
-}
-
-src_install() {
- try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome mandir=${D}/opt/gnome/man install
- dodoc AUTHORS COPYING* ChangeLog README NEWS
-}
-
+ local myconf
+ local myldflags
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ if [ "`use gtkhtml`" ]
+ then
+ # does not work !
+ #myconf="${myconf} --enable-gtkhtml-help"
+ fi
+ if [ "`use kde`" ]
+ then
+ myconf="${myconf} --with-kde-datadir=/opt/kde2/share"
+ fi
+ ./configure --host=${CHOST} --mandir=/opt/gnome/man \
+ --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome \
+ ${myconf} || die
+ emake || die
+}
+src_install() {
+ make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome \
+ mandir=${D}/opt/gnome/man install || die
+ dodoc AUTHORS COPYING* ChangeLog README NEWS
+}