summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-01-02 20:17:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-01-02 20:17:23 +0000
commitf8b1ab4b0d493ab80ba766a40d35ee17e425e90f (patch)
treede37f448b00e83191a2eec113fc6a942ef241b6d /games-util
parentversion bump (bug 36592) (diff)
downloadhistorical-f8b1ab4b0d493ab80ba766a40d35ee17e425e90f.tar.gz
historical-f8b1ab4b0d493ab80ba766a40d35ee17e425e90f.tar.bz2
historical-f8b1ab4b0d493ab80ba766a40d35ee17e425e90f.zip
version bump (bug 36592)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/showeq/Manifest6
-rw-r--r--games-util/showeq/files/digest-showeq-4.3.191
-rw-r--r--games-util/showeq/showeq-4.3.18.ebuild4
-rw-r--r--games-util/showeq/showeq-4.3.19.ebuild55
4 files changed, 61 insertions, 5 deletions
diff --git a/games-util/showeq/Manifest b/games-util/showeq/Manifest
index f70feae0220a..7a01ca9982c1 100644
--- a/games-util/showeq/Manifest
+++ b/games-util/showeq/Manifest
@@ -1,6 +1,6 @@
-MD5 f4cedace9b3cfeca83c9cc8fd3d3b0e4 showeq-4.3.18.ebuild 1332
+MD5 4dc5d33431c5b317d9e12c1eef18a2ff showeq-4.3.18.ebuild 1332
MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
-MD5 2effb65f05336df81a053969550fbd7a ChangeLog 612
-MD5 188d2f15caa0df02e4143295b630a8c5 showeq-4.3.19.ebuild 1330
+MD5 eb2622979a0e1556f347dfa261dae430 ChangeLog 771
+MD5 a0696d47db224848068dc9b71166eed3 showeq-4.3.19.ebuild 1330
MD5 750f2683b2b5e599ff1c4f7497225739 files/digest-showeq-4.3.18 67
MD5 a07a58d886a788ffc71ddb7015e61c82 files/digest-showeq-4.3.19 67
diff --git a/games-util/showeq/files/digest-showeq-4.3.19 b/games-util/showeq/files/digest-showeq-4.3.19
new file mode 100644
index 000000000000..a9a8726543f1
--- /dev/null
+++ b/games-util/showeq/files/digest-showeq-4.3.19
@@ -0,0 +1 @@
+MD5 0cd241b5d3cad4d7c7978a3b9833334d ShowEQ-4.3.19.tar.bz2 1920256
diff --git a/games-util/showeq/showeq-4.3.18.ebuild b/games-util/showeq/showeq-4.3.18.ebuild
index d9e02e2eee86..3418f9246f2a 100644
--- a/games-util/showeq/showeq-4.3.18.ebuild
+++ b/games-util/showeq/showeq-4.3.18.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/showeq-4.3.18.ebuild,v 1.3 2003/12/03 01:50:24 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/showeq-4.3.18.ebuild,v 1.4 2004/01/02 20:17:16 mr_bones_ Exp $
inherit games
diff --git a/games-util/showeq/showeq-4.3.19.ebuild b/games-util/showeq/showeq-4.3.19.ebuild
new file mode 100644
index 000000000000..10c8a51d781d
--- /dev/null
+++ b/games-util/showeq/showeq-4.3.19.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/showeq/showeq-4.3.19.ebuild,v 1.1 2004/01/02 20:17:16 mr_bones_ Exp $
+
+inherit games
+
+S="${WORKDIR}/${PN}"
+DESCRIPTION="A Everquest monitoring program"
+HOMEPAGE="http://seq.sourceforge.net"
+SRC_URI="mirror://sourceforge/seq/ShowEQ-${PV}.tar.bz2"
+
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/x11
+ sys-devel/libtool
+ sys-devel/autoconf
+ sys-devel/automake
+ media-libs/libpng
+ >=net-libs/libpcap-0.6.2
+ >=x11-libs/qt-3.1
+ >=sys-libs/gdbm-1.8.0
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "/CFLAGS/s:-O2:${CFLAGS}:" \
+ -e "/CXXFLAGS/s:-O2:${CXXFLAGS}:" acinclude.m4 || \
+ die "sed acinclude.m4 failed"
+ sed -i \
+ -e "/OPT_CXX=/s:-O2:${CXXFLAGS}:" \
+ -e "/OPT_C=/s:-O2:${CFLAGS}:" configure.in || \
+ die "sed configure.in failed"
+}
+
+src_compile() {
+ cd ${S}
+ make -f Makefile.dist || die "make failed"
+ egamesconf || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ egamesinstall || die
+ doman showeq.1 || die "doman failed"
+ dodoc BUGS CHANGES FAQ INSTALL README* ROADMAP TODO doc/*.{doc,txt} || \
+ die "dodoc failed"
+ dohtml doc/* || die "dohtml failed"
+ prepgamesdirs
+}