summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-04-08 07:46:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-04-08 07:46:38 +0000
commit0c826dfd65368abcf6c90bc4f8f0953e4ef06652 (patch)
treedbb866d7cc0cf37f043c90bc670bc2f12de20348 /games-util/grfcodec/grfcodec-0_pre2306.ebuild
parentstable x86, bug 307847 (diff)
downloadhistorical-0c826dfd65368abcf6c90bc4f8f0953e4ef06652.tar.gz
historical-0c826dfd65368abcf6c90bc4f8f0953e4ef06652.tar.bz2
historical-0c826dfd65368abcf6c90bc4f8f0953e4ef06652.zip
initial commit - ebuild and patch submitted by Locke 'Wizzleby' Shinseiko via bug #300328
Package-Manager: portage-2.1.7.17/cvs/Linux i686
Diffstat (limited to 'games-util/grfcodec/grfcodec-0_pre2306.ebuild')
-rw-r--r--games-util/grfcodec/grfcodec-0_pre2306.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/games-util/grfcodec/grfcodec-0_pre2306.ebuild b/games-util/grfcodec/grfcodec-0_pre2306.ebuild
new file mode 100644
index 000000000000..37dfbed13fe1
--- /dev/null
+++ b/games-util/grfcodec/grfcodec-0_pre2306.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/grfcodec/grfcodec-0_pre2306.ebuild,v 1.1 2010/04/08 07:46:37 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+MY_PV=${PV/0_pre/r}
+DESCRIPTION="A suite of programs to modify openttd/Transport Tycoon Deluxe's GRF files"
+HOMEPAGE="http://binaries.openttd.org/extra/grfcodec/"
+SRC_URI="http://binaries.openttd.org/extra/grfcodec/${MY_PV}/${PN}-${MY_PV}-source.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+DEPEND="dev-lang/perl
+ dev-libs/boost"
+RDEPEND=""
+
+src_prepare() {
+ cat > Makefile.local <<-__EOF__
+ CC = $(tc-getCC)
+ CXX = $(tc-getCXX)
+ CFLAGS = ${CFLAGS}
+ CXXFLAGS = ${CXXFLAGS}
+ LDOPTS = ${LDFLAGS}
+ STRIP = :
+ V = 1
+ __EOF__
+
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_install() {
+ dobin ${PN} grf{diff,merge} || die
+ dodoc *.txt Changelog || die
+}