summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-06-01 20:21:09 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-06-01 20:21:09 +0000
commit3a71029af40cb47e4efbf5b4895cdb0af8e4bf98 (patch)
tree2365d3471eff66ce4a1cb5f84da8e9d6374528be /games-strategy/wargus
parentle is not lt in bash comparsion. Fixes bug#419149. (diff)
downloadhistorical-3a71029af40cb47e4efbf5b4895cdb0af8e4bf98.tar.gz
historical-3a71029af40cb47e4efbf5b4895cdb0af8e4bf98.tar.bz2
historical-3a71029af40cb47e4efbf5b4895cdb0af8e4bf98.zip
revbump, fix underlinking, split wargus-data and fix sandbox violation wrt #418051 and #419143
Package-Manager: portage-2.2.0_alpha108/cvs/Linux x86_64
Diffstat (limited to 'games-strategy/wargus')
-rw-r--r--games-strategy/wargus/ChangeLog9
-rw-r--r--games-strategy/wargus/files/wargus-2.2.6-underlinking.patch18
-rw-r--r--games-strategy/wargus/wargus-2.2.6-r2.ebuild (renamed from games-strategy/wargus/wargus-2.2.6-r1.ebuild)22
3 files changed, 33 insertions, 16 deletions
diff --git a/games-strategy/wargus/ChangeLog b/games-strategy/wargus/ChangeLog
index 91a1291a2595..52213be1c2f7 100644
--- a/games-strategy/wargus/ChangeLog
+++ b/games-strategy/wargus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-strategy/wargus
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wargus/ChangeLog,v 1.19 2012/05/28 13:18:06 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wargus/ChangeLog,v 1.20 2012/06/01 20:21:09 hasufell Exp $
+
+*wargus-2.2.6-r2 (01 Jun 2012)
+
+ 01 Jun 2012; Julian Ospald <hasufell@gentoo.org> -wargus-2.2.6-r1.ebuild,
+ +wargus-2.2.6-r2.ebuild, +files/wargus-2.2.6-underlinking.patch:
+ revbump, fix underlinking, split wargus-data and fix sandbox violation wrt
+ #418051 and #419143
*wargus-2.2.6-r1 (28 May 2012)
diff --git a/games-strategy/wargus/files/wargus-2.2.6-underlinking.patch b/games-strategy/wargus/files/wargus-2.2.6-underlinking.patch
new file mode 100644
index 000000000000..e3e11db165d1
--- /dev/null
+++ b/games-strategy/wargus/files/wargus-2.2.6-underlinking.patch
@@ -0,0 +1,18 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Jun 1 20:15:57 UTC 2012
+Subject: build system
+
+fix underlinking
+see: https://bugs.launchpad.net/wargus/+bug/1007586
+
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -157,7 +157,7 @@
+
+ if(NOT WIN32)
+ include_directories(${GTK2_INCLUDE_DIRS})
+- set(wargus_LIBS ${wargus_LIBS} ${GTK2_LIBRARIES})
++ set(wargus_LIBS ${wargus_LIBS} ${GTK2_LIBRARIES} X11)
+ endif()
+
+ if (NOT WIN32 AND NOT MAEMO)
diff --git a/games-strategy/wargus/wargus-2.2.6-r1.ebuild b/games-strategy/wargus/wargus-2.2.6-r2.ebuild
index 58486454e992..4e4a0d3c6aa4 100644
--- a/games-strategy/wargus/wargus-2.2.6-r1.ebuild
+++ b/games-strategy/wargus/wargus-2.2.6-r2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wargus/wargus-2.2.6-r1.ebuild,v 1.1 2012/05/28 13:18:06 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wargus/wargus-2.2.6-r2.ebuild,v 1.1 2012/06/01 20:21:09 hasufell Exp $
EAPI=2
-inherit eutils cdrom cmake-utils gnome2-utils games
+inherit eutils cmake-utils gnome2-utils games
-DESCRIPTION="Warcraft II for the Stratagus game engine (Needs WC2 DOS CD)"
+DESCRIPTION="Warcraft II for the Stratagus game engine"
HOMEPAGE="http://wargus.sourceforge.net/"
SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${PN}_${PV}.orig.tar.gz"
@@ -20,17 +20,15 @@ RDEPEND="=games-engines/stratagus-${PV}*[theora]
sys-libs/zlib
x11-libs/gtk+:2"
DEPEND="${RDEPEND}
- media-sound/cdparanoia
- media-sound/timidity++
- media-video/ffmpeg2theora
virtual/pkgconfig"
+PDEPEND="games-strategy/wargus-data"
S=${WORKDIR}/${PN}_${PV}.orig
src_prepare() {
- cdrom_get_cds data/rezdat.war
epatch "${FILESDIR}/${PN}-2.2.5.5-libpng.patch" \
- "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-build.patch" \
+ "${FILESDIR}/${P}-underlinking.patch"
sed \
-e "/^Exec/s#/usr/games/wargus#${GAMES_BINDIR}/wargus#" \
@@ -53,12 +51,6 @@ src_compile() {
src_install() {
cmake-utils_src_install
-
- local dir=${GAMES_DATADIR}/stratagus/${PN}
-
- "${D}"/usr/games/bin/wartool -m -v -r "${CDROM_ROOT}"/data "${D}/${dir}" \
- || die "Failed to extract data"
-
prepgamesdirs
}
@@ -68,7 +60,7 @@ pkg_preinst() {
}
pkg_postinst() {
- elog "Enabling OpenGL ingame seems to cause segfaults/crashes."
+ elog "Enabling OpenGL in-game seems to cause segfaults/crashes."
games_pkg_postinst
gnome2_icon_cache_update
}