summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-08-10 00:35:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-08-10 00:35:30 +0000
commit591c7509f3a169191ab9991fdf20d53cd44b27f5 (patch)
tree9192d1e95942057e755cc2af62079f433b5ff13c /games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild
parentVersion bump (diff)
downloadhistorical-591c7509f3a169191ab9991fdf20d53cd44b27f5.tar.gz
historical-591c7509f3a169191ab9991fdf20d53cd44b27f5.tar.bz2
historical-591c7509f3a169191ab9991fdf20d53cd44b27f5.zip
EAPI=2
Package-Manager: portage-2.1.6.13/cvs/Linux i686
Diffstat (limited to 'games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild')
-rw-r--r--games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild15
1 files changed, 8 insertions, 7 deletions
diff --git a/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild b/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild
index 3d8e2ae9fdcb..047aa214de83 100644
--- a/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild
+++ b/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild,v 1.1 2008/10/04 19:46:06 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/ufo-ai/ufo-ai-2.2.1.ebuild,v 1.2 2009/08/10 00:35:30 mr_bones_ Exp $
+EAPI=2
inherit eutils autotools games
MY_P="${P/o-a/oa}"
@@ -39,11 +40,9 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}-source
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
# move data from packages to source dir
- mv "${WORKDIR}/base" "${S}"
+ mv "${WORKDIR}/base" "${S}" || die
# Set basedir & fixes bug in finding text files - it should use fs_basedir
epatch "${FILESDIR}"/${P}-gentoo.patch
@@ -57,7 +56,7 @@ src_unpack() {
|| die "sed failed"
}
-src_compile() {
+src_configure() {
egamesconf \
$(use_enable mmx) \
--enable-release \
@@ -65,7 +64,9 @@ src_compile() {
--enable-dedicated \
$(use_enable !dedicated client) \
--with-shaders
+}
+src_compile() {
emake lang || die "emake langs failed"
if use doc ; then