summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-01-31 07:27:00 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-01-31 07:27:00 +0000
commit273635aa1df943195e176d7a0b74f6e4a0b7399f (patch)
treef68a24adabaacf35bdf49e22ffac7ad91687c4a9 /games-strategy/freeciv/freeciv-2.1.11.ebuild
parentVersion bump for 5.1 slot, now includes support for Qt Gui. (diff)
downloadhistorical-273635aa1df943195e176d7a0b74f6e4a0b7399f.tar.gz
historical-273635aa1df943195e176d7a0b74f6e4a0b7399f.tar.bz2
historical-273635aa1df943195e176d7a0b74f6e4a0b7399f.zip
version bump
Package-Manager: portage-2.1.7.16/cvs/Linux i686
Diffstat (limited to 'games-strategy/freeciv/freeciv-2.1.11.ebuild')
-rw-r--r--games-strategy/freeciv/freeciv-2.1.11.ebuild162
1 files changed, 162 insertions, 0 deletions
diff --git a/games-strategy/freeciv/freeciv-2.1.11.ebuild b/games-strategy/freeciv/freeciv-2.1.11.ebuild
new file mode 100644
index 000000000000..fa0abd92f15a
--- /dev/null
+++ b/games-strategy/freeciv/freeciv-2.1.11.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freeciv/freeciv-2.1.11.ebuild,v 1.1 2010/01/31 07:27:00 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils gnome2-utils games
+
+DESCRIPTION="multiplayer strategy game (Civilization Clone)"
+HOMEPAGE="http://www.freeciv.org/"
+SRC_URI="mirror://sourceforge/freeciv/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="auth dedicated ggz gtk nls readline sdl Xaw3d"
+
+RDEPEND="readline? ( sys-libs/readline )
+ sys-libs/zlib
+ !dedicated? (
+ nls? ( virtual/libintl )
+ gtk? ( x11-libs/gtk+:2 )
+ !gtk? (
+ sdl? (
+ media-libs/libsdl
+ media-libs/sdl-image
+ media-libs/freetype
+ )
+ !sdl? (
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? ( x11-libs/libXaw )
+ )
+ )
+ ggz? ( dev-games/ggz-client-libs )
+ media-libs/libpng
+ media-libs/alsa-lib
+ media-libs/audiofile
+ sdl? ( media-libs/sdl-mixer )
+ auth? ( virtual/mysql )
+ )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ !dedicated? (
+ gtk? ( dev-util/pkgconfig )
+ x11-proto/xextproto
+ )"
+
+pkg_setup() {
+ games_pkg_setup
+ if ! use dedicated ; then
+ if use gtk ; then
+ einfo "The Freeciv Client will be built with the GTK+-2 toolkit"
+ elif use sdl ; then
+ einfo "The Freeciv Client will be built with the SDL toolkit"
+ elif use Xaw3d ; then
+ einfo "The Freeciv Client will be built with the Xaw3d toolkit"
+ else
+ einfo "The Freeciv Client will be built with the Xaw toolkit"
+ fi
+ fi
+}
+
+src_prepare() {
+ # install locales in /usr/share/locale
+ #sed -i \
+ #-e 's:^\(localedir = \).*:\1/usr/share/locale:' \
+ #intl/Makefile.in po/Makefile.in.in \
+ #|| die "sed failed"
+ #sed -i \
+ #-e 's:$datadir/locale:/usr/share/locale:' \
+ #configure \
+ #|| die "sed failed"
+
+ # change .desktop category so it's freedesktop complient
+ sed -i \
+ -e '/Icon/ s:\.png::' \
+ bootstrap/freeciv.desktop.in \
+ || die "sed failed"
+ # install the .desktop in /usr/share/applications
+ # install the icons in /usr/share/pixmaps
+ sed -i \
+ -e 's:^\(desktopfiledir = \).*:\1/usr/share/applications:' \
+ -e 's:^\(icon[0-9]*dir = \)$(prefix)\(.*\):\1/usr\2:' \
+ -e 's:^\(icon[0-9]*dir = \)$(datadir)\(.*\):\1/usr/share\2:' \
+ client/Makefile.in \
+ server/Makefile.in \
+ data/Makefile.in \
+ data/icons/Makefile.in \
+ || die "sed failed"
+
+ # remove civclient manpage if dedicated server
+ if use dedicated ; then
+ sed -i \
+ -e '/man_MANS = /s:civclient.6::' \
+ doc/man/Makefile.in \
+ || die "sed failed"
+ fi
+}
+
+src_configure() {
+ local mysoundconf
+ local myclient
+
+ if use dedicated ; then
+ myclient="no"
+ else
+ myclient="xaw"
+ use Xaw3d && myclient="xaw3d"
+ use sdl && myclient="sdl"
+ if use gtk ; then
+ myclient="gtk"
+ fi
+ fi
+
+ egamesconf \
+ --disable-dependency-tracking \
+ --localedir=/usr/share/locale \
+ $(use_enable auth) \
+ $(use_enable nls) \
+ $(use_with readline) \
+ $(use_enable sdl sdl-mixer) \
+ $(use_with ggz ggz-client) \
+ --enable-client=${myclient} \
+ ${mysoundconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if ! use dedicated ; then
+ # Install the app-defaults if Xaw/Xaw3d toolkit
+ if ! use gtk && ! use sdl ; then
+ insinto /etc/X11/app-defaults
+ doins data/Freeciv || die "doins failed"
+ fi
+ # Create and install the html manual. It can't be done for dedicated
+ # servers, because the 'civmanual' tool is then not built. Also
+ # delete civmanual from the GAMES_BINDIR, because it's then useless.
+ # Note: to have it localized, it should be ran from _postinst, or
+ # something like that, but then it's a PITA to avoid orphan files...
+ ./manual/civmanual || die "civmanual failed"
+ dohtml manual*.html || die "dohtml failed"
+ rm -f "${D}/${GAMES_BINDIR}"/civmanual
+ fi
+
+ dodoc ChangeLog NEWS doc/{BUGS,CodingStyle,HACKING,HOWTOPLAY,README*,TODO}
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}