summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-19 23:56:42 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-19 23:56:42 +0000
commit03cf18aa1a5f8d7abf6e6435fd5b16814b5547e3 (patch)
tree11a6195f457b8b6d19ab7b97e33ea8dcb453bc09 /games-simulation
parentold (diff)
downloadhistorical-03cf18aa1a5f8d7abf6e6435fd5b16814b5547e3.tar.gz
historical-03cf18aa1a5f8d7abf6e6435fd5b16814b5547e3.tar.bz2
historical-03cf18aa1a5f8d7abf6e6435fd5b16814b5547e3.zip
EAPI=2; add use-based dep
Package-Manager: portage-2.1.6.4/cvs/Linux 2.6.27.8 i686
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/planets/ChangeLog8
-rw-r--r--games-simulation/planets/Manifest4
-rw-r--r--games-simulation/planets/planets-0.1.13.ebuild17
3 files changed, 12 insertions, 17 deletions
diff --git a/games-simulation/planets/ChangeLog b/games-simulation/planets/ChangeLog
index 6194568880bb..154dfe923e79 100644
--- a/games-simulation/planets/ChangeLog
+++ b/games-simulation/planets/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/planets
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/ChangeLog,v 1.16 2008/06/22 21:04:56 opfer Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/ChangeLog,v 1.17 2009/01/19 23:56:42 mr_bones_ Exp $
+
+ 19 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ planets-0.1.13.ebuild:
+ EAPI=2; add use-based dep
22 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
planets-0.1.13.ebuild:
diff --git a/games-simulation/planets/Manifest b/games-simulation/planets/Manifest
index e4ac0447e5a3..8176fc1cbb5e 100644
--- a/games-simulation/planets/Manifest
+++ b/games-simulation/planets/Manifest
@@ -1,4 +1,4 @@
DIST planets-0.1.13.tgz 49732 RMD160 aca43156b191f221f257ab1738d33621d2277016 SHA1 76f530a81c86afd4f8c43589a8dfd1e51892a975 SHA256 cd4be19dc1e16cc3d5bb20fdfa2af025b50cd21dbce5d1e8b3041c4e786c3624
-EBUILD planets-0.1.13.ebuild 1014 RMD160 7716cf221de8d5d663a680c8dcb45eee84eb850a SHA1 3b9a96b0b83411ea705f0c2611fb87f0916d7f93 SHA256 92a1677de52d606a83c63211c54dda7b88f621fb38d2217768dd92639ecd6f44
-MISC ChangeLog 1815 RMD160 6e08b667d226ac112bdf790a91fda388493162bc SHA1 f6d94f19acd231409f8964a9ee47c0f0acc2a5b6 SHA256 c718fe3be256ee5c96b53df4041cdd8fabffd3e35e5a071338dfe236683a593e
+EBUILD planets-0.1.13.ebuild 771 RMD160 12c8d3b1c12eced2c0100808683319db84ee8b68 SHA1 536b3623bd25314b3bda9eede7233a5b82b1d1cb SHA256 d8aeccc30f93266c69d6e395f9488a144b78547c3b3f15484406c563dde409cd
+MISC ChangeLog 1928 RMD160 144bcd25285777fc7b8a8798d13fd756065c1c63 SHA1 4786aa66d630a14887af9974a50cdc653468a0c2 SHA256 23e3ccba81ec61a30aedf621188f5db3a3ce08e14de89569e3def5353cc9b821
MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-simulation/planets/planets-0.1.13.ebuild b/games-simulation/planets/planets-0.1.13.ebuild
index 483ba3b46efd..ee3b75d203a7 100644
--- a/games-simulation/planets/planets-0.1.13.ebuild
+++ b/games-simulation/planets/planets-0.1.13.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/planets-0.1.13.ebuild,v 1.6 2008/06/22 21:04:56 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/planets/planets-0.1.13.ebuild,v 1.7 2009/01/19 23:56:42 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="a simple interactive planetary system simulator"
@@ -16,17 +17,7 @@ IUSE=""
RDEPEND="dev-lang/tcl
dev-lang/tk"
DEPEND="${RDEPEND}
- dev-lang/ocaml"
-
-pkg_setup() {
- # response to bug #134257
- if ! built_with_use dev-lang/ocaml tk ; then
- eerror "${PN} doesn't build properly if"
- eerror "dev-lang/ocaml is built without tk support."
- die "Please emerge dev-lang/ocaml with USE=tk"
- fi
- games_pkg_setup
-}
+ dev-lang/ocaml[tk]"
src_install() {
dogamesbin planets || die "dogamesbin failed"