summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-11-04 23:11:23 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-11-04 23:11:23 +0000
commitb22fda70dc03d7f3d3c76d7b3bdf5c2330c8b345 (patch)
tree9504088999a49cae6ded5291f6b355e2d4caf6f9 /games-puzzle/enigma/enigma-1.01.ebuild
parentfix repoman warnings and fix bug #196803 (diff)
downloadhistorical-b22fda70dc03d7f3d3c76d7b3bdf5c2330c8b345.tar.gz
historical-b22fda70dc03d7f3d3c76d7b3bdf5c2330c8b345.tar.bz2
historical-b22fda70dc03d7f3d3c76d7b3bdf5c2330c8b345.zip
Version bump to 1.01
Package-Manager: portage-2.1.3.16
Diffstat (limited to 'games-puzzle/enigma/enigma-1.01.ebuild')
-rw-r--r--games-puzzle/enigma/enigma-1.01.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/games-puzzle/enigma/enigma-1.01.ebuild b/games-puzzle/enigma/enigma-1.01.ebuild
new file mode 100644
index 000000000000..fe2e1769c669
--- /dev/null
+++ b/games-puzzle/enigma/enigma-1.01.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/enigma-1.01.ebuild,v 1.1 2007/11/04 23:11:22 tupone Exp $
+
+inherit autotools eutils games
+
+DESCRIPTION="puzzle game similar to Oxyd"
+HOMEPAGE="http://www.nongnu.org/enigma/"
+SRC_URI="mirror://berlios/enigma-game/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="media-libs/sdl-ttf
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ dev-libs/xerces-c
+ net-libs/enet
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ cp /usr/share/gettext/config.rpath .
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable nls) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ACKNOWLEDGEMENTS AUTHORS CHANGES README doc/HACKING
+ dohtml -r doc/*
+ doman doc/enigma.6
+ prepgamesdirs
+}