summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-01-28 10:44:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-01-28 10:44:38 +0000
commit71058f10b8c2560de2e7a49f570dce980828f68d (patch)
treebc85ad8d8b70b5288abf97c602c4abed8cb03381 /games-kids/gtans/gtans-1.2.ebuild
parentinitial commit (bug 39401) (diff)
downloadhistorical-71058f10b8c2560de2e7a49f570dce980828f68d.tar.gz
historical-71058f10b8c2560de2e7a49f570dce980828f68d.tar.bz2
historical-71058f10b8c2560de2e7a49f570dce980828f68d.zip
initial commit (bug 39401)
Diffstat (limited to 'games-kids/gtans/gtans-1.2.ebuild')
-rw-r--r--games-kids/gtans/gtans-1.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-kids/gtans/gtans-1.2.ebuild b/games-kids/gtans/gtans-1.2.ebuild
new file mode 100644
index 000000000000..6591d2c44c78
--- /dev/null
+++ b/games-kids/gtans/gtans-1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gtans/gtans-1.2.ebuild,v 1.1 2004/01/28 10:44:32 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="The Tangram is a chinese puzzle. The object is to put seven geometric shapes together so as to form a given outline."
+HOMEPAGE="http://gtans.sourceforge.net/"
+SRC_URI="http://download.sourceforge.net/gtans/${P}.tar.gz"
+
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nls"
+
+DEPEND="virtual/x11
+ >=x11-libs/gtk+-1.2.1
+ dev-libs/glib
+ nls? ( sys-devel/gettext )
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ if ! use nls ; then
+ sed -i \
+ -e "/\(TGTXT\| po\)/ s/^/#/" \
+ -e "/^CC/ s:=.*:= ${CC}:" \
+ -e "/misc/ s/PREFIX.*/install/" \
+ -e "/^CFLG[ ]*=/ s:=.*:= ${CFLAGS}:" makefile \
+ || die "sed makefile failed"
+ fi
+ sed -i \
+ -e "s:/share::" \
+ -e "/^PREFIX/ s:usr:usr/share:" misc/Makefile \
+ || die "sed misc/Makefile failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS HISTORY || die "dodoc failed"
+ prepgamesdirs
+}