summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-02-08 21:33:38 +0000
committerMike Frysinger <vapier@gentoo.org>2004-02-08 21:33:38 +0000
commit31bfd0ea89f64b7f09b29cb701a91f9bbcbdd4a2 (patch)
tree8ba3ee730dabcfcde650ac4cd545303f0b1d0a2c /games-fps/unreal-tournament-goty
parentx86 stable (diff)
downloadhistorical-31bfd0ea89f64b7f09b29cb701a91f9bbcbdd4a2.tar.gz
historical-31bfd0ea89f64b7f09b29cb701a91f9bbcbdd4a2.tar.bz2
historical-31bfd0ea89f64b7f09b29cb701a91f9bbcbdd4a2.zip
new cdrom interface
Diffstat (limited to 'games-fps/unreal-tournament-goty')
-rw-r--r--games-fps/unreal-tournament-goty/metadata.xml34
-rw-r--r--games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild118
-rw-r--r--games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild89
3 files changed, 90 insertions, 151 deletions
diff --git a/games-fps/unreal-tournament-goty/metadata.xml b/games-fps/unreal-tournament-goty/metadata.xml
new file mode 100644
index 000000000000..557cfc4abe91
--- /dev/null
+++ b/games-fps/unreal-tournament-goty/metadata.xml
@@ -0,0 +1,34 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+ <name>Mike Frysinger</name>
+</maintainer>
+<longdescription>
+In the single player mode, the player squares off
+against computer controlled Bots in all the game modes
+through a tournament ladder with increasing difficulty.
+Thanks to Epic's unmatched AI coding wizardry, Unreal
+Tournament's Bots are more life like than any
+computer-controlled characters to date. They understand
+each game's unique rules. They have a firm handle on all
+the different weapons at their disposal and how best to
+use them. They can swim, use elevators, climb stairs,
+and put on Toxin suits if they have to. If they're on
+the player's team, they can take orders to attack,
+defend or freelance.
+
+Unreal Tournament's bread and butter is the online multiplayer
+mode. Squaring off against other combatants from around the world, or on
+the other end of a LAN connection, provides some of the most thrilling and
+tense battles seen on a PC. Unreal Tournament's unparalleled networking
+code makes it as easy to play the game against anyone, anytime. If the
+host server has unique content -- like custom skins or maps -- UT
+will automatically download and install that content in REAL TIME, as the
+game is connecting. And thanks to Epic Games' amazing work on Unreal
+Tournament's network play, you can be sure that even a 33.6K modem can get
+a silky smooth connection to the server.
+</longdescription>
+</pkgmetadata>
diff --git a/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild b/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild
index c75cc8fccc69..fe325dd67e68 100644
--- a/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild
+++ b/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v 1.2 2003/09/09 23:44:19 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-436.ebuild,v 1.3 2004/02/08 21:28:34 vapier Exp $
inherit games eutils
@@ -12,47 +12,16 @@ SRC_URI="ftp://ftp.lokigames.com/pub/beta/ut/ut-install-${PV}-GOTY.run
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86"
-IUSE="X 3dfx S3TC nls"
+IUSE="X 3dfx S3TC nls opengl"
DEPEND="!games-fps/unreal-tournament"
-RDEPEND="X? ( virtual/x11 )"
+RDEPEND="X? ( virtual/x11 )
+ opengl? ( virtual/opengl )"
S=${WORKDIR}
-export UT_CD1=${UT_SETUP_CDROM1}
-export UT_CD2=${UT_SETUP_CDROM2}
-if [ -z "${UT_CD1}" ] ; then
- for mline in `mount | egrep -e '(iso|cdrom)' | awk '{print $3}'` ; do
- [ ! -d ${mline}/System ] && continue
- [ -d ${mline}/Help/chaosut ] \
- && UT_CD2=${mline} \
- || UT_CD1=${mline}
- done
-fi
-[ -z "${UT_CD2}" ] && UT_CD2=${UT_CD1}
-
pkg_setup() {
- if [ -z "${UT_CD1}" ] || [ -z "${UT_CD2}" ] ; then
- echo
- eerror "You must mount the first UT CD first !"
- echo
- ewarn "If you do not have the CDs, but have the data files"
- ewarn "mounted somewhere on your filesystem, just export"
- ewarn "the variable UT_SETUP_CDROM1 so that it points to the"
- ewarn "base of the Unreal Tournament GOTY data."
- echo
- einfo "If you have 2 CDROM drives you can also export the"
- einfo "variable UT_SETUP_CDROM2 to specify the 2nd cdrom."
- einfo "Otherwise you will be prompted to switch CDs in the"
- einfo "middle of the emerge."
- echo
- einfo "Also note that if you want to *just* install the game"
- einfo "and *not* install the extra GOTY stuff (Chaos mod/different"
- einfo "languages/S3TC textures) then you can use the regular"
- einfo "unreal-tournament ebuild instead."
- echo
- die "You must provide the Unreal Tournament data before running the install"
- fi
+ cdrom_get_cds System/ Help/chaosut
games_pkg_setup
}
@@ -63,17 +32,18 @@ src_unpack() {
src_install() {
local dir=${GAMES_PREFIX_OPT}/${PN/-goty/}
+ local Ddir=${D}/${dir}
dodir ${dir}
###########
### PRE ###
# System
if [ `use 3dfx` ] ; then
- tar -zxf Glide.ini.tar.gz -C ${D}/${dir} || die "install Glide ini"
+ tar -zxf Glide.ini.tar.gz -C ${Ddir} || die "install Glide ini"
else
- tar -zxf OpenGL.ini.tar.gz -C ${D}/${dir} || die "install OpenGL ini"
+ tar -zxf OpenGL.ini.tar.gz -C ${Ddir} || die "install OpenGL ini"
fi
- tar -zxf data.tar.gz -C ${D}/${dir} || die "extract System data"
+ tar -zxf data.tar.gz -C ${Ddir} || die "extract System data"
# the most important things, ucc & ut :)
exeinto ${dir}
@@ -87,99 +57,83 @@ src_install() {
### PRE ###
###########
-
###########
### CD1 ###
- export UT_CD=${UT_CD1}
-
# Help, Logs, Music, Sounds, Textures, Web
- cp -rf ${UT_CD}/{Help,Logs,Music,Textures,Web} ${D}/${dir}/ || die "copy Help, Logs, Music, Textures, Web CD1"
+ cp -rf ${CDROM_ROOT}/{Help,Logs,Music,Textures,Web} ${Ddir}/ || die "copy Help, Logs, Music, Textures, Web CD1"
dodir ${dir}/Sounds
if [ `use nls` ] ; then
- cp -rf ${UT_CD}/Sounds/* ${D}/${dir}/Sounds/ || die "copy Sounds CD1"
+ cp -rf ${CDROM_ROOT}/Sounds/* ${Ddir}/Sounds/ || die "copy Sounds CD1"
else
- cp -rf ${UT_CD}/Sounds/*.uax ${D}/${dir}/Sounds/ || die "copy Sounds CD1"
+ cp -rf ${CDROM_ROOT}/Sounds/*.uax ${Ddir}/Sounds/ || die "copy Sounds CD1"
fi
# System
dodir ${dir}/System
if [ `use nls` ] ; then
- cp ${UT_CD}/System/*.{est,frt,itt,int,u} ${D}/${dir}/System/ || die "copy System data CD1"
+ cp ${CDROM_ROOT}/System/*.{est,frt,itt,int,u} ${Ddir}/System/ || die "copy System data CD1"
else
- cp ${UT_CD}/System/*.{int,u} ${D}/${dir}/System/ || die "copy System data CD1"
+ cp ${CDROM_ROOT}/System/*.{int,u} ${Ddir}/System/ || die "copy System data CD1"
fi
# now we uncompress the maps
einfo "Uncompressing CD1 Maps ... this may take some time"
dodir ${dir}/Maps
- cd ${D}/${dir}
+ cd ${Ddir}
export HOME=${T}
- export UT_DATA_PATH=${D}/${dir}/System
- for f in `find ${UT_CD}/Maps/ -name '*.uz' -printf '%f '` ; do
- ./ucc decompress ${UT_CD}/Maps/${f} -nohomedir || die "uncompressing map CD1 ${f}"
+ export UT_DATA_PATH=${Ddir}/System
+ for f in `find ${CDROM_ROOT}/Maps/ -name '*.uz' -printf '%f '` ; do
+ ./ucc decompress ${CDROM_ROOT}/Maps/${f} -nohomedir || die "uncompressing map CD1 ${f}"
mv System/${f:0:${#f}-3} Maps/ || die "copy map CD1 ${f}"
done
### CD1 ###
###########
-
### Have user switch cds if need be ###
- if [ "${UT_CD1}" == "${UT_CD2}" ] ; then
- while :; do
- einfo "Please mount the 2nd cd at ${UT_CD2} and press return when ready (or CTRL+C to abort)"
- read
- [ -d ${UT_CD2}/System ] && break
- [ -d ${UT_CD2}/Help/chaosut ] && break
- eerror "Could not verify that ${UT_CD2} really contains the 2nd CD"
- done
- fi
-
+ cdrom_load_next_cd
###########
### CD2 ###
- export UT_CD=${UT_CD2}
-
# Help, Sounds
- cp -rf ${UT_CD}/{Help,Sounds} ${D}/${dir}/ || die "copy Help, Sounds CD2"
+ cp -rf ${CDROM_ROOT}/{Help,Sounds} ${Ddir}/ || die "copy Help, Sounds CD2"
# S3TC Textures
if [ `use S3TC` ] ; then
- cp -rf ${UT_CD}/Textures ${D}/${dir}/ || die "copy S3TC Textures CD2"
+ cp -rf ${CDROM_ROOT}/Textures ${Ddir}/ || die "copy S3TC Textures CD2"
else
- cp -rf ${UT_CD}/Textures/{JezzTex,Jezztex2,SnowDog,chaostex{,2}}.utx ${D}/${dir}/Textures/ || die "copy Textures CD2"
+ cp -rf ${CDROM_ROOT}/Textures/{JezzTex,Jezztex2,SnowDog,chaostex{,2}}.utx ${Ddir}/Textures/ || die "copy Textures CD2"
fi
# System
- cp -rf ${UT_CD}/System/*.{u,int} ${D}/${dir}/System/ || die "copy System CD2"
+ cp -rf ${CDROM_ROOT}/System/*.{u,int} ${Ddir}/System/ || die "copy System CD2"
# now we uncompress the maps
einfo "Uncompressing CD2 Maps ... this may take some time"
dodir ${dir}/Maps
- cd ${D}/${dir}
+ cd ${Ddir}
export HOME=${T}
- export UT_DATA_PATH=${D}/${dir}/System
- for f in `find ${UT_CD}/maps/ -name '*.uz' -printf '%f '` ; do
- ./ucc decompress ${UT_CD}/maps/${f} -nohomedir || die "uncompressing map CD2 ${f}"
+ export UT_DATA_PATH=${Ddir}/System
+ for f in `find ${CDROM_ROOT}/maps/ -name '*.uz' -printf '%f '` ; do
+ ./ucc decompress ${CDROM_ROOT}/maps/${f} -nohomedir || die "uncompressing map CD2 ${f}"
mv System/${f:0:${#f}-3} Maps/ || die "copy map CD2 ${f}"
done
### CD2 ###
###########
-
###########
### END ###
cd ${S}
# Textures
- tar -zxf Credits.tar.gz -C ${D}/${dir} || die "extract credits texture"
+ tar -zxf Credits.tar.gz -C ${Ddir} || die "extract credits texture"
# NetGamesUSA.com
- tar -zxf NetGamesUSA.com.tar.gz -C ${D}/${dir}/ || die "extract NetGamesUSA.com"
+ tar -zxf NetGamesUSA.com.tar.gz -C ${Ddir}/ || die "extract NetGamesUSA.com"
# Patch UT-GOTY
cd setup.data
cp patch.dat{,.orig}
sed -e 's:sh uz-maps.sh:echo:' patch.dat.orig > patch.dat
- ./bin/Linux/x86/loki_patch patch.dat ${D}/${dir} || die "failed to patch"
+ ./bin/Linux/x86/loki_patch patch.dat ${Ddir} || die "failed to patch"
cd ${S}
# now we install the IpDrv.so patch
@@ -189,6 +143,11 @@ src_install() {
# install a few random files
insinto ${dir}
doins README icon.{bmp,xpm} || die "installing random files"
+
+ # now, since these files are coming off a cd, the times/sizes/md5sums wont
+ # be different ... that means portage will try to unmerge some files (!)
+ # we run touch on ${D} so as to make sure portage doesnt do any such thing
+ find ${Ddir} -exec touch '{}' \;
### END ###
###########
@@ -196,13 +155,10 @@ src_install() {
}
pkg_postinst() {
- echo
+ games_pkg_postinst
einfo "You might want to install the bonus packs too."
einfo "Many servers on the internet use them, and the"
einfo "majority of players do too."
echo
einfo "Just run: emerge unreal-tournament-bonuspacks"
- echo
-
- games_pkg_postinst
}
diff --git a/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild b/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild
index efa4968bae42..61fe77949cc7 100644
--- a/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild
+++ b/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v 1.2 2003/09/09 23:44:19 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament-goty/unreal-tournament-goty-451.ebuild,v 1.3 2004/02/08 21:28:34 vapier Exp $
-inherit games
+inherit games eutils
DESCRIPTION="Futuristic FPS (Game Of The Year edition)"
HOMEPAGE="http://www.unrealtournament.com/"
@@ -20,40 +20,8 @@ RDEPEND="X? ( virtual/x11 )
S=${WORKDIR}
-export UT_CD1=${UT_SETUP_CDROM1}
-export UT_CD2=${UT_SETUP_CDROM2}
-if [ -z "${UT_CD1}" ] ; then
- for mline in `mount | egrep -e '(iso|cdrom)' | awk '{print $3}'` ; do
- [ ! -d ${mline}/System ] && continue
- [ -d ${mline}/Help/chaosut ] \
- && UT_CD2=${mline} \
- || UT_CD1=${mline}
- done
-fi
-[ -z "${UT_CD2}" ] && UT_CD2=${UT_CD1}
-
pkg_setup() {
- if [ -z "${UT_CD1}" ] || [ -z "${UT_CD2}" ] ; then
- echo
- eerror "You must mount the first UT CD first !"
- echo
- ewarn "If you do not have the CDs, but have the data files"
- ewarn "mounted somewhere on your filesystem, just export"
- ewarn "the variable UT_SETUP_CDROM1 so that it points to the"
- ewarn "base of the Unreal Tournament GOTY data."
- echo
- einfo "If you have 2 CDROM drives you can also export the"
- einfo "variable UT_SETUP_CDROM2 to specify the 2nd cdrom."
- einfo "Otherwise you will be prompted to switch CDs in the"
- einfo "middle of the emerge."
- echo
- einfo "Also note that if you want to *just* install the game"
- einfo "and *not* install the extra GOTY stuff (Chaos mod/different"
- einfo "languages/S3TC textures) then you can use the regular"
- einfo "unreal-tournament ebuild instead."
- echo
- die "You must provide the Unreal Tournament data before running the install"
- fi
+ cdrom_get_cds System/ Help/chaosut
games_pkg_setup
}
@@ -91,26 +59,23 @@ src_install() {
### PRE ###
###########
-
###########
### CD1 ###
- export UT_CD=${UT_CD1}
-
# Help, Logs, Music, Sounds, Textures, Web
- cp -rf ${UT_CD}/{Help,Logs,Music,Textures,Web} ${Ddir}/ || die "copy Help, Logs, Music, Textures, Web CD1"
+ cp -rf ${CDROM_ROOT}/{Help,Logs,Music,Textures,Web} ${Ddir}/ || die "copy Help, Logs, Music, Textures, Web CD1"
dodir ${dir}/Sounds
if [ `use nls` ] ; then
- cp -rf ${UT_CD}/Sounds/* ${Ddir}/Sounds/ || die "copy Sounds CD1"
+ cp -rf ${CDROM_ROOT}/Sounds/* ${Ddir}/Sounds/ || die "copy Sounds CD1"
else
- cp -rf ${UT_CD}/Sounds/*.uax ${Ddir}/Sounds/ || die "copy Sounds CD1"
+ cp -rf ${CDROM_ROOT}/Sounds/*.uax ${Ddir}/Sounds/ || die "copy Sounds CD1"
fi
# System
dodir ${dir}/System
if [ `use nls` ] ; then
- cp ${UT_CD}/System/*.{est,frt,itt,int,u} ${Ddir}/System/ || die "copy System data CD1"
+ cp ${CDROM_ROOT}/System/*.{est,frt,itt,int,u} ${Ddir}/System/ || die "copy System data CD1"
else
- cp ${UT_CD}/System/*.{int,u} ${Ddir}/System/ || die "copy System data CD1"
+ cp ${CDROM_ROOT}/System/*.{int,u} ${Ddir}/System/ || die "copy System data CD1"
fi
# now we uncompress the maps
@@ -119,42 +84,30 @@ src_install() {
cd ${Ddir}
export HOME=${T}
export UT_DATA_PATH=${Ddir}/System
- for f in `find ${UT_CD}/Maps/ -name '*.uz' -printf '%f '` ; do
- ./ucc decompress ${UT_CD}/Maps/${f} -nohomedir || die "uncompressing map CD1 ${f}"
+ for f in `find ${CDROM_ROOT}/Maps/ -name '*.uz' -printf '%f '` ; do
+ ./ucc decompress ${CDROM_ROOT}/Maps/${f} -nohomedir || die "uncompressing map CD1 ${f}"
mv System/${f:0:${#f}-3} Maps/ || die "copy map CD1 ${f}"
done
### CD1 ###
###########
-
### Have user switch cds if need be ###
- if [ "${UT_CD1}" == "${UT_CD2}" ] ; then
- while :; do
- einfo "Please mount the 2nd cd at ${UT_CD2} and press return when ready (or CTRL+C to abort)"
- read
- [ -d ${UT_CD2}/System ] && break
- [ -d ${UT_CD2}/Help/chaosut ] && break
- eerror "Could not verify that ${UT_CD2} really contains the 2nd CD"
- done
- fi
-
+ cdrom_load_next_cd
###########
### CD2 ###
- export UT_CD=${UT_CD2}
-
# Help, Sounds
- cp -rf ${UT_CD}/{Help,Sounds} ${Ddir}/ || die "copy Help, Sounds CD2"
+ cp -rf ${CDROM_ROOT}/{Help,Sounds} ${Ddir}/ || die "copy Help, Sounds CD2"
# S3TC Textures
if [ `use S3TC` ] ; then
- cp -rf ${UT_CD}/Textures ${Ddir}/ || die "copy S3TC Textures CD2"
+ cp -rf ${CDROM_ROOT}/Textures ${Ddir}/ || die "copy S3TC Textures CD2"
else
- cp -rf ${UT_CD}/Textures/{JezzTex,Jezztex2,SnowDog,chaostex{,2}}.utx ${Ddir}/Textures/ || die "copy Textures CD2"
+ cp -rf ${CDROM_ROOT}/Textures/{JezzTex,Jezztex2,SnowDog,chaostex{,2}}.utx ${Ddir}/Textures/ || die "copy Textures CD2"
fi
# System
- cp -rf ${UT_CD}/System/*.{u,int} ${Ddir}/System/ || die "copy System CD2"
+ cp -rf ${CDROM_ROOT}/System/*.{u,int} ${Ddir}/System/ || die "copy System CD2"
# now we uncompress the maps
einfo "Uncompressing CD2 Maps ... this may take some time"
@@ -162,14 +115,13 @@ src_install() {
cd ${Ddir}
export HOME=${T}
export UT_DATA_PATH=${Ddir}/System
- for f in `find ${UT_CD}/maps/ -name '*.uz' -printf '%f '` ; do
- ./ucc decompress ${UT_CD}/maps/${f} -nohomedir || die "uncompressing map CD2 ${f}"
+ for f in `find ${CDROM_ROOT}/maps/ -name '*.uz' -printf '%f '` ; do
+ ./ucc decompress ${CDROM_ROOT}/maps/${f} -nohomedir || die "uncompressing map CD2 ${f}"
mv System/${f:0:${#f}-3} Maps/ || die "copy map CD2 ${f}"
done
### CD2 ###
###########
-
###########
### END ###
cd ${S}
@@ -206,13 +158,10 @@ src_install() {
}
pkg_postinst() {
- echo
+ games_pkg_postinst
einfo "You might want to install the bonus packs too."
einfo "Many servers on the internet use them, and the"
einfo "majority of players do too."
echo
einfo "Just run: emerge unreal-tournament-bonuspacks"
- echo
-
- games_pkg_postinst
}