summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-22 07:04:27 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-22 07:04:27 +0000
commitb6223c40c116db694cd1de6b1aef123e4a132446 (patch)
treea823ff4dbe7599d0014b5ce7f4a967f431dffbe9 /games-arcade
parentMarked stable on mips. (diff)
downloadhistorical-b6223c40c116db694cd1de6b1aef123e4a132446.tar.gz
historical-b6223c40c116db694cd1de6b1aef123e4a132446.tar.bz2
historical-b6223c40c116db694cd1de6b1aef123e4a132446.zip
add autotools patch from Jon Atkins; rework ebuild as a result
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/jumpnbump/ChangeLog8
-rw-r--r--games-arcade/jumpnbump/Manifest4
-rw-r--r--games-arcade/jumpnbump/files/digest-jumpnbump-1.50-r12
-rw-r--r--games-arcade/jumpnbump/jumpnbump-1.50-r1.ebuild42
4 files changed, 54 insertions, 2 deletions
diff --git a/games-arcade/jumpnbump/ChangeLog b/games-arcade/jumpnbump/ChangeLog
index 73b9fd9b890b..ef0d64901b6a 100644
--- a/games-arcade/jumpnbump/ChangeLog
+++ b/games-arcade/jumpnbump/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-arcade/jumpnbump
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/jumpnbump/ChangeLog,v 1.6 2004/08/10 12:03:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/jumpnbump/ChangeLog,v 1.7 2004/09/22 07:04:27 mr_bones_ Exp $
+
+*jumpnbump-1.50-r1 (22 Sep 2004)
+
+ 22 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +jumpnbump-1.50-r1.ebuild:
+ add autotools patch from Jon Atkins; rework ebuild as a result
10 Aug 2004; Michael Sterrett <mr_bones_@gentoo.org> jumpnbump-1.50.ebuild:
Support no-X install (bug #59952)
diff --git a/games-arcade/jumpnbump/Manifest b/games-arcade/jumpnbump/Manifest
index 88953695f1f7..03e1d110f099 100644
--- a/games-arcade/jumpnbump/Manifest
+++ b/games-arcade/jumpnbump/Manifest
@@ -1,6 +1,8 @@
-MD5 e92196229b301227d82a1e6ac59d401b ChangeLog 1620
+MD5 b8a35c5f35a399fc104e888c6ea0fad3 ChangeLog 1804
MD5 d43fd1e1866059f5840f5a88b039a0bd jumpnbump-1.41-r1.ebuild 1260
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 c0cf669a739614c6c9bced8b5687f9c9 jumpnbump-1.50-r1.ebuild 1239
MD5 eaea1b7270e30efb24b1eb9fab4eb3b8 jumpnbump-1.50.ebuild 1662
MD5 b11cea1b811841da52d3445a78547bfe files/digest-jumpnbump-1.41-r1 67
MD5 1ee13dda1cfbabf30c3715720578afa4 files/digest-jumpnbump-1.50 66
+MD5 497cdae9f9d41a225443413de88fc42e files/digest-jumpnbump-1.50-r1 143
diff --git a/games-arcade/jumpnbump/files/digest-jumpnbump-1.50-r1 b/games-arcade/jumpnbump/files/digest-jumpnbump-1.50-r1
new file mode 100644
index 000000000000..cdf2fd846c73
--- /dev/null
+++ b/games-arcade/jumpnbump/files/digest-jumpnbump-1.50-r1
@@ -0,0 +1,2 @@
+MD5 c7c79136e07948975504abcbe62ba130 jumpnbump-1.50.tar.gz 397208
+MD5 944e642bfef33048b69a253ba7cbab0e jumpnbump-1.50-autotool.patch.bz2 94692
diff --git a/games-arcade/jumpnbump/jumpnbump-1.50-r1.ebuild b/games-arcade/jumpnbump/jumpnbump-1.50-r1.ebuild
new file mode 100644
index 000000000000..5ca635e05d13
--- /dev/null
+++ b/games-arcade/jumpnbump/jumpnbump-1.50-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/jumpnbump/jumpnbump-1.50-r1.ebuild,v 1.1 2004/09/22 07:04:27 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="a funny multiplayer game about cute little fluffy bunnies"
+HOMEPAGE="http://www.jumpbump.mine.nu/"
+SRC_URI="http://www.jumpbump.mine.nu/port/${P}.tar.gz
+ mirror://gentoo/${P}-autotool.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc ~amd64"
+IUSE="X tcltk svga fbcon kde"
+
+DEPEND="virtual/libc
+ X? ( virtual/x11 )
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/libsdl-1.2
+ >=media-libs/sdl-net-1.2"
+RDEPEND="${DEPEND}
+ tcltk? (
+ dev-lang/tcl
+ dev-lang/tk )"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${WORKDIR}"
+ epatch "${DISTDIR}/${P}-autotool.patch.bz2"
+ chmod +x "${S}/configure"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ # clean up a bit. It leave a dep on Xdialog but ignore that.
+ use fbcon || rm -f "${D}${GAMES_BINDIR}/jumpnbump.fbcon"
+ use kde || rm -f "${D}${GAMES_BINDIR}/jumpnbump-kdialog"
+ use svga || rm -f "${D}${GAMES_BINDIR}/jumpnbump.svgalib"
+ use tcltk || rm -f "${D}${GAMES_BINDIR}/jnbmenu.tcl"
+ prepgamesdirs
+}