summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-03-01 17:16:54 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-03-01 17:16:54 +0000
commit2bfadc74b5a4ffe198b02b518fd4ba3d3a2d8547 (patch)
treeabf87b20f597f6cd2ea7b65783807084f5302c52 /games-arcade/ppracer/ppracer-0.3.1.ebuild
parentStable on mips, bug #79762 (diff)
downloadhistorical-2bfadc74b5a4ffe198b02b518fd4ba3d3a2d8547.tar.gz
historical-2bfadc74b5a4ffe198b02b518fd4ba3d3a2d8547.tar.bz2
historical-2bfadc74b5a4ffe198b02b518fd4ba3d3a2d8547.zip
version bump
Package-Manager: portage-2.0.51-r15
Diffstat (limited to 'games-arcade/ppracer/ppracer-0.3.1.ebuild')
-rw-r--r--games-arcade/ppracer/ppracer-0.3.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/games-arcade/ppracer/ppracer-0.3.1.ebuild b/games-arcade/ppracer/ppracer-0.3.1.ebuild
new file mode 100644
index 000000000000..3a2645d41b54
--- /dev/null
+++ b/games-arcade/ppracer/ppracer-0.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/ppracer/ppracer-0.3.1.ebuild,v 1.1 2005/03/01 17:16:54 mr_bones_ Exp $
+
+inherit flag-o-matic gnuconfig games
+
+DESCRIPTION="take on the role of Tux, the Linux Penguin, as he races down steep, snow-covered mountains"
+HOMEPAGE="http://developer.berlios.de/projects/ppracer/"
+SRC_URI="http://download.berlios.de/ppracer/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86 ~ppc"
+IUSE="X"
+
+DEPEND="virtual/opengl
+ virtual/glu
+ X? ( virtual/x11 )
+ >=dev-lang/tcl-8.4
+ media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/libpng
+ >=media-libs/freetype-2
+ sys-libs/zlib"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ gnuconfig_update
+ autoconf || die "autoconf failed"
+}
+
+src_compile() {
+ # alpha needs -mieee for this game to avoid FPE
+ use alpha && append-flags -mieee
+
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-data-dir="${GAMES_DATADIR}/${PN}" \
+ $(use_with X x) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog
+ dohtml -r html/*
+ prepgamesdirs
+}