summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2014-07-11 08:21:58 +0000
committerUlrich Müller <ulm@gentoo.org>2014-07-11 08:21:58 +0000
commit8f1f7c79ab9bb05a644c509be621e0d1b412ed8e (patch)
tree9d9cb7aae5ea87183add280d85797183b6f57d70 /eclass
parentdroped vdr use-flag, droped media-video/vdr from depend, droped useless servi... (diff)
downloadhistorical-8f1f7c79ab9bb05a644c509be621e0d1b412ed8e.tar.gz
historical-8f1f7c79ab9bb05a644c509be621e0d1b412ed8e.tar.bz2
historical-8f1f7c79ab9bb05a644c509be621e0d1b412ed8e.zip
Avoid reserved names for functions and variables, bug 516092.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog12
-rw-r--r--eclass/autotools.eclass6
-rw-r--r--eclass/base.eclass8
-rw-r--r--eclass/cdrom.eclass8
-rw-r--r--eclass/cmake-utils.eclass6
-rw-r--r--eclass/cvs.eclass8
-rw-r--r--eclass/enlightenment.eclass8
-rw-r--r--eclass/eutils.eclass32
-rw-r--r--eclass/fcaps.eclass12
-rw-r--r--eclass/fixheadtails.eclass8
-rw-r--r--eclass/flag-o-matic.eclass6
-rw-r--r--eclass/games.eclass6
-rw-r--r--eclass/kde4-base.eclass6
-rw-r--r--eclass/kde4-functions.eclass6
-rw-r--r--eclass/kde4-meta-pkg.eclass8
-rw-r--r--eclass/kde4-meta.eclass16
-rw-r--r--eclass/libtool.eclass10
-rw-r--r--eclass/multilib.eclass18
-rw-r--r--eclass/multiprocessing.eclass8
-rw-r--r--eclass/pam.eclass8
-rw-r--r--eclass/pax-utils.eclass8
-rw-r--r--eclass/portability.eclass6
-rw-r--r--eclass/qmake-utils.eclass8
-rw-r--r--eclass/readme.gentoo.eclass6
-rw-r--r--eclass/toolchain-funcs.eclass6
-rw-r--r--eclass/unpacker.eclass6
-rw-r--r--eclass/user.eclass8
-rw-r--r--eclass/versionator.eclass8
28 files changed, 133 insertions, 123 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index 73d49856ffb2..107a857c8de0 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for eclass directory
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.1318 2014/07/08 08:49:10 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.1319 2014/07/11 08:21:58 ulm Exp $
+
+ 11 Jul 2014; Ulrich Müller <ulm@gentoo.org> autotools.eclass, base.eclass,
+ cdrom.eclass, cmake-utils.eclass, cvs.eclass, enlightenment.eclass,
+ eutils.eclass, fcaps.eclass, fixheadtails.eclass, flag-o-matic.eclass,
+ games.eclass, kde4-base.eclass, kde4-functions.eclass, kde4-meta.eclass,
+ kde4-meta-pkg.eclass, libtool.eclass, multilib.eclass,
+ multiprocessing.eclass, pam.eclass, pax-utils.eclass, portability.eclass,
+ qmake-utils.eclass, readme.gentoo.eclass, toolchain-funcs.eclass,
+ unpacker.eclass, user.eclass, versionator.eclass:
+ Avoid reserved names for functions and variables, bug 516092.
08 Jul 2014; Michał Górny <mgorny@gentoo.org> distutils-r1.eclass:
Support linking Python modules on aix, thanks to haubi.
diff --git a/eclass/autotools.eclass b/eclass/autotools.eclass
index c1c77be8623c..616fdd0b7afe 100644
--- a/eclass/autotools.eclass
+++ b/eclass/autotools.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.161 2014/03/01 11:51:08 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools.eclass,v 1.162 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: autotools.eclass
# @MAINTAINER:
@@ -13,8 +13,8 @@
# Note: We require GNU m4, as does autoconf. So feel free to use any features
# from the GNU version of m4 without worrying about other variants (i.e. BSD).
-if [[ ${___ECLASS_ONCE_AUTOTOOLS} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_AUTOTOOLS="recur -_+^+_- spank"
+if [[ -z ${_AUTOTOOLS_ECLASS} ]]; then
+_AUTOTOOLS_ECLASS=1
inherit libtool multiprocessing
diff --git a/eclass/base.eclass b/eclass/base.eclass
index bc93795b3f5f..9e963869d5d4 100644
--- a/eclass/base.eclass
+++ b/eclass/base.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/base.eclass,v 1.58 2012/09/27 16:35:41 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/base.eclass,v 1.59 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: base.eclass
# @MAINTAINER:
@@ -11,8 +11,8 @@
# @DESCRIPTION:
# The base eclass defines some default functions and variables.
-if [[ ${___ECLASS_ONCE_BASE} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_BASE="recur -_+^+_- spank"
+if [[ -z ${_BASE_ECLASS} ]]; then
+_BASE_ECLASS=1
inherit eutils
diff --git a/eclass/cdrom.eclass b/eclass/cdrom.eclass
index ffbbf02ed26d..34d7893625ae 100644
--- a/eclass/cdrom.eclass
+++ b/eclass/cdrom.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/cdrom.eclass,v 1.5 2012/01/18 12:42:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/cdrom.eclass,v 1.6 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: cdrom.eclass
# @MAINTAINER:
@@ -15,8 +15,8 @@
# and when the function returns, you can assume that the cd has been
# found at CDROM_ROOT.
-if [[ -z ${___ECLASS_ONCE_CDROM} ]]; then
-___ECLASS_ONCE_CDROM=1
+if [[ -z ${_CDROM_ECLASS} ]]; then
+_CDROM_ECLASS=1
inherit portability
diff --git a/eclass/cmake-utils.eclass b/eclass/cmake-utils.eclass
index eacfa916ff6a..2b843fb02323 100644
--- a/eclass/cmake-utils.eclass
+++ b/eclass/cmake-utils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/cmake-utils.eclass,v 1.107 2014/05/06 15:29:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/cmake-utils.eclass,v 1.108 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: cmake-utils.eclass
# @MAINTAINER:
@@ -17,8 +17,8 @@
# builds (default), in-source builds and an implementation of the well-known use_enable
# and use_with functions for CMake.
-if [[ ${___ECLASS_ONCE_CMAKE_UTILS} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_CMAKE_UTILS="recur -_+^+_- spank"
+if [[ -z ${_CMAKE_UTILS_ECLASS} ]]; then
+_CMAKE_UTILS_ECLASS=1
# @ECLASS-VARIABLE: WANT_CMAKE
# @DESCRIPTION:
diff --git a/eclass/cvs.eclass b/eclass/cvs.eclass
index 9471e3a8fb09..7e18f5801b15 100644
--- a/eclass/cvs.eclass
+++ b/eclass/cvs.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/cvs.eclass,v 1.83 2013/09/28 16:22:29 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/cvs.eclass,v 1.84 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: cvs.eclass
# @MAINTAINER:
@@ -13,8 +13,8 @@
# cvs_src_unpack. If you find that you need to call the cvs_* functions
# directly, I'd be interested to hear about it.
-if [[ ${___ECLASS_ONCE_CVS} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_CVS="recur -_+^+_- spank"
+if [[ -z ${_CVS_ECLASS} ]]; then
+_CVS_ECLASS=1
inherit eutils
diff --git a/eclass/enlightenment.eclass b/eclass/enlightenment.eclass
index 65fe60151c92..89212e8efbe9 100644
--- a/eclass/enlightenment.eclass
+++ b/eclass/enlightenment.eclass
@@ -1,14 +1,14 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/enlightenment.eclass,v 1.105 2013/10/12 15:30:23 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/enlightenment.eclass,v 1.106 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: enlightenment.eclass
# @MAINTAINER:
# enlightenment@gentoo.org
# @BLURB: simplify enlightenment package management
-if [[ ${___ECLASS_ONCE_ENLIGHTENMENT} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_ENLIGHTENMENT="recur -_+^+_- spank"
+if [[ -z ${_ENLIGHTENMENT_ECLASS} ]]; then
+_ENLIGHTENMENT_ECLASS=1
inherit eutils libtool
diff --git a/eclass/eutils.eclass b/eclass/eutils.eclass
index e62c4d86bcd3..33bc36cda58f 100644
--- a/eclass/eutils.eclass
+++ b/eclass/eutils.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/eutils.eclass,v 1.435 2014/07/04 08:01:51 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/eutils.eclass,v 1.436 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: eutils.eclass
# @MAINTAINER:
@@ -15,8 +15,8 @@
# Due to the nature of this eclass, some functions may have maintainers
# different from the overall eclass!
-if [[ ${___ECLASS_ONCE_EUTILS} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_EUTILS="recur -_+^+_- spank"
+if [[ -z ${_EUTILS_ECLASS} ]]; then
+_EUTILS_ECLASS=1
inherit multilib toolchain-funcs
@@ -114,7 +114,7 @@ esvn_clean() {
# @CODE
estack_push() {
[[ $# -eq 0 ]] && die "estack_push: incorrect # of arguments"
- local stack_name="__ESTACK_$1__" ; shift
+ local stack_name="_ESTACK_$1_" ; shift
eval ${stack_name}+=\( \"\$@\" \)
}
@@ -127,23 +127,23 @@ estack_push() {
estack_pop() {
[[ $# -eq 0 || $# -gt 2 ]] && die "estack_pop: incorrect # of arguments"
- # We use the fugly __estack_xxx var names to avoid collision with
+ # We use the fugly _estack_xxx var names to avoid collision with
# passing back the return value. If we used "local i" and the
# caller ran `estack_pop ... i`, we'd end up setting the local
- # copy of "i" rather than the caller's copy. The __estack_xxx
+ # copy of "i" rather than the caller's copy. The _estack_xxx
# garbage is preferable to using $1/$2 everywhere as that is a
# bit harder to read.
- local __estack_name="__ESTACK_$1__" ; shift
- local __estack_retvar=$1 ; shift
- eval local __estack_i=\${#${__estack_name}\[@\]}
+ local _estack_name="_ESTACK_$1_" ; shift
+ local _estack_retvar=$1 ; shift
+ eval local _estack_i=\${#${_estack_name}\[@\]}
# Don't warn -- let the caller interpret this as a failure
# or as normal behavior (akin to `shift`)
- [[ $(( --__estack_i )) -eq -1 ]] && return 1
+ [[ $(( --_estack_i )) -eq -1 ]] && return 1
- if [[ -n ${__estack_retvar} ]] ; then
- eval ${__estack_retvar}=\"\${${__estack_name}\[${__estack_i}\]}\"
+ if [[ -n ${_estack_retvar} ]] ; then
+ eval ${_estack_retvar}=\"\${${_estack_name}\[${_estack_i}\]}\"
fi
- eval unset ${__estack_name}\[${__estack_i}\]
+ eval unset ${_estack_name}\[${_estack_i}\]
}
# @FUNCTION: evar_push
@@ -174,7 +174,7 @@ evar_push() {
for var ; do
[[ ${!var+set} == "set" ]] \
&& val=${!var} \
- || val="${___ECLASS_ONCE_EUTILS}"
+ || val="unset_76fc3c462065bb4ca959f939e6793f94"
estack_push evar "${var}" "${val}"
done
}
@@ -211,7 +211,7 @@ evar_pop() {
while (( cnt-- )) ; do
estack_pop evar val || die "${FUNCNAME}: unbalanced push"
estack_pop evar var || die "${FUNCNAME}: unbalanced push"
- [[ ${val} == "${___ECLASS_ONCE_EUTILS}" ]] \
+ [[ ${val} == "unset_76fc3c462065bb4ca959f939e6793f94" ]] \
&& unset ${var} \
|| printf -v "${var}" '%s' "${val}"
done
diff --git a/eclass/fcaps.eclass b/eclass/fcaps.eclass
index 76f3c35488fd..e27d6449aec3 100644
--- a/eclass/fcaps.eclass
+++ b/eclass/fcaps.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/fcaps.eclass,v 1.8 2013/06/27 01:18:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/fcaps.eclass,v 1.9 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: fcaps.eclass
# @MAINTAINER:
@@ -28,8 +28,8 @@
# )
# @CODE
-if [[ ${___ECLASS_ONCE_FCAPS} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_FCAPS="recur -_+^+_- spank"
+if [[ -z ${_FCAPS_ECLASS} ]]; then
+_FCAPS_ECLASS=1
IUSE="+filecaps"
@@ -182,8 +182,8 @@ fcaps() {
continue 2
fi
done
- if [[ ${notfound} -eq 2 ]] && [[ -z ${__FCAPS_WARNED} ]] ; then
- __FCAPS_WARNED="true"
+ if [[ ${notfound} -eq 2 ]] && [[ -z ${_FCAPS_WARNED} ]] ; then
+ _FCAPS_WARNED="true"
ewarn "Could not find cap utils; make sure libcap or libcap-ng is available."
fi
fi
diff --git a/eclass/fixheadtails.eclass b/eclass/fixheadtails.eclass
index 435d194e25ff..a760c6b51c53 100644
--- a/eclass/fixheadtails.eclass
+++ b/eclass/fixheadtails.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/fixheadtails.eclass,v 1.12 2011/08/22 04:46:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/fixheadtails.eclass,v 1.13 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: fixheadtails.eclass
# @MAINTAINER:
@@ -11,7 +11,7 @@
DEPEND=">=sys-apps/sed-4"
-__do_sed_fix() {
+_do_sed_fix() {
einfo " - fixed $1"
sed -i \
-e 's/head \+-\([0-9]\)/head -n \1/g' \
@@ -28,7 +28,7 @@ ht_fix_file() {
local i
einfo "Replacing obsolete head/tail with POSIX compliant ones"
for i in "$@" ; do
- __do_sed_fix "$i"
+ _do_sed_fix "$i"
done
}
diff --git a/eclass/flag-o-matic.eclass b/eclass/flag-o-matic.eclass
index 6ce69577081c..6d5b1ed549ee 100644
--- a/eclass/flag-o-matic.eclass
+++ b/eclass/flag-o-matic.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/flag-o-matic.eclass,v 1.200 2014/07/04 08:01:51 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/flag-o-matic.eclass,v 1.201 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: flag-o-matic.eclass
# @MAINTAINER:
@@ -10,8 +10,8 @@
# This eclass contains a suite of functions to help developers sanely
# and safely manage toolchain flags in their builds.
-if [[ ${___ECLASS_ONCE_FLAG_O_MATIC} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_FLAG_O_MATIC="recur -_+^+_- spank"
+if [[ -z ${_FLAG_O_MATIC_ECLASS} ]]; then
+_FLAG_O_MATIC_ECLASS=1
inherit eutils toolchain-funcs multilib
diff --git a/eclass/games.eclass b/eclass/games.eclass
index 4a26f77d9194..28f2ba3cdd47 100644
--- a/eclass/games.eclass
+++ b/eclass/games.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/games.eclass,v 1.157 2014/03/12 18:54:12 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/games.eclass,v 1.158 2014/07/11 08:21:58 ulm Exp $
# devlist: games@gentoo.org
#
@@ -8,8 +8,8 @@
# you better have a *good* reason why you're *not* using games.eclass
# in a games-* ebuild
-if [[ ${___ECLASS_ONCE_GAMES} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_GAMES="recur -_+^+_- spank"
+if [[ -z ${_GAMES_ECLASS} ]]; then
+_GAMES_ECLASS=1
inherit base multilib toolchain-funcs eutils user
diff --git a/eclass/kde4-base.eclass b/eclass/kde4-base.eclass
index dd1bb47f062f..838930843b7f 100644
--- a/eclass/kde4-base.eclass
+++ b/eclass/kde4-base.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.137 2014/07/04 08:01:51 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-base.eclass,v 1.138 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: kde4-base.eclass
# @MAINTAINER:
@@ -13,8 +13,8 @@
# NOTE: KDE 4 ebuilds currently support EAPIs 4 and 5. This will be
# reviewed over time as new EAPI versions are approved.
-if [[ ${___ECLASS_ONCE_KDE4_BASE} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_KDE4_BASE="recur -_+^+_- spank"
+if [[ -z ${_KDE4_BASE_ECLASS} ]]; then
+_KDE4_BASE_ECLASS=1
# @ECLASS-VARIABLE: KDE_SELINUX_MODULE
# @DESCRIPTION:
diff --git a/eclass/kde4-functions.eclass b/eclass/kde4-functions.eclass
index 746955dfe500..89031a57b951 100644
--- a/eclass/kde4-functions.eclass
+++ b/eclass/kde4-functions.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-functions.eclass,v 1.69 2014/07/04 08:01:51 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-functions.eclass,v 1.70 2014/07/11 08:21:58 ulm Exp $
inherit versionator
@@ -12,8 +12,8 @@ inherit versionator
# This eclass contains all functions shared by the different eclasses,
# for KDE 4 ebuilds.
-if [[ ${___ECLASS_ONCE_KDE4_FUNCTIONS} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_KDE4_FUNCTIONS="recur -_+^+_- spank"
+if [[ -z ${_KDE4_FUNCTIONS_ECLASS} ]]; then
+_KDE4_FUNCTIONS_ECLASS=1
# @ECLASS-VARIABLE: EAPI
# @DESCRIPTION:
diff --git a/eclass/kde4-meta-pkg.eclass b/eclass/kde4-meta-pkg.eclass
index 252402057e15..f7ea13057337 100644
--- a/eclass/kde4-meta-pkg.eclass
+++ b/eclass/kde4-meta-pkg.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta-pkg.eclass,v 1.12 2013/04/07 17:33:18 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta-pkg.eclass,v 1.13 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: kde4-meta-pkg.eclass
# @MAINTAINER:
@@ -9,8 +9,8 @@
# @DESCRIPTION:
# This eclass should only be used for defining meta packages for KDE4.
-if [[ ${___ECLASS_ONCE_KDE4_META_PKG} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_KDE4_META_PKG="recur -_+^+_- spank"
+if [[ -z ${_KDE4_META_PKG_ECLASS} ]]; then
+_KDE4_META_PKG_ECLASS=1
inherit kde4-functions
diff --git a/eclass/kde4-meta.eclass b/eclass/kde4-meta.eclass
index 997c6de0d21e..26068f7199f5 100644
--- a/eclass/kde4-meta.eclass
+++ b/eclass/kde4-meta.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.76 2014/04/17 18:16:54 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kde4-meta.eclass,v 1.77 2014/07/11 08:21:58 ulm Exp $
#
# @ECLASS: kde4-meta.eclass
# @MAINTAINER:
@@ -12,8 +12,8 @@
# You must define KMNAME to use this eclass, and do so before inheriting it. All other variables are optional.
# Do not include the same item in more than one of KMMODULE, KMMEXTRA, KMCOMPILEONLY, KMEXTRACTONLY.
-if [[ ${___ECLASS_ONCE_KDE4_META} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_KDE4_META="recur -_+^+_- spank"
+if [[ -z ${_KDE4_META_ECLASS} ]]; then
+_KDE4_META_ECLASS=1
[[ -z ${KMNAME} ]] && die "kde4-meta.eclass inherited but KMNAME not defined - broken ebuild"
@@ -167,7 +167,7 @@ kde4-meta_src_extract() {
|| die "${escm}: can't export cmake files to '${S}'."
fi
# Copy all subdirectories
- for subdir in $(__list_needed_subdirectories); do
+ for subdir in $(_list_needed_subdirectories); do
targetdir=""
if [[ $subdir = doc/* && ! -e "$wc_path/$subdir" ]]; then
continue
@@ -196,7 +196,7 @@ kde4-meta_src_extract() {
tarfile="${DISTDIR}/${tarball}"
# Detect real toplevel dir from tarball name - it will be used upon extraction
- # and in __list_needed_subdirectories
+ # and in _list_needed_subdirectories
topdir="${tarball%.tar.*}/"
ebegin "Unpacking parts of ${tarball} to ${WORKDIR}"
@@ -207,7 +207,7 @@ kde4-meta_src_extract() {
do
extractlist+=" ${topdir}${f}"
done
- extractlist+=" $(__list_needed_subdirectories)"
+ extractlist+=" $(_list_needed_subdirectories)"
pushd "${WORKDIR}" > /dev/null
@@ -228,7 +228,7 @@ kde4-meta_src_extract() {
eend $?
if [[ -n ${KDE4_STRICTER} ]]; then
- for f in $(__list_needed_subdirectories fatal); do
+ for f in $(_list_needed_subdirectories fatal); do
if [[ ! -e ${S}/${f#*/} ]]; then
eerror "'${f#*/}' is missing"
abort=true
@@ -311,7 +311,7 @@ kde4-meta_create_extractlists() {
debug-print "line ${LINENO} ${ECLASS} ${FUNCNAME}: KMEXTRACTONLY ${KMEXTRACTONLY}"
}
-__list_needed_subdirectories() {
+_list_needed_subdirectories() {
local i j kmextra kmextra_expanded kmmodule_expanded kmcompileonly_expanded extractlist
# We expand KMEXTRA by adding CMakeLists.txt files
diff --git a/eclass/libtool.eclass b/eclass/libtool.eclass
index 030612ce4d70..a92db7640a90 100644
--- a/eclass/libtool.eclass
+++ b/eclass/libtool.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/libtool.eclass,v 1.111 2014/06/12 07:14:25 haubi Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/libtool.eclass,v 1.112 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: libtool.eclass
# @MAINTAINER:
@@ -14,8 +14,8 @@
# generated libtool files. We do not run the libtoolize program because that
# requires a regeneration of the main autotool files in order to work properly.
-if [[ ${___ECLASS_ONCE_LIBTOOL} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_LIBTOOL="recur -_+^+_- spank"
+if [[ -z ${_LIBTOOL_ECLASS} ]]; then
+_LIBTOOL_ECLASS=1
# If an overlay has eclass overrides, but doesn't actually override the
# libtool.eclass, we'll have ECLASSDIR pointing to the active overlay's
@@ -43,8 +43,8 @@ ELT_try_and_apply_patch() {
local disp="${src} patch"
local log="${T}/elibtool.log"
- if [[ -z ${__ELT_NOTED_TMP} ]] ; then
- __ELT_NOTED_TMP=true
+ if [[ -z ${_ELT_NOTED_TMP} ]] ; then
+ _ELT_NOTED_TMP=true
printf 'temp patch: %s\n' "${patch}" > "${log}"
fi
printf '\nTrying %s\n' "${disp}" >> "${log}"
diff --git a/eclass/multilib.eclass b/eclass/multilib.eclass
index fd4f5fdc827f..b3e9903de32c 100644
--- a/eclass/multilib.eclass
+++ b/eclass/multilib.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/multilib.eclass,v 1.105 2014/01/17 07:44:45 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/multilib.eclass,v 1.106 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: multilib.eclass
# @MAINTAINER:
@@ -10,8 +10,8 @@
# @DESCRIPTION:
# This eclass is for all functions pertaining to handling multilib configurations.
-if [[ ${___ECLASS_ONCE_MULTILIB} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_MULTILIB="recur -_+^+_- spank"
+if [[ -z ${_MULTILIB_ECLASS} ]]; then
+_MULTILIB_ECLASS=1
inherit toolchain-funcs
@@ -414,13 +414,13 @@ multilib_toolchain_setup() {
export ABI=$1
# First restore any saved state we have laying around.
- if [[ ${__DEFAULT_ABI_SAVED} == "true" ]] ; then
+ if [[ ${_DEFAULT_ABI_SAVED} == "true" ]] ; then
for v in CHOST CBUILD AS CC CXX LD PKG_CONFIG_{LIBDIR,PATH} ; do
- vv="__abi_saved_${v}"
+ vv="_abi_saved_${v}"
[[ ${!vv+set} == "set" ]] && export ${v}="${!vv}" || unset ${v}
unset ${vv}
done
- unset __DEFAULT_ABI_SAVED
+ unset _DEFAULT_ABI_SAVED
fi
# We want to avoid the behind-the-back magic of gcc-config as it
@@ -428,10 +428,10 @@ multilib_toolchain_setup() {
if [[ ${ABI} != ${DEFAULT_ABI} ]] ; then
# Back that multilib-ass up so we can restore it later
for v in CHOST CBUILD AS CC CXX LD PKG_CONFIG_{LIBDIR,PATH} ; do
- vv="__abi_saved_${v}"
+ vv="_abi_saved_${v}"
[[ ${!v+set} == "set" ]] && export ${vv}="${!v}" || unset ${vv}
done
- export __DEFAULT_ABI_SAVED="true"
+ export _DEFAULT_ABI_SAVED="true"
# Set the CHOST native first so that we pick up the native
# toolchain and not a cross-compiler by accident #202811.
diff --git a/eclass/multiprocessing.eclass b/eclass/multiprocessing.eclass
index 0ee0abaafd05..3890f9197d7d 100644
--- a/eclass/multiprocessing.eclass
+++ b/eclass/multiprocessing.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/multiprocessing.eclass,v 1.8 2013/12/21 09:40:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/multiprocessing.eclass,v 1.9 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: multiprocessing.eclass
# @MAINTAINER:
@@ -33,8 +33,8 @@
# multijob_finish
# @CODE
-if [[ ${___ECLASS_ONCE_MULTIPROCESSING} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_MULTIPROCESSING="recur -_+^+_- spank"
+if [[ -z ${_MULTIPROCESSING_ECLASS} ]]; then
+_MULTIPROCESSING_ECLASS=1
# @FUNCTION: bashpid
# @DESCRIPTION:
diff --git a/eclass/pam.eclass b/eclass/pam.eclass
index 97f418ce747c..f55a93873fc7 100644
--- a/eclass/pam.eclass
+++ b/eclass/pam.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/eclass/pam.eclass,v 1.23 2012/08/05 15:34:20 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/pam.eclass,v 1.24 2014/07/11 08:21:58 ulm Exp $
#
# @ECLASS: pam.eclass
@@ -13,8 +13,8 @@
# This eclass contains functions to install pamd configuration files and
# pam modules.
-if [[ ${___ECLASS_ONCE_PAM} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_PAM="recur -_+^+_- spank"
+if [[ -z ${_PAM_ECLASS} ]]; then
+_PAM_ECLASS=1
inherit flag-o-matic multilib
diff --git a/eclass/pax-utils.eclass b/eclass/pax-utils.eclass
index 547d6ac1ad56..719e15bdfe24 100644
--- a/eclass/pax-utils.eclass
+++ b/eclass/pax-utils.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/pax-utils.eclass,v 1.21 2013/05/18 13:43:20 zorry Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/pax-utils.eclass,v 1.22 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: pax-utils.eclass
# @MAINTAINER:
@@ -22,8 +22,8 @@
# to contain either "PT", "XT" or "none". The default is to attempt both
# PT_PAX and XATTR_PAX.
-if [[ ${___ECLASS_ONCE_PAX_UTILS} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_PAX_UTILS="recur -_+^+_- spank"
+if [[ -z ${_PAX_UTILS_ECLASS} ]]; then
+_PAX_UTILS_ECLASS=1
# @ECLASS-VARIABLE: PAX_MARKINGS
# @DESCRIPTION:
diff --git a/eclass/portability.eclass b/eclass/portability.eclass
index 889de540fcf6..b6c41e4f0cf0 100644
--- a/eclass/portability.eclass
+++ b/eclass/portability.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/portability.eclass,v 1.25 2014/05/28 09:48:01 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/portability.eclass,v 1.26 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: portability.eclass
# @MAINTAINER:
@@ -9,8 +9,8 @@
# Diego Pettenò <flameeyes@gentoo.org>
# @BLURB: This eclass is created to avoid using non-portable GNUisms inside ebuilds
-if [[ ${___ECLASS_ONCE_PORTABILITY} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_PORTABILITY="recur -_+^+_- spank"
+if [[ -z ${_PORTABILITY_ECLASS} ]]; then
+_PORTABILITY_ECLASS=1
# @FUNCTION: treecopy
# @USAGE: <orig1> [orig2 orig3 ....] <dest>
diff --git a/eclass/qmake-utils.eclass b/eclass/qmake-utils.eclass
index ee7cad0c6a81..44576757d291 100644
--- a/eclass/qmake-utils.eclass
+++ b/eclass/qmake-utils.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/qmake-utils.eclass,v 1.1 2013/12/02 09:42:38 pinkbyte Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/qmake-utils.eclass,v 1.2 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: qmake-utils.eclass
# @MAINTAINER:
@@ -11,8 +11,8 @@
# @DESCRIPTION:
# Utility eclass providing wrapper functions for Qt4 and Qt5 qmake.
-if [[ ${___ECLASS_ONCE_QMAKE_UTILS} != "recur -_+^+_- spank" ]]; then
-___ECLASS_ONCE_QMAKE_UTILS="recur -_+^+_- spank"
+if [[ -z ${_QMAKE_UTILS_ECLASS} ]]; then
+_QMAKE_UTILS_ECLASS=1
inherit eutils multilib toolchain-funcs
diff --git a/eclass/readme.gentoo.eclass b/eclass/readme.gentoo.eclass
index 48803c677cd2..d791ed4cbad3 100644
--- a/eclass/readme.gentoo.eclass
+++ b/eclass/readme.gentoo.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/readme.gentoo.eclass,v 1.11 2014/07/02 13:32:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/readme.gentoo.eclass,v 1.12 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: readme.gentoo
# @MAINTAINER:
@@ -15,8 +15,8 @@
# shown at first package installation and a file for later reviewing will be
# installed under /usr/share/doc/${PF}
-if [[ ${___ECLASS_ONCE_README_GENTOO} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_README_GENTOO="recur -_+^+_- spank"
+if [[ -z ${_README_GENTOO_ECLASS} ]]; then
+_README_GENTOO_ECLASS=1
inherit eutils
diff --git a/eclass/toolchain-funcs.eclass b/eclass/toolchain-funcs.eclass
index 460adcc5fd5f..45e72f723739 100644
--- a/eclass/toolchain-funcs.eclass
+++ b/eclass/toolchain-funcs.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain-funcs.eclass,v 1.126 2014/01/17 03:46:31 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/toolchain-funcs.eclass,v 1.127 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: toolchain-funcs.eclass
# @MAINTAINER:
@@ -13,8 +13,8 @@
# in such a way that you can rely on the function always returning
# something sane.
-if [[ ${___ECLASS_ONCE_TOOLCHAIN_FUNCS} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_TOOLCHAIN_FUNCS="recur -_+^+_- spank"
+if [[ -z ${_TOOLCHAIN_FUNCS_ECLASS} ]]; then
+_TOOLCHAIN_FUNCS_ECLASS=1
inherit multilib
diff --git a/eclass/unpacker.eclass b/eclass/unpacker.eclass
index 076115f0e111..39268ed9905a 100644
--- a/eclass/unpacker.eclass
+++ b/eclass/unpacker.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/unpacker.eclass,v 1.17 2014/05/01 19:27:14 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/unpacker.eclass,v 1.18 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: unpacker.eclass
# @MAINTAINER:
@@ -15,8 +15,8 @@
# - merge rpm unpacking
# - support partial unpacks?
-if [[ ${___ECLASS_ONCE_UNPACKER} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_UNPACKER="recur -_+^+_- spank"
+if [[ -z ${_UNPACKER_ECLASS} ]]; then
+_UNPACKER_ECLASS=1
# @ECLASS-VARIABLE: UNPACKER_BZ2
# @DEFAULT_UNSET
diff --git a/eclass/user.eclass b/eclass/user.eclass
index a44acaddb750..d09d61be5bd2 100644
--- a/eclass/user.eclass
+++ b/eclass/user.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/user.eclass,v 1.23 2014/07/04 08:01:51 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/user.eclass,v 1.24 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: user.eclass
# @MAINTAINER:
@@ -13,8 +13,8 @@
# The user eclass contains a suite of functions that allow ebuilds
# to quickly make sure users in the installed system are sane.
-if [[ ${___ECLASS_ONCE_USER} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_USER="recur -_+^+_- spank"
+if [[ -z ${_USER_ECLASS} ]]; then
+_USER_ECLASS=1
# @FUNCTION: _assert_pkg_ebuild_phase
# @INTERNAL
diff --git a/eclass/versionator.eclass b/eclass/versionator.eclass
index bab92cf7d9ab..a67863fdb4e5 100644
--- a/eclass/versionator.eclass
+++ b/eclass/versionator.eclass
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/versionator.eclass,v 1.24 2013/11/23 04:35:16 jcallen Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/versionator.eclass,v 1.25 2014/07/11 08:21:58 ulm Exp $
# @ECLASS: versionator.eclass
# @MAINTAINER:
@@ -26,8 +26,8 @@
# version_is_at_least want have
# which may be buggy, so use with caution.
-if [[ ${___ECLASS_ONCE_VERSIONATOR} != "recur -_+^+_- spank" ]] ; then
-___ECLASS_ONCE_VERSIONATOR="recur -_+^+_- spank"
+if [[ -z ${_VERSIONATOR_ECLASS} ]]; then
+_VERSIONATOR_ECLASS=1
inherit eutils