summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-28 16:45:24 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-28 16:45:24 +0000
commit46fe72eaf621b01fbb0f7ab3f2ebb431b976a3bf (patch)
treee3f4086623ef31baa29c3b068e7752ca47eeeb94 /eclass
parentFix ldd symlink again. Bug #544306. (diff)
downloadhistorical-46fe72eaf621b01fbb0f7ab3f2ebb431b976a3bf.tar.gz
historical-46fe72eaf621b01fbb0f7ab3f2ebb431b976a3bf.tar.bz2
historical-46fe72eaf621b01fbb0f7ab3f2ebb431b976a3bf.zip
Drop obsolete eclass and add new version, thanks Ted Tanberry for the work
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog6
-rw-r--r--eclass/emboss-r1.eclass (renamed from eclass/emboss.eclass)83
2 files changed, 47 insertions, 42 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index 1ee03e8696fa..7c183ceffd8b 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for eclass directory
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.1575 2015/03/28 13:32:40 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.1576 2015/03/28 16:45:24 jlec Exp $
+
+ 28 Mar 2015; Justin Lecher <jlec@gentoo.org> -emboss.eclass,
+ +emboss-r1.eclass:
+ Drop obsolete eclass and add new version, thanks Ted Tanberry for the work
28 Mar 2015; Sergei Trofimovich <slyfox@gentoo.org> ghc-package.eclass,
haskell-cabal.eclass:
diff --git a/eclass/emboss.eclass b/eclass/emboss-r1.eclass
index f2fd9452c118..1fff920c58e6 100644
--- a/eclass/emboss.eclass
+++ b/eclass/emboss-r1.eclass
@@ -1,28 +1,29 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/emboss.eclass,v 1.3 2012/09/27 16:35:41 axs Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/emboss-r1.eclass,v 1.1 2015/03/28 16:45:24 jlec Exp $
-# @ECLASS: emboss.eclass
+# @ECLASS: emboss-r1.eclass
# @MAINTAINER:
# sci-biology@gentoo.org
# jlec@gentoo.org
+# ted.tanberry@gmail.com
# @AUTHOR:
# Original author: Author Olivier Fisette <ofisette@gmail.com>
# Next gen author: Justin Lecher <jlec@gentoo.org>
+# Next gen author: Ted Tanberry <ted.tanberry@gmail.com>
# @BLURB: Use this to easy install EMBOSS and EMBASSY programs (EMBOSS add-ons).
# @DESCRIPTION:
-# The inheriting ebuild must set EAPI=4 and provide EBO_DESCRIPTION before the inherit line.
+# The inheriting ebuild must set at least EAPI=5 and provide EBO_DESCRIPTION before the inherit line.
# KEYWORDS should be set. Additionally "(R|P)DEPEND"encies and other standard
# ebuild variables can be extended (FOO+=" bar").
-# Default installation of following DOCS="AUTHORS ChangeLog NEWS README"
#
# Example:
#
-# EAPI="4"
+# EAPI="5"
#
# EBO_DESCRIPTION="applications from the CBS group"
#
-# inherit emboss
+# inherit emboss-r1
# @ECLASS-VARIABLE: EBO_DESCRIPTION
# @DESCRIPTION:
@@ -34,22 +35,17 @@
#
# Defaults to the upstream name of the module.
-# @ECLASS-VARIABLE: EBO_EAUTORECONF
-# @DESCRIPTION:
-# Set to 'no', if you don't want eautoreconf to be run after patching.
-: ${EBO_EAUTORECONF:=yes}
-
# @ECLASS-VARIABLE: EBO_EXTRA_ECONF
# @DEFAULT_UNSET
# @DESCRIPTION:
-# Extra config options passed to econf, similar to EXTRA_ECONF.
+# Extra config options passed to econf.
case ${EAPI:-0} in
- 4|5) ;;
- *) die "this eclass doesn't support < EAPI 4" ;;
+ 5) ;;
+ *) die "this eclass doesn't support < EAPI 5" ;;
esac
-inherit autotools eutils
+inherit autotools-utils eutils flag-o-matic
HOMEPAGE="http://emboss.sourceforge.net/"
LICENSE="LGPL-2 GPL-2"
@@ -62,14 +58,15 @@ DEPEND="
dev-libs/libpcre:3
sci-libs/plplot
sys-libs/zlib
- mysql? ( dev-db/mysql )
+ mysql? ( virtual/mysql )
pdf? ( media-libs/libharu )
png? ( media-libs/gd[png] )
- postgres? ( dev-db/postgresql-base )
+ postgres? ( dev-db/postgresql:= )
X? ( x11-libs/libXt )"
RDEPEND="${DEPEND}"
if [[ ${PN} == embassy-* ]]; then
+ EMBASSY_PACKAGE=yes
# The EMBASSY package name, retrieved from the inheriting ebuild's name
EN=${PN:8}
# The full name and version of the EMBASSY package (excluding the Gentoo
@@ -77,25 +74,26 @@ if [[ ${PN} == embassy-* ]]; then
EF=$(echo ${EN} | tr "[:lower:]" "[:upper:]")-${PV}
: ${EBO_DESCRIPTION:=${EN}}
DESCRIPTION="EMBOSS integrated version of ${EBO_DESCRIPTION}"
- SRC_URI="ftp://emboss.open-bio.org/pub/EMBOSS/${EF}.tar.gz -> embassy-${EN}-${PV}.tar.gz"
- DEPEND+=" >=sci-biology/emboss-6.3.1_p4[mysql=,pdf=,png=,postgres=,static-libs=,X=]"
+ SRC_URI="ftp://emboss.open-bio.org/pub/EMBOSS/${EF}.tar.gz -> embassy-${EN}-${PVR}.tar.gz"
+ DEPEND+=" >=sci-biology/emboss-6.6.0[mysql=,pdf=,png=,postgres=,static-libs=,X=]"
S="${WORKDIR}"/${EF}
fi
-DOCS="AUTHORS ChangeLog NEWS README"
-
# @FUNCTION: emboss_src_prepare
# @DESCRIPTION:
-# Does following things
+# Does the following things
#
-# 1. Patches with "${FILESDIR}"/${PF}.patch, if present
-# 2. Runs eautoreconf, unless EBO_EAUTORECONF is set to no
+# 1. Renames configure.in to configure.ac, if possible
+# 2. Applies ${PATCHES[@]} and runs autotools via autotools-utils.eclass
#
-emboss_src_prepare() {
- [[ -f ${FILESDIR}/${PF}.patch ]] && epatch "${FILESDIR}"/${PF}.patch
- [[ ${EBO_EAUTORECONF} == yes ]] && eautoreconf
+emboss-r1_src_prepare() {
+ if [[ -e configure.in ]]; then
+ mv configure.{in,ac} || die
+ fi
+
+ autotools-utils_src_prepare
}
# @FUNCTION: emboss_src_configure
@@ -111,22 +109,25 @@ emboss_src_prepare() {
# --enable-large
# --without-java
# --enable-systemlibs
-# --docdir="${EPREFIX}/usr/share/doc/${PF}"
# ${EBO_EXTRA_ECONF}
-emboss_src_configure() {
- econf \
- $(use_with X x) \
- $(use_with png pngdriver) \
- $(use_with pdf hpdf) \
- $(use_with mysql mysql) \
- $(use_with postgres postgresql) \
- $(use_enable static-libs static) \
- --enable-large \
- --without-java \
- --enable-systemlibs \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+emboss-r1_src_configure() {
+ local myeconfargs=(
+ $(use_with X x)
+ $(use_with png pngdriver "${EPREFIX}/usr")
+ $(use_with pdf hpdf "${EPREFIX}/usr")
+ $(use_with mysql mysql "${EPREFIX}/usr/bin/mysql_config")
+ $(use_with postgres postgresql "${EPREFIX}/usr/bin/pg_config")
+ --enable-large
+ --without-java
+ --enable-systemlibs
${EBO_EXTRA_ECONF}
+ )
+
+ [[ ${EMBASSY_PACKAGE} == yes ]] && \
+ append-cppflags "-I${EPREFIX}/usr/include/emboss"
+
+ autotools-utils_src_configure
}
EXPORT_FUNCTIONS src_prepare src_configure