summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Brown <rbrown@gentoo.org>2007-05-17 19:25:52 +0000
committerRichard Brown <rbrown@gentoo.org>2007-05-17 19:25:52 +0000
commitae900813e54c735e753b0e797c7db53be98bc6e9 (patch)
treed0830e0073a937bf67161b8865319c25b398af29 /eclass/ruby.eclass
parentFix missing Manifest entry for foremost-1.5.ebuild. (diff)
downloadhistorical-ae900813e54c735e753b0e797c7db53be98bc6e9.tar.gz
historical-ae900813e54c735e753b0e797c7db53be98bc6e9.tar.bz2
historical-ae900813e54c735e753b0e797c7db53be98bc6e9.zip
Explicitly add ruby to RDEPEND
Diffstat (limited to 'eclass/ruby.eclass')
-rw-r--r--eclass/ruby.eclass5
1 files changed, 3 insertions, 2 deletions
diff --git a/eclass/ruby.eclass b/eclass/ruby.eclass
index e0eaf0e4da8b..28caebb147f0 100644
--- a/eclass/ruby.eclass
+++ b/eclass/ruby.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ruby.eclass,v 1.64 2007/04/07 08:52:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ruby.eclass,v 1.65 2007/05/17 19:25:52 rbrown Exp $
#
# Author: Mamoru KOMACHI <usata@gentoo.org>
#
@@ -48,7 +48,8 @@ LICENSE="Ruby"
# If you specify RUBY_OPTIONAL you also need to take care of ruby useflag and dependency.
if [[ ${RUBY_OPTIONAL} != "yes" ]]; then
- DEPEND="virtual/ruby"
+ DEPEND="${DEPEND} virtual/ruby"
+ RDEPEND="${RDEPEND} virtual/ruby"
fi
[[ -z "${RUBY}" ]] && export RUBY=/usr/bin/ruby