summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-05-27 23:46:13 +0000
committerMike Frysinger <vapier@gentoo.org>2005-05-27 23:46:13 +0000
commit79da071cfa41c2b80f85c288d924456bb789f5a6 (patch)
treed8ae8d06d3f1b78e84f8d1c2092a0b3133170e29 /eclass/libtool.eclass
parent-amd64 until I get around to fixing the bad cast. (diff)
downloadhistorical-79da071cfa41c2b80f85c288d924456bb789f5a6.tar.gz
historical-79da071cfa41c2b80f85c288d924456bb789f5a6.tar.bz2
historical-79da071cfa41c2b80f85c288d924456bb789f5a6.zip
dont run libtoolize anymore
Diffstat (limited to 'eclass/libtool.eclass')
-rw-r--r--eclass/libtool.eclass7
1 files changed, 5 insertions, 2 deletions
diff --git a/eclass/libtool.eclass b/eclass/libtool.eclass
index 66314eac9722..74385eaca674 100644
--- a/eclass/libtool.eclass
+++ b/eclass/libtool.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/libtool.eclass,v 1.46 2005/05/11 15:15:03 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/libtool.eclass,v 1.47 2005/05/27 23:46:13 vapier Exp $
#
# Author: Martin Schlemmer <azarah@gentoo.org>
#
@@ -252,6 +252,9 @@ elibtoolize() {
${do_only_patches} == "no" && \
${deptoremove} == "" ]]
then
+ ewarn "Cannot apply any patches, please file a bug about this"
+ break
+
# Sometimes ltmain.sh is in a subdirectory ...
if [[ ! -f ${x}/configure.in && ! -f ${x}/configure.ac ]] ; then
if [[ -f ${x}/../configure.in || -f ${x}/../configure.ac ]] ; then
@@ -260,7 +263,7 @@ elibtoolize() {
fi
if type -p libtoolize &> /dev/null ; then
- ewarn "Cannot apply any patch, running libtoolize..."
+ ewarn "Cannot apply any patches, running libtoolize..."
libtoolize --copy --force
fi
cd "${x}"