summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2010-03-26 20:24:46 +0000
committerSebastian Pipping <sping@gentoo.org>2010-03-26 20:24:46 +0000
commitc8d7bd83f3bd07673e3ec75822a1d0aee2394ff0 (patch)
tree0c375799805e17bbda9ae959fe8e8170da7dbe21 /dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild
parentDrop mask for gcc-config-1.5. It seems to work after some fixes, but it's st... (diff)
downloadhistorical-c8d7bd83f3bd07673e3ec75822a1d0aee2394ff0.tar.gz
historical-c8d7bd83f3bd07673e3ec75822a1d0aee2394ff0.tar.bz2
historical-c8d7bd83f3bd07673e3ec75822a1d0aee2394ff0.zip
dev-vcs/cvs2svn: New package (copied from dev-util/cvs2svn)
Package-Manager: portage-2.2_rc67_p26/cvs/Linux i686 RepoMan-Options: --force
Diffstat (limited to 'dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild')
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild
new file mode 100644
index 000000000000..015f9a5c68f8
--- /dev/null
+++ b/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.1.1.ebuild,v 1.1 2010/03/26 20:24:46 sping Exp $
+
+inherit distutils
+
+FILEVER="42521"
+
+DESCRIPTION="Convert a CVS repository to a Subversion repository"
+HOMEPAGE="http://cvs2svn.tigris.org/"
+SRC_URI="http://cvs2svn.tigris.org/files/documents/1462/${FILEVER}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ppc x86"
+IUSE=""
+
+DEPEND="dev-lang/python
+ >=dev-util/subversion-1.0.9"
+RDEPEND="${DEPEND}
+ dev-vcs/rcs"
+
+src_install() {
+ distutils_src_install
+ insinto "/usr/share/${PN}"
+ doins -r contrib cvs2svn-example.options {profile-repos,show-db,verify-cvs2svn}.py
+ doman cvs2svn.1
+}
+
+src_test() {
+ # Need this because subversion is localized, but the tests aren't
+ export LC_ALL=C
+ python run-tests.py || die "tests failed"
+}
+
+pkg_postinst() {
+ elog "Additional scripts and examples have been installed to:"
+ elog " /usr/share/${PN}/"
+}