summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2004-09-21 08:35:30 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2004-09-21 08:35:30 +0000
commite2ea2ed44be03074e04e940e1b446aa69e423433 (patch)
tree1c8427376de5b42d4307d611cee71fd3f8f40fde /dev-util
parentadded some die()'s in pkg_install() (diff)
downloadhistorical-e2ea2ed44be03074e04e940e1b446aa69e423433.tar.gz
historical-e2ea2ed44be03074e04e940e1b446aa69e423433.tar.bz2
historical-e2ea2ed44be03074e04e940e1b446aa69e423433.zip
Fix the ebuild to take the fs_fs into account, and add authz_svn support
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/subversion/ChangeLog8
-rw-r--r--dev-util/subversion/Manifest4
-rw-r--r--dev-util/subversion/subversion-1.1.0_rc2.ebuild103
3 files changed, 58 insertions, 57 deletions
diff --git a/dev-util/subversion/ChangeLog b/dev-util/subversion/ChangeLog
index efb8f2373c3c..85b5e6656945 100644
--- a/dev-util/subversion/ChangeLog
+++ b/dev-util/subversion/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/subversion
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/ChangeLog,v 1.97 2004/09/21 08:25:31 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/ChangeLog,v 1.98 2004/09/21 08:35:30 pauldv Exp $
+
+ 21 Sep 2004; Paul de Vrieze <pauldv@gentoo.org> subversion-1.1.0_rc2.ebuild:
+ Fix two issues. Bug #63991 to add support for authz_svn authentication in
+ the default apache2 configuration file (conditional). Bug #64672 to take
+ into account that with the new fs_fs support the server part is no longer
+ dependent on berkeley db.
21 Sep 2004; Paul de Vrieze <pauldv@gentoo.org> subversion-1.0.6.ebuild:
Fix the location of the jar archive (bug #64800)
diff --git a/dev-util/subversion/Manifest b/dev-util/subversion/Manifest
index e8e348f4fea5..7c83676b432f 100644
--- a/dev-util/subversion/Manifest
+++ b/dev-util/subversion/Manifest
@@ -4,11 +4,11 @@ MD5 50b381d130b73e50c2cddbf95cf8ad42 subversion-1.0.3.ebuild 9229
MD5 1b9acc042ae6c0b58071cf9ea8adc57a subversion-0.27.0.ebuild 7880
MD5 5cff2e6d2191553c86d931e5240ba23a subversion-0.32.1.ebuild 8136
MD5 6d782eebdb1eb7b3296fd8f7b9c3f98e subversion-1.0.4-r1.ebuild 9541
-MD5 5c23fb9e89ba23ca5974f9dde821774e ChangeLog 16288
+MD5 198c72ed72bc056c210fbeb94e3771f6 ChangeLog 16626
MD5 8fbcd267012fd1eef74d5161888cc7b8 metadata.xml 222
MD5 11edc2e84a30096642ba71e234b20108 subversion-1.0.4.ebuild 9381
MD5 477868a5a577d64402abbbe07dc32bcc subversion-1.0.6.ebuild 9724
-MD5 91e10ceb13f0dd81b23587de67771ed4 subversion-1.1.0_rc2.ebuild 9030
+MD5 57ae0ec6243ac831244c0ad20a0b5f15 subversion-1.1.0_rc2.ebuild 8866
MD5 e232822bee0a8ed00f6b9d7805b83307 files/digest-subversion-0.27.0 132
MD5 44e762d79cdf7048a3300c29c77f0e81 files/digest-subversion-1.0.1 70
MD5 a92dea7d8f92e84faf8e695b2bd93d42 files/digest-subversion-1.0.2 70
diff --git a/dev-util/subversion/subversion-1.1.0_rc2.ebuild b/dev-util/subversion/subversion-1.1.0_rc2.ebuild
index da58206782a0..ca18ffe1af59 100644
--- a/dev-util/subversion/subversion-1.1.0_rc2.ebuild
+++ b/dev-util/subversion/subversion-1.1.0_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.1.0_rc2.ebuild,v 1.4 2004/09/05 19:00:40 pauldv Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-1.1.0_rc2.ebuild,v 1.5 2004/09/21 08:35:30 pauldv Exp $
inherit elisp-common libtool python eutils
@@ -128,23 +128,21 @@ src_compile() {
( emake external-all && emake local-all ) || die "make of subversion failed"
fi
- #building fails without the apache apr-util as includes are wrong.
- #Also the python bindings do not work without db installed
- if use berkdb; then
- if use python; then
- if use apache2; then
- emake swig-py || die "subversion python bindings failed"
- else
- emake SVN_APR_INCLUDES="-I${S}/apr/include -I${S}/apr-util/include" swig-py || die "subversion python bindings failed"
- fi
- fi
- if use perl; then
- make swig-pl || die "Perl library building failed"
- fi
- if use java; then
- make JAVACFLAGS="-source 1.3 -encoding iso8859-1" javahl || die "Compilation failed"
+ if use python; then
+ #building fails without the apache apr-util as includes are wrong.
+ if use apache2; then
+ emake swig-py || die "subversion python bindings failed"
+ else
+ emake SVN_APR_INCLUDES="-I${S}/apr/include -I${S}/apr-util/include" swig-py || die "subversion python bindings failed"
fi
fi
+ if use perl; then
+ make swig-pl || die "Perl library building failed"
+ fi
+ if use java; then
+ make JAVACFLAGS="-source 1.3 -encoding iso8859-1" javahl || die "Compilation failed"
+ fi
+
cd ${S}
if use emacs; then
einfo "compiling emacs support"
@@ -170,23 +168,21 @@ src_install () {
fi
fi
- if use berkdb; then
- dobin svn-config
- if use python; then
- make install-swig-py DESTDIR=${D} DISTUTIL_PARAM=--prefix=${D} LD_LIBRARY_PATH="-L${D}/usr/lib" || die "Installation of subversion python bindings failed"
+ dobin svn-config
+ if use python; then
+ make install-swig-py DESTDIR=${D} DISTUTIL_PARAM=--prefix=${D} LD_LIBRARY_PATH="-L${D}/usr/lib" || die "Installation of subversion python bindings failed"
- # move python bindings
- mkdir -p ${D}${PYTHON_DIR}/site-packages
- mv ${D}/usr/lib/svn-python/svn ${D}${PYTHON_DIR}/site-packages
- mv ${D}/usr/lib/svn-python/libsvn ${D}${PYTHON_DIR}/site-packages
- rmdir ${D}/usr/lib/svn-python
- fi
- if use perl; then
- make DESTDIR=${D} install-swig-pl || die "Perl library building failed"
- fi
- if use java; then
- make DESTDIR="${D}" install-javahl || die "installation failed"
- fi
+ # move python bindings
+ mkdir -p ${D}${PYTHON_DIR}/site-packages
+ mv ${D}/usr/lib/svn-python/svn ${D}${PYTHON_DIR}/site-packages
+ mv ${D}/usr/lib/svn-python/libsvn ${D}${PYTHON_DIR}/site-packages
+ rmdir ${D}/usr/lib/svn-python
+ fi
+ if use perl; then
+ make DESTDIR=${D} install-swig-pl || die "Perl library building failed"
+ fi
+ if use java; then
+ make DESTDIR="${D}" install-javahl || die "installation failed"
fi
dodoc BUGS COMMITTERS COPYING HACKING INSTALL README
@@ -219,7 +215,7 @@ src_install () {
#Install apache module config
- if useq apache2 && useq berkdb; then
+ if useq apache2; then
mkdir -p ${D}/etc/apache2/conf/modules.d
cat <<EOF >${D}/etc/apache2/conf/modules.d/47_mod_dav_svn.conf
<IfDefine SVN>
@@ -234,6 +230,11 @@ src_install () {
AuthUserFile ${SVN_REPOS_LOC}/conf/svnusers
Require valid-user
</Location>
+ <IfDefine SVN_AUTHZ>
+ <IfModule !authz_svn_module.c>
+ LoadModule authz_svn_module extramodules/mod_authz_svn.so
+ </IfModule>
+ </IfDefine>
</IfDefine>
EOF
fi
@@ -242,29 +243,23 @@ EOF
pkg_postinst() {
use emacs && elisp-site-regen
- if use berkdb; then
- if use apache2; then
- einfo "Subversion has multiple server types. To enable the http based version"
- einfo "you must edit /etc/conf.d/apache2 to include both \"-D DAV\" and \"-D SVN\""
- einfo ""
- fi
- einfo "A repository needs to be created using the \"ebuild <path to ${PVR}.ebuild> config\" command"
- einfo "or using svnadmin (see man svnadmin) if this subversion install is used as server"
+ if use apache2; then
+ einfo "Subversion has multiple server types. To enable the http based version"
+ einfo "you must edit /etc/conf.d/apache2 to include both \"-D DAV\" and \"-D SVN\""
einfo ""
- einfo "If you upgraded from an older version of berkely db and experience"
- einfo "problems with your repository then run the following command:"
- einfo " su apache -c \"db4_recover -h /path/to/repos\""
-
- if use apache2; then
- einfo ""
- einfo "To allow web access a htpasswd file needs to be created using the"
- einfo "following command:"
- einfo " htpasswd2 -m -c ${SVN_REPOS_LOC}/conf/svnusers USERNAME"
- fi
+ fi
+ einfo "A repository needs to be created using the \"ebuild <path to ${PVR}.ebuild> config\" command"
+ einfo "or using svnadmin (see man svnadmin) if this subversion install is used as server"
+ einfo ""
+ einfo "If you upgraded from an older version of berkely db and experience"
+ einfo "problems with your repository then run the following command:"
+ einfo " su apache -c \"db4_recover -h /path/to/repos\""
- else
- einfo "Your subversion is client only as the server is only build when"
- einfo "the berkdb flag is set"
+ if use apache2; then
+ einfo ""
+ einfo "To allow web access a htpasswd file needs to be created using the"
+ einfo "following command:"
+ einfo " htpasswd2 -m -c ${SVN_REPOS_LOC}/conf/svnusers USERNAME"
fi
}