summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-01-16 12:05:25 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-01-16 12:05:25 +0000
commit65b5eab5ac69c03c6c3a7d41df510e596273b22a (patch)
treee426105c9ba6fdd160f33687b0971fb40a1b46cf /dev-util
parentclean up (diff)
downloadhistorical-65b5eab5ac69c03c6c3a7d41df510e596273b22a.tar.gz
historical-65b5eab5ac69c03c6c3a7d41df510e596273b22a.tar.bz2
historical-65b5eab5ac69c03c6c3a7d41df510e596273b22a.zip
estonian locale fix
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/dialog/ChangeLog8
-rw-r--r--dev-util/dialog/Manifest7
-rw-r--r--dev-util/dialog/dialog-0.9_beta20031002.ebuild10
-rw-r--r--dev-util/dialog/files/dialog-0.9_beta20031002-estonian-sed.patch137
4 files changed, 157 insertions, 5 deletions
diff --git a/dev-util/dialog/ChangeLog b/dev-util/dialog/ChangeLog
index 7f7b4668ffe5..0b3173a2de8b 100644
--- a/dev-util/dialog/ChangeLog
+++ b/dev-util/dialog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/dialog
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/ChangeLog,v 1.28 2004/01/14 03:30:38 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/ChangeLog,v 1.29 2004/01/16 12:05:25 seemant Exp $
+
+ 16 Jan 2004; Seemant Kulleen <seemant@gentoo.org>
+ dialog-0.9_beta20031002.ebuild :
+
+ Added a patch in files/ to fix the regexes in the configure script, so
+ this should be friendly to the Estonian (et_EE) locale finally
13 Jan 2004; Jon Portnoy <avenj@gentoo.org> dialog-0.9_beta20031002.ebuild :
Stable on AMD64.
diff --git a/dev-util/dialog/Manifest b/dev-util/dialog/Manifest
index 8f0a53b79d9e..ed650a590d55 100644
--- a/dev-util/dialog/Manifest
+++ b/dev-util/dialog/Manifest
@@ -1,7 +1,8 @@
-MD5 756fe47194fd01a5ecf782f0509c9d54 ChangeLog 4315
MD5 779bdce4b72bd427e3a101a00cdfa863 dialog-0.9_beta20020814.ebuild 737
+MD5 3d7f17273e17fd2bc81a389685d0f164 dialog-0.9_beta20031002.ebuild 882
MD5 998478c5933a2f8f4a0baddcc4925876 dialog-0.9_beta20030308-r1.ebuild 751
-MD5 00de8c9c30445dba4f7db1c6ad230dda dialog-0.9_beta20031002.ebuild 779
+MD5 caf357df38405844c660668e8a87e132 ChangeLog 4544
+MD5 fa5de41b2448fb24c52ed732502fb447 files/dialog-0.9_beta20031002-estonian-sed.patch 5669
MD5 83d91da6cd47dba6eee950aecd9d99a9 files/digest-dialog-0.9_beta20020814 77
-MD5 28b29c8805aa2ec280824b48d087a793 files/digest-dialog-0.9_beta20030308-r1 77
MD5 17918ae779a2bbc4038b5d41c84b2beb files/digest-dialog-0.9_beta20031002 77
+MD5 28b29c8805aa2ec280824b48d087a793 files/digest-dialog-0.9_beta20030308-r1 77
diff --git a/dev-util/dialog/dialog-0.9_beta20031002.ebuild b/dev-util/dialog/dialog-0.9_beta20031002.ebuild
index f2b7263ed84c..b42c85cd6981 100644
--- a/dev-util/dialog/dialog-0.9_beta20031002.ebuild
+++ b/dev-util/dialog/dialog-0.9_beta20031002.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/dialog-0.9_beta20031002.ebuild,v 1.9 2004/01/14 03:30:38 avenj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/dialog-0.9_beta20031002.ebuild,v 1.10 2004/01/16 12:05:25 seemant Exp $
+
+inherit eutils
MY_PV="${PV/_beta/b-}"
S=${WORKDIR}/${PN}-${MY_PV}
@@ -15,6 +17,12 @@ KEYWORDS="x86 ~ppc sparc alpha hppa ~arm amd64 ia64 ppc64 mips"
DEPEND=">=app-shells/bash-2.04-r3
>=sys-libs/ncurses-5.2-r5"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-estonian-sed.patch
+}
+
src_compile() {
econf --with-ncurses || die "configure failed"
}
diff --git a/dev-util/dialog/files/dialog-0.9_beta20031002-estonian-sed.patch b/dev-util/dialog/files/dialog-0.9_beta20031002-estonian-sed.patch
new file mode 100644
index 000000000000..80131b13a292
--- /dev/null
+++ b/dev-util/dialog/files/dialog-0.9_beta20031002-estonian-sed.patch
@@ -0,0 +1,137 @@
+--- configure.orig 2003-09-10 16:16:06.000000000 -0700
++++ configure 2004-01-16 03:58:43.000000000 -0800
+@@ -65,7 +65,7 @@
+ fi
+
+ case "$ac_option" in
+- -*=*) ac_optarg=`echo "$ac_option" | sed 's/[-_a-zA-Z0-9]*=//'` ;;
++ -*=*) ac_optarg=`echo "$ac_option" | sed 's/[-_[:alnum:]]*=//'` ;;
+ *) ac_optarg= ;;
+ esac
+
+@@ -99,7 +99,7 @@
+ -disable-* | --disable-*)
+ ac_feature=`echo $ac_option|sed -e 's/-*disable-//'`
+ # Reject names that are not valid shell variable names.
+- if test -n "`echo $ac_feature| sed 's/[-a-zA-Z0-9_]//g'`"; then
++ if test -n "`echo $ac_feature| sed 's/[-[:alnum:]_]//g'`"; then
+ { echo "configure: error: $ac_feature: invalid feature name" 1>&2; exit 1; }
+ fi
+ ac_feature=`echo $ac_feature| sed 's/-/_/g'`
+@@ -108,7 +108,7 @@
+ -enable-* | --enable-*)
+ ac_feature=`echo $ac_option|sed -e 's/-*enable-//' -e 's/=.*//'`
+ # Reject names that are not valid shell variable names.
+- if test -n "`echo $ac_feature| sed 's/[-_a-zA-Z0-9]//g'`"; then
++ if test -n "`echo $ac_feature| sed 's/[-_[:alnum:]]//g'`"; then
+ { echo "configure: error: $ac_feature: invalid feature name" 1>&2; exit 1; }
+ fi
+ ac_feature=`echo $ac_feature| sed 's/-/_/g'`
+@@ -357,7 +357,7 @@
+ -with-* | --with-*)
+ ac_package=`echo $ac_option|sed -e 's/-*with-//' -e 's/=.*//'`
+ # Reject names that are not valid shell variable names.
+- if test -n "`echo $ac_package| sed 's/[-_a-zA-Z0-9]//g'`"; then
++ if test -n "`echo $ac_package| sed 's/[-_[:alnum:]]//g'`"; then
+ { echo "configure: error: $ac_package: invalid package name" 1>&2; exit 1; }
+ fi
+ ac_package=`echo $ac_package| sed 's/-/_/g'`
+@@ -370,7 +370,7 @@
+ -without-* | --without-*)
+ ac_package=`echo $ac_option|sed -e 's/-*without-//'`
+ # Reject names that are not valid shell variable names.
+- if test -n "`echo $ac_package| sed 's/[-a-zA-Z0-9_]//g'`"; then
++ if test -n "`echo $ac_package| sed 's/[-[:alnum:]_]//g'`"; then
+ { echo "configure: error: $ac_package: invalid package name" 1>&2; exit 1; }
+ fi
+ ac_package=`echo $ac_package| sed 's/-/_/g'`
+@@ -398,7 +398,7 @@
+ ;;
+
+ *)
+- if test -n "`echo $ac_option| sed 's/[-a-z0-9.]//g'`"; then
++ if test -n "`echo $ac_option| sed 's/[-[:lower:][:digit:].]//g'`"; then
+ echo "configure: warning: $ac_option: invalid host type" 1>&2
+ fi
+ if test "x$nonopt" != xNONE; then
+@@ -1478,7 +1478,7 @@
+ if test "$GCC" = yes ; then
+ echo $ac_n "checking version of $CC""... $ac_c" 1>&6
+ echo "configure:1481: checking version of $CC" >&5
+- GCC_VERSION="`${CC} --version|sed -e '2,$d' -e 's/^[^0-9.]*//' -e 's/[^0-9.].*//'`"
++ GCC_VERSION="`${CC} --version|sed -e '2,$d' -e 's/^[^[:digit:].]*//' -e 's/[^[:digit:].].*//'`"
+ test -z "$GCC_VERSION" && GCC_VERSION=unknown
+ echo "$ac_t""$GCC_VERSION" 1>&6
+ fi
+@@ -1773,7 +1773,7 @@
+ #endif
+ EOF
+ if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
+- egrep "(^|[^a-zA-Z_0-9])off_t[^a-zA-Z_0-9]" >/dev/null 2>&1; then
++ egrep "(^|[^[:alpha:]_[:digit:]])off_t[^[:alpha:]_[:digit:]]" >/dev/null 2>&1; then
+ rm -rf conftest*
+ ac_cv_type_off_t=yes
+ else
+@@ -1806,7 +1806,7 @@
+ #endif
+ EOF
+ if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
+- egrep "(^|[^a-zA-Z_0-9])size_t[^a-zA-Z_0-9]" >/dev/null 2>&1; then
++ egrep "(^|[^[:alpha:]_[:digit:]])size_t[^[:alpha:]_[:digit:]]" >/dev/null 2>&1; then
+ rm -rf conftest*
+ ac_cv_type_size_t=yes
+ else
+@@ -3195,10 +3195,10 @@
+ else
+ echo $ac_n "checking version of bison""... $ac_c" 1>&6
+ echo "configure:3198: checking version of bison" >&5
+- ac_prog_version=`$INTLBISON --version 2>&1 | sed -n 's/^.*GNU Bison.* \([0-9]*\.[0-9.]*\).*$/\1/p'`
++ ac_prog_version=`$INTLBISON --version 2>&1 | sed -n 's/^.*GNU Bison.* \([[:digit:]]*\.[[:digit:].]*\).*$/\1/p'`
+ case $ac_prog_version in
+ '') ac_prog_version="v. ?.??, bad"; ac_verc_fail=yes;;
+- 1.2[6-9]* | 1.[3-9][0-9]* | [2-9].*)
++ 1.2[6-9]* | 1.[3-9][[:digit:]]* | [2-9].*)
+ ac_prog_version="$ac_prog_version, ok"; ac_verc_fail=no;;
+ *) ac_prog_version="$ac_prog_version, bad"; ac_verc_fail=yes;;
+ esac
+@@ -3512,7 +3512,7 @@
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+- ac_tr_lib=HAVE_LIB`echo dbmalloc | sed -e 's/[^a-zA-Z0-9_]/_/g' \
++ ac_tr_lib=HAVE_LIB`echo dbmalloc | sed -e 's/[^[:alnum:]_]/_/g' \
+ -e 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
+ cat >> confdefs.h <<EOF
+ #define $ac_tr_lib 1
+@@ -3575,7 +3575,7 @@
+ fi
+ if eval "test \"`echo '$ac_cv_lib_'$ac_lib_var`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+- ac_tr_lib=HAVE_LIB`echo dmalloc | sed -e 's/[^a-zA-Z0-9_]/_/g' \
++ ac_tr_lib=HAVE_LIB`echo dmalloc | sed -e 's/[^[:alnum:]_]/_/g' \
+ -e 'y/abcdefghijklmnopqrstuvwxyz/ABCDEFGHIJKLMNOPQRSTUVWXYZ/'`
+ cat >> confdefs.h <<EOF
+ #define $ac_tr_lib 1
+@@ -3681,7 +3681,7 @@
+ ;;
+ ..|./*|.\\*) #(vi
+ ;;
+-.[a-zA-Z]:[\\/]*) #(vi OS/2 EMX
++.[[:alpha:]]:[\\/]*) #(vi OS/2 EMX
+ ;;
+ .\${*prefix}*) #(vi
+ eval withval="$withval"
+@@ -6228,11 +6228,11 @@
+ # turns \\\\ into \\, and sed turns \\ into \).
+ sed -n \
+ -e "s/'/'\\\\''/g" \
+- -e "s/^\\([a-zA-Z0-9_]*_cv_[a-zA-Z0-9_]*\\)=\\(.*\\)/\\1=\${\\1='\\2'}/p"
++ -e "s/^\\([[:alnum:]_]*_cv_[[:alnum:]_]*\\)=\\(.*\\)/\\1=\${\\1='\\2'}/p"
+ ;;
+ *)
+ # `set' quotes correctly as required by POSIX, so do not add quotes.
+- sed -n -e 's/^\([a-zA-Z0-9_]*_cv_[a-zA-Z0-9_]*\)=\(.*\)/\1=${\1=\2}/p'
++ sed -n -e 's/^\([[:alnum:]_]*_cv_[[:alnum:]_]*\)=\(.*\)/\1=${\1=\2}/p'
+ ;;
+ esac >> confcache
+ if cmp -s $cache_file confcache; then