summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-02-16 16:05:02 +0000
committerAron Griffis <agriffis@gentoo.org>2002-02-16 16:05:02 +0000
commit633ab44eccb4c649f5f3255e81b2b336ead30da0 (patch)
tree66245eb58a2369e14f5644ff1e3c25ddf061085b /dev-util
parentadded missing init script (diff)
downloadhistorical-633ab44eccb4c649f5f3255e81b2b336ead30da0.tar.gz
historical-633ab44eccb4c649f5f3255e81b2b336ead30da0.tar.bz2
historical-633ab44eccb4c649f5f3255e81b2b336ead30da0.zip
Fixed problem of installing outside of sandbox
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/devhelp/devhelp-0.3-r1.ebuild61
-rw-r--r--dev-util/devhelp/files/digest-devhelp-0.3-r11
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-util/devhelp/devhelp-0.3-r1.ebuild b/dev-util/devhelp/devhelp-0.3-r1.ebuild
new file mode 100644
index 000000000000..6446b770326d
--- /dev/null
+++ b/dev-util/devhelp/devhelp-0.3-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Mikael Hallendal <micke@hallendal.net>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/devhelp/devhelp-0.3-r1.ebuild,v 1.1 2002/02/16 16:05:02 agriffis Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Developer help browser"
+SRC_URI="http://devhelp.codefactory.se/download/${P}.tar.gz"
+HOMEPAGE="http://devhelp.codefactory.se/"
+
+RDEPEND=">=gnome-base/gnome-libs-1.2.8
+ >=gnome-base/ORBit-0.5.10-r1
+ >=gnome-base/bonobo-1.0.9-r1
+ >=gnome-base/libglade-0.17-r1
+ >=dev-libs/libxml-1.8.15
+ >=gnome-extra/gtkhtml-0.10.0
+ >=gnome-base/gconf-1.0.4-r2
+ >=gnome-base/gnome-vfs-1.0.2-r1
+ >=gnome-base/oaf-0.6.6-r1
+ >=gnome-base/gnome-print-0.30"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ >=dev-util/intltool-0.11"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --disable-more-warnings \
+ --disable-install-schemas \
+ --without-python $myconf || die
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog README NEWS TODO
+}
+
+pkg_postinst() {
+ # This is directly from the rpm specfile for devhelp...
+ # Fix gconf permissions
+ killall gconfd-1 2>/dev/null >/dev/null
+ chmod o+rX /etc/gconf -R
+ # Install schemas
+ gconftool-1 --shutdown
+ SOURCE=xml::/etc/gconf/gconf.xml.defaults
+ GCONF_CONFIG_SOURCE=$SOURCE \
+ gconftool-1 --makefile-install-rule \
+ /etc/gconf/schemas/devhelp.schemas \
+ # 2>/dev/null >/dev/null || exit 1
+ assert "gconftool-1 execution failed"
+}
diff --git a/dev-util/devhelp/files/digest-devhelp-0.3-r1 b/dev-util/devhelp/files/digest-devhelp-0.3-r1
new file mode 100644
index 000000000000..88d6e5972815
--- /dev/null
+++ b/dev-util/devhelp/files/digest-devhelp-0.3-r1
@@ -0,0 +1 @@
+MD5 1d7fd20f9b4eec86242a71def64cd766 devhelp-0.3.tar.gz 367683