summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-01-09 02:39:34 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-01-09 02:39:34 +0000
commitc924bf606dd4a387942671bc52e8f572358a6644 (patch)
tree0891f13c93dda71ab60d981806154353ae1f45a0 /dev-util/pkgcore-checks/pkgcore-checks-0.4.13.ebuild
parentBump (diff)
downloadhistorical-c924bf606dd4a387942671bc52e8f572358a6644.tar.gz
historical-c924bf606dd4a387942671bc52e8f572358a6644.tar.bz2
historical-c924bf606dd4a387942671bc52e8f572358a6644.zip
Bump
Package-Manager: portage-2.2_rc61/cvs/Linux x86_64
Diffstat (limited to 'dev-util/pkgcore-checks/pkgcore-checks-0.4.13.ebuild')
-rw-r--r--dev-util/pkgcore-checks/pkgcore-checks-0.4.13.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/pkgcore-checks/pkgcore-checks-0.4.13.ebuild b/dev-util/pkgcore-checks/pkgcore-checks-0.4.13.ebuild
new file mode 100644
index 000000000000..9deec9da08bf
--- /dev/null
+++ b/dev-util/pkgcore-checks/pkgcore-checks-0.4.13.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgcore-checks/pkgcore-checks-0.4.13.ebuild,v 1.1 2010/01/09 02:39:34 patrick Exp $
+
+inherit distutils
+
+DESCRIPTION="pkgcore developmental repoman replacement"
+HOMEPAGE="http://www.pkgcore.org/"
+SRC_URI="http://www.pkgcore.org/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/pkgcore-0.5.9
+ >=dev-python/snakeoil-0.3.6
+ >=dev-lang/python-2.4"
+DEPEND="${RDEPEND}"
+
+DOCS="NEWS AUTHORS"
+
+PYTHON_MODNAME=pkgcore_checks
+
+src_test() {
+ "${python}" setup.py test || die "tests returned non zero"
+}
+
+pkg_postinst() {
+ einfo "updating pkgcore plugin cache"
+ pplugincache pkgcore_checks.plugins pkgcore.plugins
+ distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ python_version
+ # Careful not to remove this on up/downgrades.
+ local sitep="${ROOT}"usr/lib/python${PYVER}/site-packages
+ if [[ -e "${sitep}/pkgcore_checks/plugins/plugincache2" ]] &&
+ ! [[ -e "${sitep}/pkgcore_checks/base.py" ]]; then
+ rm "${sitep}/pkgcore_checks/plugins/plugincache2"
+ fi
+ distutils_pkg_postrm
+}