summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-01-10 23:24:07 +0000
committerMike Frysinger <vapier@gentoo.org>2009-01-10 23:24:07 +0000
commit391cd6ad451a421345b63e0d21b3b67d696a0417 (patch)
treeaf36c8e8136b710af99e86045731f4b06ed67fcd /dev-util/mingw-runtime
parentversion bump, fixes bug 223239 and 245465 (diff)
downloadhistorical-391cd6ad451a421345b63e0d21b3b67d696a0417.tar.gz
historical-391cd6ad451a421345b63e0d21b3b67d696a0417.tar.bz2
historical-391cd6ad451a421345b63e0d21b3b67d696a0417.zip
old
Diffstat (limited to 'dev-util/mingw-runtime')
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-3.14.ebuild80
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-3.15.ebuild81
2 files changed, 0 insertions, 161 deletions
diff --git a/dev-util/mingw-runtime/mingw-runtime-3.14.ebuild b/dev-util/mingw-runtime/mingw-runtime-3.14.ebuild
deleted file mode 100644
index a073660b7b4e..000000000000
--- a/dev-util/mingw-runtime/mingw-runtime-3.14.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/mingw-runtime-3.14.ebuild,v 1.2 2008/07/02 21:49:29 vapier Exp $
-
-# This version does not work as the configure script expects the installed
-# cross-compiler to be able to link binaries ... except we haven't provided
-# any of the crt objects yet so it is impossible to link binaries.
-# Older mingw-runtime packages hacked around the issue, but this version seems
-# to have dropped said hack thus breaking the package.
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-inherit eutils flag-o-matic
-
-DESCRIPTION="Free Win32 runtime and import library definitions"
-HOMEPAGE="http://www.mingw.org/"
-SRC_URI="mirror://sourceforge/mingw/${PN}-${PV/_p/-}-src.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="crosscompile_opts_headers-only"
-RESTRICT="strip"
-
-DEPEND=""
-
-S=${WORKDIR}/${PN}-${PV%_p*}
-
-is_crosscompile() {
- [[ ${CHOST} != ${CTARGET} ]]
-}
-just_headers() {
- use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
-}
-
-pkg_setup() {
- if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
- die "Invalid configuration"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e "/W32API_INCLUDE/s:=.*:='-I /usr/${CTARGET}/usr/include':" \
- $(find -name configure) || die
- epatch "${FILESDIR}"/${PN}-3.12-DESTDIR.patch
-}
-
-src_compile() {
- just_headers && return 0
-
- CHOST=${CTARGET} strip-unsupported-flags
- econf --host=${CTARGET} || die
- emake || die
-}
-
-src_install() {
- if just_headers ; then
- insinto /usr/${CTARGET}/usr/include
- doins -r include/* || die
- else
- local insdir
- is_crosscompile \
- && insdir=${D}/usr/${CTARGET} \
- || insdir=${D}
- emake install DESTDIR="${insdir}" || die
- env -uRESTRICT CHOST=${CTARGET} prepallstrip
- rm -rf "${insdir}"/usr/doc
- dodoc CONTRIBUTORS ChangeLog README TODO readme.txt
- fi
- is_crosscompile && dosym usr /usr/${CTARGET}/mingw
-}
diff --git a/dev-util/mingw-runtime/mingw-runtime-3.15.ebuild b/dev-util/mingw-runtime/mingw-runtime-3.15.ebuild
deleted file mode 100644
index e7462a950aa9..000000000000
--- a/dev-util/mingw-runtime/mingw-runtime-3.15.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/mingw-runtime-3.15.ebuild,v 1.1 2008/09/08 02:50:42 vapier Exp $
-
-# This version does not work as the configure script expects the installed
-# cross-compiler to be able to link binaries ... except we haven't provided
-# any of the crt objects yet so it is impossible to link binaries.
-# Older mingw-runtime packages hacked around the issue, but this version seems
-# to have dropped said hack thus breaking the package.
-
-export CBUILD=${CBUILD:-${CHOST}}
-export CTARGET=${CTARGET:-${CHOST}}
-if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
- fi
-fi
-
-inherit eutils flag-o-matic
-
-MY_P="mingwrt-${PV}-mingw32"
-DESCRIPTION="Free Win32 runtime and import library definitions"
-HOMEPAGE="http://www.mingw.org/"
-SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="crosscompile_opts_headers-only"
-RESTRICT="strip"
-
-DEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-is_crosscompile() {
- [[ ${CHOST} != ${CTARGET} ]]
-}
-just_headers() {
- use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
-}
-
-pkg_setup() {
- if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
- die "Invalid configuration"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i \
- -e "/W32API_INCLUDE/s:=.*:='-I /usr/${CTARGET}/usr/include':" \
- $(find -name configure) || die
- epatch "${FILESDIR}"/${PN}-3.12-DESTDIR.patch
-}
-
-src_compile() {
- just_headers && return 0
-
- CHOST=${CTARGET} strip-unsupported-flags
- econf --host=${CTARGET} || die
- emake || die
-}
-
-src_install() {
- if just_headers ; then
- insinto /usr/${CTARGET}/usr/include
- doins -r include/* || die
- else
- local insdir
- is_crosscompile \
- && insdir=${D}/usr/${CTARGET} \
- || insdir=${D}
- emake install DESTDIR="${insdir}" || die
- env -uRESTRICT CHOST=${CTARGET} prepallstrip
- rm -rf "${insdir}"/usr/doc
- dodoc CONTRIBUTORS ChangeLog README TODO readme.txt
- fi
- is_crosscompile && dosym usr /usr/${CTARGET}/mingw
-}